locked
can't edit doc. properties - error Failed to get value of the "Approval Status" column from the "Moderation Status" field ty RRS feed

  • Question

  • We're having an issue in a document library where if you attempt to edit a document's properties the following error occurs:

     

    Failed to get value of the "Approval Status" column from the "Moderation Status" field type control.  See details in log. Exception message: Input string was not in a correct format

     

    There is no significant information in the log. 

     

    A seperate new document library created on the same site does not have the issue.

     

    The owners of the site think this particular document library may have been originally created in SharePoint 2003 but can't remember for sure (we are now MOSS 2007).  I came on after the upgrade of all sites so I don't know for sure either.

     

    Research hasn't let me to a solution yet.  I've tried turning off Workflow, Versioning and Approval, and turning it back on but it did not resolve the problem.  I'm new to SharePoint and primiarly focused on server Administraton, not sites and their design.

     

    Also, noticed on the bad document library, when Editing the document properties, the Approval Status is visible, with choices like: 0;#Approved.  Selecting a choice doesn't help.  But on the new good document library, the Approval Status field is not visible when Editing the document properties.

     

    If anyone could shead some light on this issue it would be most appreciated.

     

     

     

    • Moved by Mike Walsh FIN Thursday, October 16, 2008 4:52 AM wrong forum (Moved from SharePoint - Workflow to SharePoint - Setup, Upgrade, Administration and Operation)
    Friday, November 16, 2007 9:51 PM

Answers

  • Ok - I ran into this problem too.  It hit all my lists from the previous version of sharepoint.  Something must have changes with the latest fixes from MS - because they were working properly a month ago.

    In any case, I did find a fix.  I got Sharepoint Manager 2007 from here:

    http://www.sharepointblogs.com/keutmann/archive/2007/01/27/sharepoint-manager-2007-update.aspx

    Turned on full object model view

    Went to each list that was bad and changed the Approval Status field to hidden, then saved.

     

    Everything seems to work properly now.  Hope that helps someone else.

     

    Saturday, December 8, 2007 4:52 AM

All replies

  • I am encountering this exact issue.

    First of all, the reason for the error occuring is due to the Approval Status field appearing on the edit document properties form, and containing the incorrect value 0;#Approved. I believe this is how the Name/Value pair is stored (most likely in an XML file).

    In an attempt to investigate a workaround, we created a new Document Library within the same site, and it all worked fine, until we copied a document from the "corrupt" Document Library. The issue then began appearing in an identical fashion in the newly created Document Library?

    One workaround is to utilise the Office Integration, and edit the document properties from within the Office Application associated with the document. This is not a solution to the problem though, so any further information would be most greatly appreciated.
    Sunday, November 18, 2007 10:55 PM
  • Thanks for the info, nice to know at least I'm not alone with the problem!

     

    Still need to find a solid solution though.  As you said the Office Integration isn't a solution to the problem, and for us isn't something the company wants to utilize.

     

    I had the same results as you, a new library didn't have the problem.  I tried even updating the Forms but no luck there either.  I don't want my users to have to recreate everything in a new library.

     

    Monday, November 19, 2007 9:39 PM
  • This problem appeared after we upgraded from v2. I tried disabling and re-enabling the approval settings on the list, no dice.

    It looks like I'm going to have to recreate the list and migrate the data (in my case it's a Event list/calendar that's causing the problem). Ugh.


    I'll also note that this is a large list (>1000 items) so that may have something to do with the root cause.
    Wednesday, November 21, 2007 8:53 PM
  • Our implementation is an upgrade from v2.

    The Document Library in question currently has approx. 750 documents.

    I also tried disabling and re-enabling the Approval process without any success.

    I am trying to replicate the issue in another Document Library, but have not had any luck yet? I have recreated the environment on a testing server, using a backup of the content database, so that I can investigate without causing further problems. I created a new Document Library, and using the Folder View, moved the files out of the "broken" Document Library into the new Library. The issue did not appear in the new library (contrary to what I posted earlier). The old library still has the problem field?
    Thursday, November 22, 2007 4:25 AM
  • Ok - I ran into this problem too.  It hit all my lists from the previous version of sharepoint.  Something must have changes with the latest fixes from MS - because they were working properly a month ago.

    In any case, I did find a fix.  I got Sharepoint Manager 2007 from here:

    http://www.sharepointblogs.com/keutmann/archive/2007/01/27/sharepoint-manager-2007-update.aspx

    Turned on full object model view

    Went to each list that was bad and changed the Approval Status field to hidden, then saved.

     

    Everything seems to work properly now.  Hope that helps someone else.

     

    Saturday, December 8, 2007 4:52 AM
  • Thank you so very much for posting your solution. 

     

    It worked perfectly!!!!!

     

     

     

    Monday, December 10, 2007 5:36 PM
  • Thank you kindly for pointing us to the SharePoint Manager 2007 application.

    Initially when I ran the exe, nothing happened, however upon killing the process and trying later (and waiting) the application finally popped up and worked perfectly!

    Many thanks!
    Wednesday, December 19, 2007 4:05 AM
  • Can this be done with Sharepoint Designer?

     

    Tuesday, January 15, 2008 2:39 PM
  • Sorry, no. If you're not the farm administrator, you're going to have to enlist their assistance to get this fixed; SharePoint Designer can't fix this.

     

    Tuesday, January 15, 2008 3:07 PM
  • I had the same problem.

    It worked for me and solved the issue.

    Thanks

    Farzin

    Thursday, April 17, 2008 7:53 PM
  • awesome! Thanks!
    Wednesday, October 15, 2008 11:25 PM
  • I've read through this entire thread and failed completely to see the connection to the Workflow forum.

    Moving to Admin.
    Thursday, October 16, 2008 4:51 AM
  • Thank you, thank you , thank you.  How many times have a run into this issue, without finally saying thanks for the post.
    Wednesday, July 21, 2010 6:43 PM