locked
files missing from document library in sharepoint 2013 RRS feed

  • Question

  • My problem is a bit different from all the posts out there. while in essence it is similar. Users reported that uploaded files disappeared from the library. no one can see them including me with full control on the site collection. if I access the document library with explorer view I can see the folder structure with the files. 

    a lot of posts suggest that the files are checked out and I need to check them back in. the only difference is i don't have the "require files to be checked out before they can be edited" also when I go to "manage files which have no checked in version" I see an empty list. there is no files to check in. 

    how to get the files to be seen in the document library. 

    Monday, February 29, 2016 2:04 PM

All replies

  • Do you have a view configured that is hiding the files?
    Monday, February 29, 2016 2:25 PM
  • On the same lines as Alex mentioned.

    You could also go to the "All Site Content" and check the Item count and Last Modified for your library

    Monday, February 29, 2016 7:22 PM
  • Item count is 0, although I can see the files in explorer view. and last modified is 20 hours ago.

    Alex Brassington, I don't power view installed or configured. if your talking about a different view please let me know.

    time difference is responsible for delayed response. 


    Tuesday, March 1, 2016 10:15 AM
  • Not power view but SharePoint list views. They let you order, sort, filter or group your data based on setting you provide. It is possible to create a view that hides some of your documents.

    Try to re-create the issue. Using the browser upload a file, then confirm it exists with the browser and with Explorer view.

    Then try with adding a file with explorer view and repeat the tests.

    Let us know the results.

    Tuesday, March 1, 2016 1:18 PM
  • I dragged some files both to explorer view and to the site. let me see if the turn disappearing. I'll keep you updated. mean while one of the site admins has installed share point designer and he was testing with some views. he is checking that as well.
    Tuesday, March 1, 2016 2:22 PM