locked
WSUS clients do not find and download updates RRS feed

  • Question

  • Hi,I have about 150 WSUS clients, running Windows 7 Pro x64. About half of them have 20 or so updates pending, even though the updates are regularly approved and the clients are set to download/install every night at 11:00 p.m. The GPO looks to be right, remember the other half of WSUS clients are reporting no needed updates, so it is working for them. The WindowsUpdate.log file shows zero updates detected when I am certain there are some available.

    This is what happens at 11

    2015-05-12    23:00:10:145     808    7f4    AU    Forced install timer expired for AUInstallType = 4
    2015-05-12    23:00:10:145     808    7f4    AU    UpdateDownloadProperties: 0 download(s) are still in progress.
    2015-05-12    23:00:10:145     808    7f4    AU    Setting AU scheduled install time to 2015-05-14 03:00:00
    2015-05-12    23:00:10:145     808    7f4    AU    Successfully wrote event for AU health state:0

    Then is starts logging again at around 1:30 a.m. There is one error at the bottom of the log.

    2015-05-13    10:19:38:117     796    16dc    AUClnt    WARNING: Shell_NotifyIcon failed (dwMessage=0x0, uFlags=0x7, hr=0x800703F0)
    2015-05-13    10:19:38:117     796    16dc    AUClnt    WARNING: Shell_NotifyIcon failed (dwMessage=0x0, uFlags=0x7, hr=0x800703F0)
    2015-05-13    10:19:38:117     796    16dc    AUClnt    WARNING: Shell_NotifyIcon failed (dwMessage=0x0, uFlags=0x7, hr=0x800703F0)
    2015-05-13    10:19:38:117     796    16dc    AUClnt    WARNING: Shell_NotifyIcon failed (dwMessage=0x0, uFlags=0x7, hr=0x800703F0)
    2015-05-13    10:19:38:120     808    7f4    AU    AU received handle event
    2015-05-13    10:19:38:120     808    7f4    AU    AU setting pending client directive to 'Install Approval'

    Not sure what that means. Does anyone have any idea. Many thanks in advance.


    Jason

    Wednesday, May 13, 2015 2:45 PM

All replies

  • Hi

     You can install wsus client diagnostic tool on a client;and check the logs;

    download WSUS Client Dİagnostic Tool;

    http://www.microsoft.com/en-us/download/details.aspx?id=30827x

    Also check some of the updates dependes to another update install before,

    And you can test these steps one of a client;(for client succesfully connect to wsus)

    wuauclt /detectnow

    Wednesday, May 13, 2015 3:15 PM
  • That tool sounds great, but the link gives me a "page not found." I'll run the wuauclt /detectnow command on my affected clients.

    Jason

    Wednesday, May 13, 2015 3:41 PM
  • That linked worked! Thanks.

    The client passed the three tests, but the program threw an error and I am not sure if it is an error with my WSUS client, or with the program itself.

    The error: 

    GetFileVersion(szEngineDir,&susVersion) failed with hr=0x80070002

    The system cannot find the file specified.


    Jason

    Wednesday, May 13, 2015 4:04 PM
  • I looked up the 0x80070002 error and that lead me to a page that has a Microsoft "fix-it." I ran the fix-it and it came back when then another error, 0x80070005. That is a permissions error on the registry and is resulting, in this case, from the Domain Users group being a member of the local Guests group. I removed them from Guests and rebooted.

    Jason

    Wednesday, May 13, 2015 4:30 PM
  • Hi

     Please run"wuauclt /resetauthorization /detectnow" on the client.Inspect the Windowsupdateilog after a couple of minutes to ensure the correct target group has been recorded in the "initializing simple targeting cookie"log entry,then check the WSUS admin console after 30 minutes for the client status report.

    Wednesday, May 13, 2015 4:57 PM
  • did you use local WSUS server and proxy-server?

    Set checkbox "Bypass proxy server for local addresses."


    Thursday, May 14, 2015 12:53 PM
  • The WSUS server is not behind a proxy. I 've been re-imaging the affected machines and removing them from the WSUS server before the imaging process completes. That's been working for right now.

    Jason

    Thursday, June 18, 2015 6:49 PM