none
Display Entries instead of "View Entries" option in multiple-line text column in Sharepoint online

    Question

  • Hi,

    Is it possible in Sharepoint online to create or modify a list view, that instead of showing "View Entries" in multiple-line text column with append-only checked, will show all entries for that element, so user will not have to click it and open every element, every time he needs to read comments?

    regards,

    Marek

    Tuesday, March 7, 2017 11:07 AM

All replies

  • Hi Marek,

    By default, when append-only is checked for multiple-line text column, it will show “View entries” in multiple-line text column.

    There are some methods to get rid of “View entries” in multiple-line text column.

    1. You could customize the data view web part to display the value of the append-only multiple-line text column.

    For more detailed information, refer to the article below.

    Get rid of ‘View Entries’ in a SharePoint 2013 Append-Only Column in a View.

    https://www.brightwork.com/blog/show-content-sharepoint-2013-append-rtf-column-view#.WL9yLeS7pes

    2. You could create two multiple-line text columns, check the append-only for one multiple-line text column and uncheck the append-only for another multiple-line text column.

    Then create the workflow to copy value from one multiple-line text column and another multiple-line text column.

    For more detailed information, refer to the article below.

    Show the most recent comment from SharePoint text fields instead of “view items”.

    http://officepowerups.com/2013/06/25/sharepoint-show-most-recent-comment/

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, March 8, 2017 3:46 AM
    Moderator
  • Hello Sara,

    Unfortunately option 1. so far doesn't work for me (option with workflow won't be accepted as solution). I don't have " “td class=”ms-vb” " section in my test_view.aspx file. I have found <xsl:template ...... , section for my append only column and have tried changing lines that include " disable-output-escaping="yes" ",but with no luck. It is of course possible, that I'm simply doing something wrong. First difference is that when I create new View as in Instruction, It's not empty - It already contains all columns from my list, so I don't need to add them or data source (I'm just pointing it out, not sure If it matters).

    As I mentioned before - It's Sharepoint Online.

    And I'm using SPD2013.

    Monday, March 20, 2017 3:13 PM