none
Hyper-V switch changes to internal automagically RRS feed

  • Question

  • I have a 2012R2 server running Hyper-V.    Everything has been running just fine until I arrived this morning to find one of the VMs on the system not talking on the network.    Turns out the web server VM has a hard coded address of 172.16.0.111 but is not communicating.   Further investigation unearthed the fact that the ONLY VSwitch on the host was set to "Internal".   HyperV failed to allow me to change this back to external.   Creating a new VSwitch for external access worked fine.   I moved all VM's onto this newly created External switch and all is fine.   Oddest part of this issue is that the original and only VSwitch was set to External and working fine until this morning.   

    I can get into details regarding hardwares, etc. but I wondered if anyone else had seen such behaviour.    The host has seen no changes in the past 10 days, patching etc. and was rebooted 10 days ago without issues.

    Wednesday, October 31, 2018 7:35 PM

All replies

  • Hi,

    Thanks for your question. 

    OK, I understand your current situation, now let's begin discussing this problem.

    I'm wondering of is there any error message when you changed the VM's network adapter from internal V-Sw to original external. Did this VM have a single NIC adapter previously?

    The problematic VM is that Web server VM with the ip 172.16.0.111? This IP is belong to internal or external?

    Highly appreciate your effort and time. If you have any question or concern, please feel free to let me know.

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Thursday, November 1, 2018 3:23 AM
    Moderator
  • Hi,

    How are things going on?

    Please feel free to let me know if you need further assistance.

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, November 5, 2018 2:38 PM
    Moderator