locked
Response group agent forwading. RRS feed

  • Question

  • Hi All,

    i have configured a Response Group. Its number is +21000
    there is a agent called "Operator" in this response group and when we
    call from the Outside we can here the message as "Thank you for calling
    abc company for operator press or say one" and when we press one the call
    comes to the Agent - Operator and can answer as well.

    But the customer requirement is to forward this call to a
    physical phone. which is used by the current operator. So i have forwarded the agent
    called "Operator" to that extension +22522 it shows as "calls
    are being forwaded to +22522" but once we call from outside it is not
    going to this extension and instead hold on music is playing.

    If we do call forwading using a normal lync client it works
    well.

    Thanks.


    Wednesday, March 7, 2012 4:50 PM

Answers

  • Hi,

    Thanks its working now. Issue was we were forwarding using the lync client, but it has to be done from the server (Response Group Queue) :D. This is the first experience with Response Group.

    Thanks 

    • Marked as answer by Ckanishka Thursday, March 8, 2012 11:37 AM
    Thursday, March 8, 2012 11:37 AM

All replies

  • Hi,

    I think you have to define the sip:+number@domain.com if you are trying to forward a call

    Have you tried this

    • To forward call to another telephone number, click Forward to telephone number, and then in the SIP addressfield, type the telephone number in the format sip:<number>@<domainname> (for example, sip:+13205550121@domain.com).
    • To forward call to another user, click Forward to SIP address, andthen in the SIP address field, type the URI for user in the format sip:<username>@<domainname>

    Have a look in to this it might help you http://technet.microsoft.com/en-us/library/gg412827.aspx and http://social.technet.microsoft.com/Forums/en-US/ocsclients/thread/8e0793e0-a837-441b-a058-06aba06e6f1e/ 

    Hope above helps


    If answer is helpful, please hit the green arrow on the left, or mark as answer. Salahuddin | Blogs:http://salahuddinkhatri.wordpress.com | MCITP Microsoft Lync

    Wednesday, March 7, 2012 9:19 PM
  • Hi,

    When i type that format it says "One or more selected contacts cannot receive your calls. Either the contact is outside of your organisation, is an automated service, or is not running your version of Lync" and i am unable to add the number.

    Thanks.

    Thursday, March 8, 2012 7:24 AM
  • is this operator enabled for lync. If yes then try to add username@domainname.com, when you do the call forwarding to any number it will forward doesn't matter that number is the sip uri of a user enabled for lync or not. but in response groups i believe you have to define those users numbers or sip accouts which are enabled for lync.

    If the user is not enabled for lync try to enable that user for lync and then try but s/he will only be able to receive call if there is sim ring is enabled on the IP PBX which is integrated with lync or if you using voice gateway directly integrated with lync or integtreated between lync and ip pbx then you have to enable sim ring on the gateway or your configuration should be like the same so that s/he will be able to receive call.

    Hope above make sens


    If answer is helpful, please hit the green arrow on the left, or mark as answer. Salahuddin | Blogs:http://salahuddinkhatri.wordpress.com | MCITP Microsoft Lync

    Thursday, March 8, 2012 8:15 AM
  • Also if this doesn't work try to forward a call to those users who are lync enabled once it is worked then i belive there is some thing you need to do let us try this first.

    If answer is helpful, please hit the green arrow on the left, or mark as answer. Salahuddin | Blogs:http://salahuddinkhatri.wordpress.com | MCITP Microsoft Lync

    Thursday, March 8, 2012 8:15 AM
  • Hi,

    Thanks its working now. Issue was we were forwarding using the lync client, but it has to be done from the server (Response Group Queue) :D. This is the first experience with Response Group.

    Thanks 

    • Marked as answer by Ckanishka Thursday, March 8, 2012 11:37 AM
    Thursday, March 8, 2012 11:37 AM