locked
Windows wakes from sleep everyday at 5:00PM RRS feed

  • Question

  •  

    For some reason my computer is waking from sleep automatically every day for about a week. The system log shows it happening at exactly 5:00PM and some seconds. When I check to see what the source is, using powercfg.exe -lastwake, it simply says "Fixed feautre". I can't recall something that I may have done recently to cause this. Any ideas what may be causing this, or any thing I can do more to investigate? Isn't "fixed feature" simply the device that will put the computer into sleep mode via a button? Are there magical PC gnomes hitting the power button on my keyboard at 5:00PM every day? Thanks
    Saturday, May 24, 2008 4:36 PM

Answers

  • Hello,

     

    I think this issue may be a little complex. Let’s try the following steps firstly:

     

    1.    Go to your computer’s website and download the latest BIOS update. Refer to the manufacturer’s instructions and update your BIOS via it.

    2.    Still in the Command Prompt window, type the following command-line:

    powercfg –devicequery wake_armed  (press Enter)

    The command will help you check which devices may wake the computer wake up.

    3.    In device manager, right-click the device listed in Step 2 and select Properties, switch to Power Management tab and clear the checkbox of Allow this device to wake the computer.

    4.    Check the task scheduler (Run “taskschd.msc”), if some task set wake your computer in certain times.

    Hope this helps!

    Regards,

    Lionel Chen

    Tuesday, May 27, 2008 2:23 AM
  • After some further investigation, I am now suspicious of the BIOS. I checked the APM settings in the BIOS. Everything is disabled from waking the computer, including the RTC. I did notice that I actually wasn't running the latest firmware, though the last time I believe I updated it was well before this problem started to occur. I updated to the latest revision. I'll see if this helps.

     

    The problem seems to be more random now. My computer woke at around 11:29 AM this time. Again, it showed the source being Fixed Feature - Timer Expired (RTC). From what I guess, Timer Expired makes it sound like that I have an RTC timer configured to wake the computer. I do see this feature in the BIOS, but like I mentioned, it has been disabled the entire time. I hope this newer firmware fixes it.

     

    Wednesday, May 28, 2008 10:27 PM

All replies

  • Might be evil gnomes - they wake my HP lappy (almost) every day at 8:00 pm.
    Check your Event Viewer > power logs, and look for the wakeup time.  See if it lists something meaningful for the wakeup cause.  Hopefully, you get more info than my "wake from unknown source" (AKA Evil Gnomes.")

    Saturday, May 24, 2008 9:32 PM
  • Hello,

     

    I think this issue may be a little complex. Let’s try the following steps firstly:

     

    1.    Go to your computer’s website and download the latest BIOS update. Refer to the manufacturer’s instructions and update your BIOS via it.

    2.    Still in the Command Prompt window, type the following command-line:

    powercfg –devicequery wake_armed  (press Enter)

    The command will help you check which devices may wake the computer wake up.

    3.    In device manager, right-click the device listed in Step 2 and select Properties, switch to Power Management tab and clear the checkbox of Allow this device to wake the computer.

    4.    Check the task scheduler (Run “taskschd.msc”), if some task set wake your computer in certain times.

    Hope this helps!

    Regards,

    Lionel Chen

    Tuesday, May 27, 2008 2:23 AM
    1. BIOS is already updated to latest. I am pretty sure that I updated it well before this behavior began (meaning I don't think the updated BIOS is causing it). My motherboard is an Asus P5E3 Premium.
    2. I ran this before and found two devices that could wake the computer. One was the mouse and the other was USB root hub. I disabled the mouse. The keyboard is connected to the PC via a Bluetooth USB device, which I assume is the "USB Root Hub" device. When I ran powercfg -lastwake after one of these mysterious awakining, it displayed the source as "Fixed Feature". When I run powercfg -lastwake after I hit the sleep button on my keyboard to wake the computer, it displays the source being the USB Root Hub.
    3. I had already checked the Task Scheduler. Being that it was happening at 5:00PM, it was my first inclination that there was some task created that was waking the computer from sleep. I found nothing.

    An update to this strange behavior...

     

    A couple days ago, while I was at home, I put my computer into sleep at about 4:50PM. The PC did not wake at 5:00PM that time. Instead it woke around 5:30PM.

     

    I'm almost about to restore my computer from a full PC backup that I made 2-3 weeks ago. I would prefer to find the solution, but this starting to get annoying. My restore would take me back to having to re-install several applications and a device driver, which I would rather avoid.

    Tuesday, May 27, 2008 3:56 PM
  • So I restored my computer from a full backup made earlier this month. I reinstalled the following software to get me back to my cujrrent config:

    • Unreal Tournament 3
    • Software Bisque Seeker (3D Solar System simulator)
    • HP TV Tuner USB device drivers (this is installed on another Vista computer that does not wake on its own)
    • Configured Media Center for my tuner
    • Latest Windows updates

    Now the computer returned from sleep around 2:41 AM last night, according to the event log. The source shows as RTC. I have enclosed the event log as well as the results of when I run powercfg.exe. Also, I ran the other powercfg.exe commands you mentioned, and again disabled the mouse because I do not want that to wake my computer in case it is accidentally bumped. I will see if my computer wakes on its own today.

     

    C:\Users\BMcGarvey>powercfg -devicequery wake_armed
    Logitech HID-Compliant Keyboard (001)

     

    C:\Users\BMcGarvey>powercfg.exe -lastwake

    Wake History Count - 1
    Wake History [0]
      Wake Source Count - 1
      Wake Source [0]
        Type: Fixed Feature
        Timer Expired (RTC)

    ---------------------------------------------------

    Log Name:      System
    Source:        Microsoft-Windows-Power-Troubleshooter
    Date:          5/28/2008 2:43:54 AM
    Event ID:      1
    Task Category: None
    Level:         Information
    Keywords:     
    User:          LOCAL SERVICE
    Computer:      BMcGarvey-PC
    Description:
    The system has resumed from sleep.

    Sleep Time: 5/28/2008 2:41:13 AM
    Wake Time: 5/28/2008 6:43:38 AM

    Wake Source: RTC
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Power-Troubleshooter" Guid="{cdc05e28-c449-49c6-b9d2-88cf761644df}" />
        <EventID>1</EventID>
        <Version>0</Version>
        <Level>4</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2008-05-28T06:43:54.716Z" />
        <EventRecordID>13719</EventRecordID>
        <Correlation ActivityID="{542105DA-F7D4-4394-B016-8FB0FC3A39E1}" />
        <Execution ProcessID="1848" ThreadID="11252" />
        <Channel>System</Channel>
        <Computer>BMcGarvey-PC</Computer>
        <Security UserID="S-1-5-19" />
      </System>
      <EventData>
        <Data Name="SleepTime">2008-05-28T02:41:13.722Z</Data>
        <Data Name="WakeTime">2008-05-28T06:43:38.359Z</Data>
        <Data Name="SleepDuration">23051</Data>
        <Data Name="WakeDuration">859</Data>
        <Data Name="DriverInitDuration">632</Data>
        <Data Name="BiosInitDuration">893</Data>
        <Data Name="HiberWriteDuration">0</Data>
        <Data Name="HiberReadDuration">0</Data>
        <Data Name="HiberPagesWritten">0</Data>
        <Data Name="Attributes">24834</Data>
        <Data Name="TargetState">4</Data>
        <Data Name="EffectiveState">4</Data>
        <Data Name="WakeSourceType">3</Data>
        <Data Name="WakeSourceTextLength">0</Data>
        <Data Name="WakeSourceText">
        </Data>
      </EventData>
    </Event>

     

    Wednesday, May 28, 2008 12:36 PM
  • After some further investigation, I am now suspicious of the BIOS. I checked the APM settings in the BIOS. Everything is disabled from waking the computer, including the RTC. I did notice that I actually wasn't running the latest firmware, though the last time I believe I updated it was well before this problem started to occur. I updated to the latest revision. I'll see if this helps.

     

    The problem seems to be more random now. My computer woke at around 11:29 AM this time. Again, it showed the source being Fixed Feature - Timer Expired (RTC). From what I guess, Timer Expired makes it sound like that I have an RTC timer configured to wake the computer. I do see this feature in the BIOS, but like I mentioned, it has been disabled the entire time. I hope this newer firmware fixes it.

     

    Wednesday, May 28, 2008 10:27 PM
  • Hi Brandon,

     

    Thanks for your updates on this issue. Based on my experience, many sleeping-wakeup issues are BIOS related.

     

    In this case, to confirm your conclusion, it’s recommended to contact the motherboard manufacturer to see if this is a known issue.

     

    Regards,

    Lionel Chen

     

    Thursday, May 29, 2008 4:13 AM
  • I think I may have resolved this issue. I reinstalled Windows completely and so far it seems like the wake event is not occuring anymore. The suspect is an HP USB TV Tuner. Either it be the driver or the software included it. Another computer that I installed this device on began doing the same thing. I was able to do a System Restore on that computer to a date prior to installing the device and that computer is no longer waking. I wish I knew a way to troubleshoot the issue a little better than having to resort to a reload of Windows. Strange that the device or software was able to access to the RTC timer, but I suppose anything is possible. I wonder where that information was stored. I even uninstalled the driver and all of the software but it continued to wake the computer. It took a reload to clear this up.

     

    Wednesday, June 4, 2008 10:43 PM
  • Hi,

    I have similar problems only that in my case the RTC (Realtime clock??) is involved and I do not know how to turn this off. I checked the BIOS, but there is not much there which could refer to this. My laptop is a brand new Sony Vaio VGN-SR15G

    Here is what the command line shows:

    Microsoft Windows [Version 6.0.6001]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\ioannis>powercfg -lastwake
    Wake History Count - 1
    Wake History [0]
      Wake Source Count - 1
      Wake Source [0]
        Type: Fixed Feature
        Timer Expired (RTC)

    C:\Users\ioannis>powercfg -devicequery wake_armed


    C:\Users\ioannis>

    The wakeup times from sleep and hibernation seem to be quite random to me. Any suggestions how to deal with this kind of problem? Is there a kill switch to prevent Vista from messing with any unsolicited powerconfig/wakeup?

    Thank you, Jannis
    Saturday, August 23, 2008 4:09 PM
  • My Vista PC has the same problem.  It wakes from sleep at various times for an unknown reason.  When I run powercfg lastwake, the source identified is timer expired (RTC).  After much difficulty, I had gotten my Vista PC sleep mode to function correctly.  Now this problem has arisen.  I have the power options set so that sleep should resume automatically after 5 minutes.  That does not happen. But I can put the PC into sleep state manually.  Unfortunately, it wakes up after some period of time with the soucre beith timer expired (RTC).  Can you tell me how to fix this so that my pc stays asleep until I wake it?  The only device armed to wake the pc is the keyboard

    Monday, September 15, 2008 2:34 PM
  • My problem was with a Hauuppauge USB TV tuner. Something in the software or drivers was causing my PC to wake every day. Simply uninstalling the software did nothing. I had to perform a System Restore on one computer back to a point prior to installing the TV tuner. On another PC, I had to reload Vista because I did not have a restore point. I no longer use the TV tuner.

     

    Many computers have the ability to configure an RTC wake timer in the BIOS. It was disabled on my motherboard, but somehow this software was accessing it by some other means.

     

    Monday, September 15, 2008 2:50 PM
  • I'm currently fighting this problem on one of two almost identical machines running Vista Ultimate. Guess what! The one with the problem had a Hauppauge Tuner card at a point in time. Call that a smoking gun!

     

    I'll return when I've found a way that does not involve just reinstalling the whole system.

    Sunday, September 28, 2008 4:24 PM
  • Same problem. Nearly new Dell, Vista SP1. Nothing has ever been connected except a PNY thumb drive and a pair of Medion speakers. It is connected to an APC 750 UPC. I only use this computer to run a trading platform and at the end of the day I shut it down. It won't stay in Sleep more than a few minutes. I blamed the backup and restore, the platform sweeping data, the internet, etc. I tried Dell, but they said to contact Microsoft!

    Thanks.

    Thursday, November 20, 2008 1:48 AM
  • Hi, I've got the same problems.

    My computer nearly every night starts at 03:00. (resumes from hibernation)

    I already disabled automatic windows updates and set them to 18:00.
    I set Windows Media Center not to download automatically, not to optimize automatically but set all times to 18.00 or something like that, before disabling the feature.
    I set defragmentation to wednesday 21:00.

    I don't think that my USB devices are responsible for the resume:

    powercfg lastwake
    Aktivierungsverlaufsanzahl - 1
    Aktivierungsverlauf [0]
      Aktivierungsquellenanzahl  - 0

    Maybe there's a solution for those who want, that their computers never wake up anymore (not even by planned tasks which are scheduled to wake up your system)

    1. Open a CMD prompt
    2. powercfg -setacvalueindex scheme_current sub_sleep bd3b718a-0680-4d9d-8ab2-e1d2b4ac806d 0
    3. powercfg -setdcvalueindex scheme_current sub_sleep bd3b718a-0680-4d9d-8ab2-e1d2b4ac806d 0
    4. powercfg -setactive scheme_current

    This changes and applies a new power scheme that stops the machine from being woken from sleep. 


    Another nice site I found:

    But I could not solve my problem, yet. I need wake up from sleep, but not at 3 o'clock in the night Wink

    Anyone has any new ideas to solve this problem?
    Sunday, November 30, 2008 10:46 AM
  • I have an HP slimline machine and had the same problem.
    Using the above recommended website, I managed to figure out all of the issues.

    Namely these were:
    Nvidia nForce 10/100 LAN - Disable wake on LAN
    Keyboard/Mouse - Verify they aren't affected by movement / light which could activate them
    Task Scheduler - Go through every task and verify that none of them have a 'wake up computer' condition
    In my case, Media Center Update would regularly try to update every morning causing the computer to come out of standby.
    Sunday, February 1, 2009 10:56 PM
  • After staring at the system logs for half an hour, I found podzeekins note above - 
     (Win7Ueval, Gigabyte x58UD5,F9e)
     
    The system details are not what is significant, however....in the system logs this may be the reason:

    The Kernel CEIP (Customer Experience Improvement Program) was set to run at 0330 weekly.  Other data gathering tasks for CEIP and some housekeeping tasks were set to run at other times and days.  This was a new install, and I do not recall setting any of them. 

     None of them were set to wake the machine, but the wake times roughly correspond to logged wake times.  The computer will not start itslef this way from shutdown, only from sleep.

    Saturday, September 19, 2009 2:50 PM
  • In my experience, the culprit is typically Media Center.  In Windows 7, disabling the automatic update can only be done temporarily via the Task Scheduler; it tends to reset the "wake from sleep" setting every time it runs.  You need to disable it in Media Center.

    In WinXP, you cannot disable the automatic update via the Task Scheduler; you have to disable the updates inside Media Center itself.  See this thread for details: How to prevent Media Center from waking the PC to update TV Guide

    This problem is the result of some terrible decision making on the part of Microsoft.  On my new Win7 machine, I don't even have a tuner, and have never run Media Center, but it still wants to update the TV Guide every night.

    Friday, April 9, 2010 6:37 PM
  • this was VERY helpful. something kept waking my computer up in the middle of the night and the process above allowed me to find it and stop it. thanks Lionel!!

     

    Sunday, May 22, 2011 3:39 PM