none
Project Published job takes long time to execute in PS2013 RRS feed

  • Question

  • Hello Team,

    Need your help!

    I have environment where 50 attribute including calculation field

    Server Config :

    2 web with 32 GB RAM and 2.27 GHz CPU 2 Core

    2 App with 32 Ram and 2.27 GHz CPU 2 Core

    1 DB  with 64 Ram and 2.27 GHz CPU 2 Core

    Published job takes more than 10 min to execute for 600 Line Project

    Could you please help to resolve to improve the performance.

    Thanks

    Wednesday, March 11, 2015 5:07 PM

Answers

  • EPM Admin, 

    Here are a few things I would check:

    1) Check if you have all the DB Maintenance Plans set. What was applicable for 2010 also applies for 2013. (Mainly having additional TempDbs, regular rebuilding of indexes, setting fill actor of 70%)

    2) Check the time taken for user synchronization with project Sites. In one of my environments this was the biggest culprit, especially if your model is to give every one access to every project site.

    3) Check the time taken for the "Task List Sync". If possible turn this off and test. Here are more details: Link 1Link 2

    4) Make sure the clocks on all servers are synced


    Cheers,

    Prasanna Adavi, Project MVP

    Blog:   Podcast:    Twitter:    LinkedIn:   

    • Marked as answer by Ashu_ Thursday, March 12, 2015 3:47 AM
    Wednesday, March 11, 2015 7:33 PM
    Moderator
  • Thanks for your response Prasanna !

    Step 3 has been work for me, i have run the command and that improve the publish jobs performance.

    Disable-SPProjectEnterpriseProjectTaskSync -Url http://servername/PWA/TestProject

    • Marked as answer by Ashu_ Thursday, March 12, 2015 3:51 AM
    Thursday, March 12, 2015 3:47 AM

All replies

  • Hi EPMAdmin,

    I would check initially the SQL Server (e.g. IOPS, db indexes etc.).

    Is your SQL Server environment shared with other applications?

    Paul

    Wednesday, March 11, 2015 5:48 PM
  • EPM Admin, 

    Here are a few things I would check:

    1) Check if you have all the DB Maintenance Plans set. What was applicable for 2010 also applies for 2013. (Mainly having additional TempDbs, regular rebuilding of indexes, setting fill actor of 70%)

    2) Check the time taken for user synchronization with project Sites. In one of my environments this was the biggest culprit, especially if your model is to give every one access to every project site.

    3) Check the time taken for the "Task List Sync". If possible turn this off and test. Here are more details: Link 1Link 2

    4) Make sure the clocks on all servers are synced


    Cheers,

    Prasanna Adavi, Project MVP

    Blog:   Podcast:    Twitter:    LinkedIn:   

    • Marked as answer by Ashu_ Thursday, March 12, 2015 3:47 AM
    Wednesday, March 11, 2015 7:33 PM
    Moderator
  • Thanks for your response Prasanna !

    Step 3 has been work for me, i have run the command and that improve the publish jobs performance.

    Disable-SPProjectEnterpriseProjectTaskSync -Url http://servername/PWA/TestProject

    • Marked as answer by Ashu_ Thursday, March 12, 2015 3:51 AM
    Thursday, March 12, 2015 3:47 AM