locked
S4B statues not changing consistantly RRS feed

  • Question

  • Been noticing a problem with some users where their S4B status does not change when they have a meeting in their Outlook calendar. I've got one user Win10 Office 2016 that their status never changes when they are in a meeting.

    I've deleted sip_username@domain .com already but did not fix the problem.

    I just did a test and the person who sent me the test meeting status did change 3 minutes after the meeting started my status didn't change until 18 minutes in.

    Again it's not consistent and not isolated to certain users.  Makes me thing it's server side.

    Any ideas?

    Wednesday, June 15, 2016 7:51 PM

Answers

  • Yes, of course. The Client will receive the Information through the EWS connect. Maybe it takes a while. You should do some tracing on the Client for the Webtraffic to EWS. maybe it exist some delay?

    regards Holger Technical Specialist UC

    • Marked as answer by Niko.Cheng Saturday, July 9, 2016 5:15 AM
    Friday, June 17, 2016 5:12 PM
  • 15 min used to be default refresh rate in Outlook which we manually used to edit it. Yes you can check the latency as Holger suggested .But looks like the update and Autodiscover correction fixed your issue.


    Linus

    • Marked as answer by Niko.Cheng Saturday, July 9, 2016 5:15 AM
    Friday, June 17, 2016 6:24 PM

All replies

  • Hi Milo 145,

    Please press Ctrl and right click Lync icon in the taskbar, open configuration information. On the open page check if EWS status and MAPI status are OK.

    Make sure your SFB server and client with the latest update.

    For your client side, please check if you set this configuration, personal---Update my presence based on my calendar information.

    For details, please refer to

    https://community.spiceworks.com/topic/278489-status-in-lync-does-not-change-when-meeting-from-outlook-begins

    You could try to configure the Set-csClientpolicy with this:


    WebServicePollInterval

    CalendarStatePublicationInterval 

    You could try to reduce the value of the parameter above and test again.

    For details, please refer to

    http://www.justin-morris.net/how-does-lync-2010-use-exchange-calendar-information/

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Eason Huang
    TechNet Community Support

    Thursday, June 16, 2016 8:48 AM
  • Thank you for the information.

    I've changed MapiPollinterval, WebServerPollinterval and CalendarStatePublicationInterval all to 60 seconds.

    Addressed skype 2016 problem with this https://support.microsoft.com/en-us/kb/3147130

    Also addressed an autodiscover DNS issue that did not effect Skype 2013 but does seem to effect Skype 2016.

    Purged sip_user@domain.com

    Did an initial test this morning.  Status changed within 3 minutes into the meeting.  Thought I had it licked but not so much.  I've got a test meeting with another user right now, 15min in either one of our status have changed ....... 

    When a status does change to in a meeting and the meeting ends the status changes to available in less than a minute.  Just wish it would change that fast when a meeting starts.  This was never a problem before, worked perfectly.

    This is a exchange hybrid config with S4B on prem.  Could this be a latency issue somewhere?

    TIA

    Friday, June 17, 2016 3:24 PM
  • have seen delay in status change when the user mailbox on EXO and Lync User onprem, which perfectly suites that status changes between 3 min - 15 min interval.

    have you noticed this when both the users on prem ? is the issue remains same for EXO and Exchange onprem mailbox users ?

    this behavior likely because of calendar sync polling interval between Exchange and Lync, in general if you have created the meeting which is less than 30 min before your status would not change. it will take minimum 30 minutes to get updated.

    Regards,

    Rajukb


    Regards, Raju

    Friday, June 17, 2016 4:44 PM
  • Yes, of course. The Client will receive the Information through the EWS connect. Maybe it takes a while. You should do some tracing on the Client for the Webtraffic to EWS. maybe it exist some delay?

    regards Holger Technical Specialist UC

    • Marked as answer by Niko.Cheng Saturday, July 9, 2016 5:15 AM
    Friday, June 17, 2016 5:12 PM
  • 15 min used to be default refresh rate in Outlook which we manually used to edit it. Yes you can check the latency as Holger suggested .But looks like the update and Autodiscover correction fixed your issue.


    Linus

    • Marked as answer by Niko.Cheng Saturday, July 9, 2016 5:15 AM
    Friday, June 17, 2016 6:24 PM