none
Headphones not working on windows 10 (tried everything) RRS feed

  • Question

  • Hello,

    Last week, my headphones were working just fine. Today, when I truly needed them, they don't seem to be recognized by my laptop's jack.

    I've tried just about everything: updating the system, updating the drivers, installing and uninstalling, installing different drivers, restarting, disabling and re enabling, you name it. I've tried everything and my laptop still does not recognize any headphone, I've tried different types and no luck. They work fine in any other device.

    For some reason, Realtek HD audio manager does not appear in my control panel. I tried a lot of methods to find it, but it just does not exist in my computer at all. Just the manager for my headphones, but it doesn't have the option to disable the front panel jacks that is also recommended.

    I've been searching and trying different things for about three hours already and I don't know what to do anymore.

    Thanks in advance.

    ......

    Update:

    I've also tried updating to window's update 1909, nothing.

    I tried installing an older version of Realtek HD audio manager and now I can find the manager but it won't open no matter what I do.

    I have tried changing to High Definition Audio Device and it shows me the headphones but they are not recognized when I plug them in.

    I tried editing the registry with a Registry Editor but a part of the code does not exist in my registry.

    Please, I really don't know what else to do, nothing works.

    Should I just give up and never ever use headphones on my laptop again?

    ..............

    So my computer specs in case you need them:

    It's an HP pavilion 360.

    Windows 10

    B&O Play (this controller also doesn't show up. It did before I downgraded Realtek, but it didn't have the option to disable the front panel jack that was advised to fix my problem).

    High Definition Audio Device, driver version 10.0.18362.356

    Realtek High Definition Audio, driver version 6.0.1.8036

    ...............

    Edit 2:

    I found the B&O controller and tried enabling playback multi-streaming, still nothing.

    I've tried making the headphones the default device, but the option is not available.


    • Edited by RocioL Monday, December 9, 2019 5:53 PM tried fixing the problem but it's still there
    Monday, December 9, 2019 11:19 AM

All replies

  • Try to clean install 1909 and install all audio driver from manufacturer website, test result. Please note backup your important data in advance.

    If this way still no help, I think it should not be a system related issue, you need to contact manufacturer after-sale support for help, hardware(like mother board or audio adapter) issue on your PC need to be considered.

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 10, 2019 2:11 AM
    Moderator
  • I'm not sure if this is the 100% exact issue we're also having, however, I recently am able to reproduce the analog headphones not working in our Windows 10 environment and provide a "fix" to get them working again. This is on 1809, 1903, and 1909 OS installs, between various models of HP and Dell devices, having varied Realtek driver versions all the way up to the latest release.

    The behavior we found was when a user plugged in the analog headphones the sound wouldn't switch to them and continue to playback via the onboard laptop speakers. We noticed after we imaged our devices the headphones worked fine for a brief time until Windows auto installed drivers. We also tried installing the latest drivers from Realtek and same issue.

    Once the device had the service/application installed the headphones had issues and we seemed to have narrowed down that there is a service (Realtek Audio Universal Service) set for Automatic startup that runs "C:\WINDOWS\System32\RtkAudUService64.exe". However, we also found there is a startup application (Realtek HD Audio Universal Service) set to run "RtkAudUService64.exe".

    If we disable both the service and startup application the headphones work properly.
    If we let the service start Automatically but disable the startup application the headphones work properly.
    If we then manually run the "RtkAudUService64.exe" application we see a flash of a program then the headphones no longer work.

    It seems that if the application is running (via the service) and then tries to relaunch itself (via the startup application) it causes the issue for us.

    If we remove the startup application entry it just would come back (probably hard coded into their application to put in a startup item if it's not found) rather than relying on the installed service.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\RtkAudUService

    So we're now working to leave the startup application, however, have it set as disabled via the registry entry. This allows the service to still run but it prevents the application from trying to run a 2nd time allowing headphone use.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\StartupApproved\Run]
    "RtkAudUService"=hex:03,00,00,00,73,0b,b8,6a,81,d0,d5,01

    I've also reached out to Realtek support today with all my testing information and details in hopes they can fix this seemingly wide spread issue about Realtek drivers not liking analog headphones.



    • Edited by Bertlor Wednesday, January 22, 2020 3:45 PM added more details
    Wednesday, January 22, 2020 3:39 PM
  • I just got this problem after installing the Windows 10 1903 2020-01 cumulative update KB4528760 (and the 2020-01 Update for .NET Framework 3.5 & 4.8 KB4532938). The headphones were working right before the update.

    The laptop speakers work. When you mouseover the speaker icon with the headphones plugged in, it still says "Speakers:" on it, and headphones are not listed in the sound devices section (either in the Control Panel-->Sound section, or in the Windows 10 sound settings). However, you can still tell that it detects when the headphones are plugged in because the volume indicator changes when you plug/unplug them from the port.

    I don't see the RtkAudUService running, either in services.msc, or in the Task Manager Startup section.

    I reinstalled the Realtek drivers from the ASUS website (ASUS Vivobook Flip 14). Nothing worked. Currently the driver is listed as 6.0.1.8564 (10/31/2018)

    This is very annoying!!

    EDIT (2020-01-23 9:54PM EST): After uninstalling the KB4528760 update (the 1903 2020-01 Cumulative), then reinstalling it, my headphones are working again! By the way, the Realtek drivers themselves didn't appear to change through the Windows update process, except for when I uninstalled/reinstalled them manually myself.


    • Edited by areacode212 Friday, January 24, 2020 2:56 AM they're working again!
    Thursday, January 23, 2020 5:56 PM
  • my Headphones still work on 1909 build 18363.592 ="January 14, 2020—KB4528760" and "KB4532938 Cumulative Update for .NET Framework 3.5 and 4.8" installed.
    "Realtek High Definition Audio" driver version 6.0.1.7572
    Sound Mixer only displays "Speakers" for me, too, so that is not the problem.
    I disabled the autostart of the "Realtek HD Audio Manager" (but on my system it is called RTHDVCPL) a long time ago, as this but-ugly thing seems to not be needed, anyway.

    Maybe the problem is only with new Realtek drivers?
    Thursday, January 23, 2020 6:21 PM