Msvcr71.dll Missing RRS feed

  • Question

  • We have a security camera here at Holy Cross Head Start.  We were able to view the cameras using Windows XP and Internet Explorer.  After updateing several of the computers to Windows 7 Professional, I tried to reinstall the Camera software.  This software is installed from the DVR unit.  After going through the motions, I get an error message that Reads "Msvcr71.dll missing"  and am unable to view the cameras using Internet Explorer.  As near as I can tell Msvcr71.dll is a Visual C Runtime Library file.
    Monday, May 3, 2010 6:01 PM


All replies

  • Hi Ed_HolyCross,

    Please ensure you don't have any pending updates from Windows Update related to .net framework.

    In case you do not, download and install the .net framework.

    Avoid to download the msvcr71.dll file from any other source since it could create reliability and security issues.



    Monday, May 3, 2010 6:38 PM
  • Hi,


    To fix the issue, you may also try to troubleshooting suggestions the following link mentions:


    Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


    If it still cannot work, I would like to suggest you start Command Prompt as administrator to run the following command:

    regsvr32 msvcr71.dll



    Arthur Li - MSFT
    Wednesday, May 5, 2010 3:06 AM
  • Both of these suggestions were tried prior to my post.  They did not work.  Thank you.
    Friday, May 7, 2010 2:29 AM
  • I was concerned about downloading a file from an unknown source.  But, nothing else I tried has worked.  So (reluctantly) I did download the file from the site you suggested and placed it in my System32 directory.  After scanning it for viruses and malware.  It worked.  I can view the security cameras on my Windows 7 PC.  Thank you for you help.
    Friday, May 7, 2010 2:31 AM
  • Since I have 64 bit Windows 7, I had to copy the file from System32 after doing the .net install to the SysWOW64 folder. That did the trick for me. Official Microsoft files from link EDMV provided / plus manual copy to SysWOW64 because of 64bit Windows.
    Wednesday, April 4, 2012 2:34 PM
  • To fix the issue, download MSVCR71.dll from microsoft and copy int owindows foler
    Monday, November 4, 2013 9:23 PM
  • All the following solutions are working. You can check these as well.
    Friday, January 8, 2016 4:19 AM