none
Window 7 can not access network (DHCP, Diagnostic Policy,...) RRS feed

  • Question

  • We have hundred PC (running XP) joined to domain controller 2003, works very smoothly. But now we're planning to upgrade our PC to Window 7

    But the issue are:

    After join Window 7 to 2003 domain, after few times restarts window7 machine then all service can not startup ( DHCP, Diagnostic Policy.., ...... if you try to restart manually then "Access Denied")---> machine can not get DHCP info (IP add, DNS,....)--> can not login to domain account

    To resolve this kind of issue: we have to add "Local Service + Network Service" to local Administrator Group then it works

    Anybody can help

    Thanks in advanced

    Wednesday, April 28, 2010 2:38 AM

All replies

  • First thoughts:

    If you are able to successfully joined the machine under Windows 7 to the domain, then network infrastructure services should be working:

    DHCP - should work

    DNS - should work

    Domain admin privileges - you appear to have them

     

    If after rebooting the machine (after you initially join the machine to the domain), you will need to test logging on to the machine with a domain user account.

    You could try the same account that you used to join the machine to the domain.  Make sure that underneath the password field it states <your domain name>.  If instead it lists the local machine name, you'll need to logon with domain\domainusername credentials.

    Keep in mind that in order to restart those type of services, you will need to have elevated privileges.  Typically, adding your domain admin account to the local administrators group would meet your needs.  You may first need to logon as the local administrator to add this account, however.

     

    Wednesday, April 28, 2010 3:41 PM
  • i don't not have chance to login via domain account, because window 7 can not get IP address/DNS,subnetmask ( before i can)

    I only login to local machine only (administrator account) then check from there but any time try to start manually ( always get Access Denied)

     

    also try to run "cmd" as Adminstrator then ipconfig /renew ---> then get "Access Denied" also

     

    Try fresh Window 2003 installation in test lab then nothing goes wrong, so i just wonder which things on our real system can cause the issues

     

     

     

    Thursday, April 29, 2010 6:46 AM
  • I can tell you that by default, Windows 7 is not causing this.

    I have seen many different corporate environments that push settings through Group Policy.  Do you know if you have a Group Policy management team at your company?  Perhaps policy is detecting that your computer isn't authorized for some reason (anti-virus software not present or updated).

    If the symptom happens when joining the domain, unjoin from the domain and see if the symptoms go away.

     

    Then, try to join the domain again.

    Thursday, April 29, 2010 2:09 PM
  • Dear,

    We control (IT dept) the GPO settings and also try to check the current GPO settings vs fresh GPO ( on new W2k3), but nothings are different.

    Also try to unjoin machine ( assign static IP first) but after unjoin the Window 7 also can not access network either ( can not get DHCP, Diagnotise Policy Server up/running, Access Denied if you start manually), that seems something change Window 7 registry permissions, but the issue we do not know who ???

    Also tro to Window 7 System restore back to the original, then try again then all are the same, big crazy !!!!!!!!!!!!!!!!    

    Friday, April 30, 2010 2:25 AM
  • A few issues at play here:

    1. You cannot "get" DHCP

    2. Access denied errors when restarting services

    3. Any others?

    Let's look at issue 1 first.  You assigned a static IP address to your workstation.  What information are you expecting it to get from DHCP?  I would set the IP address back to DHCP assigned and then do an ipconfig /renew.  See if your workstation obtains an IP address, DNS server address, etc. from DHCP.

    Friday, April 30, 2010 6:23 PM
  • We have assinged the static IP address + subnet mask + DNS + WINS then it can comunicate to our 2003 domain, after that if we re-define DHCP enable on Window 7 then it can not get these infomation from DHCP server ( even it can get before joining to 2003 domain).

    Have tried one more test: if we add EveryOne to local Administrator then it can get DHCP (IP, subnbet, DNS,...) but it can not ping anywhere "but i forget the output"  but it's quite strange not like normal " request timed out"

    Saturday, May 1, 2010 1:57 AM
  • am having the exact same problem. have been working on it for 3 weeks thinking it was a virus using GPO to lock up computers on the domain( 2003).

    I will try your work around but did you find what the actual cause was. This is also causing file servers to lock up when running a .exe file from a shared folder.

    please help. thank you

    Saturday, September 8, 2012 5:45 PM