locked
Component Services My Computer Down Error RRS feed

  • Question

  • Hi

    We are facing with component services +com Services I think not working properly

    1. When I open component services My computer show down arrow

    2. mstsdc -uninstall or reinstall make it come up again and where able to open our cluster but as soon the server restart it again goes down

    3. We are getting this error

    an error occurred while processing the last operation. error code 8004E00F - COM+ was unable to talk to the Microsoft Distributed Transaction Coordinator

    I tired the following troubleshooting step

    https://blogs.msdn.microsoft.com/asiatech/2012/01/25/how-to-troubleshoot-the-red-arrow-issue-in-component-services-iii/

    Not able to register these catsrv.dll, catsrvut.dll, comsvcs.dll file getting error

    or +com services is running and that is from Network services.

    Can anyone provide any solution for this

    Tuesday, March 15, 2016 8:24 PM

All replies

  • I'd start by checking the system event log. If nothing then I'd compare the service startups here.

    https://technet.microsoft.com/en-us/library/dd349799%28v=ws.10%29.aspx?f=255&MSPPError=-2147217396

    http://www.blackviper.com/service-configurations/black-vipers-windows-server-2008-r2-service-configurations/

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Wednesday, March 16, 2016 2:57 AM
  • Hi,

    According to my research, the issue may be caused by MSDTC (Distributed transaction coordinator) Service being set to run under the local system account. It should run under NT

     Authority\NetworkService account instead. Please try the following steps:

    Note: Before performing these steps, please do take a backup of the registry.

    1. Press Windows key and the R key to open the Run prompt and type Regedit.exe and press enter to open the Registry Editor.

    2. Locate HKEY_LOCAL_MACHINE\Software\Microsoft\MSDTC.

    3. Right click on TurnOffRpcSecurity and select Modify. Add value 1.

    4. In the Run prompt, type Services.msc and locate Distributed Transaction Coordinator. Right click on it and select Stop.

    5. Right click on the Service and then select properties. Click on the Log On tab.

    6. Change the Log on account back to NT Authority\NetworkService

    7. Just type NT Authority\NetworkService

    8. the Password is blank.

    9. Click Apply and Ok

    10. Start Distributed Transaction Coordinator service.

    Restart the computer and check if you still experience the issue.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 16, 2016 8:53 AM
  • I have tried that it does not work. 
    Wednesday, March 16, 2016 6:00 PM
  • this also done before posting this question no luck. We are building the new server
    Wednesday, March 16, 2016 6:01 PM
  • Hi,

    Thanks for sharing your current progress and sorry for the limited help on this case.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 17, 2016 1:29 AM