locked
SharePoint 2007: Deleting a Site Collection RRS feed

  • Question

  • I am trying to delete an extremely large site collection from Central Admin in MOSS 2007, however this crashed midway through and whilst the site appears to be deleted when I navigate to the URL (Page not found error), it is still appearing in the site collection list in Central Admin. When I attempt to delete this again in Central Admin, it keeps defaulting to "No Selection" when I click on it. Does anyone have any idea how we can force delete this site collection?
    Tuesday, January 28, 2020 2:41 PM

All replies

  • Hi

    First of all, try running stsadm -o databaserepair -url 'http://sitecollectionurl' -databasename 'ContentDBName'

    If it returns <OrphanedObjects Count="0" />, then the site collection is gone from the content DB, but still referenced in the configuration database.  Remove the content DB in Central administration and then add it right back in, and the problem should go away.

    Tuesday, January 28, 2020 4:34 PM
  • Thank you Tina. I have run that command and it does indeed return <OrphanedObjects Count="0" />

    I have removed the content DB in Central Admin but when I am trying to add this back in, I get the below error message:

    <DB Name> on <DB Server> contains user-defined schema.  Databases must be empty before they can be used.  Delete all of the tables, stored procedures and other objects or use a different database.

    I have two other site collections on this database so I need to restore this.

    Monday, February 10, 2020 12:09 PM