locked
SQL connection - Get and transform missing data RRS feed

  • Question

  • Hi all,

    I have a query that i run in Management Studio.  It contains a UNION of two grouped queries.  It returns 147 records.

    If i put an SQL connection in excel 2016 it is only returning 45 results.

    If i make an ODBC connection in the same excel book to the same SQL server it returns the full 147.

    Any ideas why?

    Dan

    Wednesday, January 29, 2020 1:28 PM

Answers

  • Do you have a sample table/data and query?

    Seth

    A user just like you

    Wednesday, January 29, 2020 8:41 PM
  • Hi,

    Sorry for late reply.

    I found the answer.  I cleared the cache files here:

    C:\Users\{username}\AppData\Local\Microsoft\Office\16.0\PowerQuery

    and my problem went away.

    Dan

    • Marked as answer by CRMScholar Tuesday, February 25, 2020 8:51 AM
    Tuesday, February 25, 2020 8:51 AM

All replies

  • Do you have a sample table/data and query?

    Seth

    A user just like you

    Wednesday, January 29, 2020 8:41 PM
  • Hi,

    Considering the issue is mainly related to query, to help you resolve the issue better, I will move the thread to Power Query. You may get more helpful replies there. Thanks for your kind understanding. 

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.

    Best Regards,

    Emily


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Office 2019.

    Monday, February 3, 2020 11:40 AM
  • Hi,

    Sorry for late reply.

    I found the answer.  I cleared the cache files here:

    C:\Users\{username}\AppData\Local\Microsoft\Office\16.0\PowerQuery

    and my problem went away.

    Dan

    • Marked as answer by CRMScholar Tuesday, February 25, 2020 8:51 AM
    Tuesday, February 25, 2020 8:51 AM