locked
DPM 2016 agent install fails on laptops just removed from DPM 2012R2 agent RRS feed

  • Question

  • We are updating our DPM backup system, we build a new 2016 server and we are using SQL 2014 and installed DPM 2016.  I am trying to move over our backup jobs to the new server. I stop protecting on the old and remove the agent.  I go to the new server and try to install the 2016 agent and when trying to install the agent on a Win10 laptop the error I get is "Install protection agent on.......failed:  Error 347: An error occurred when the agent operation attempted to create the DPM Agent Coordinator service on ....... Error Detailes: Unspecified error  Recommended action: verify that the Agent Coordnator service on ....is responding, if it is present".

    I then tried installing it from cmd using  dpmagentinstaller_x64 /q server.abc.com /IAcceptEULA and it shows running for about 10 minutes in taskmanager.  I then try to attach it in DPM and it shows error ID 270 and when I check the folders on the laptop it has the main folder but missing the additional files/folders.

    I have had this work on 1 out of 3 laptops so far and I have many to go.  I have tried rebooting the laptops, making sure they are updated. I am able to re-add the old agent with no problems then remove it but never able to get the 2016 agent to install.

    Tuesday, January 16, 2018 4:10 PM

Answers

  • House keeping - closing old post.

    If you remove the /q switch you would most likely see the error.  "The program can’t start because mi.dll is missing from your computer. Try reinstalling the program to fix this problem."

    solution below.

    https://support.microsoft.com/en-us/help/4018028/dpm-agent-install-fails-with-error-347-an-error-occurred-when-the-agen

    Regards
    Mike Jacquet


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, January 10, 2020 9:22 PM