locked
Outlook Pro Plus 365 Tries to Switch from On-Premises Exchange Server to Office 365 RRS feed

  • Question

  • I have done a lot of research on this, and can't find a definitive answer.

    We have an On-Premises Exchange Server.  When we setup an Outlook Pro Plus 365 profile for our On-Premises Exchange Server, it connects to the server, but within a minute or two, Outlook puts up a dialog with the Heading "Microsoft Sign in".  It is asking for an email or phone with a Next button to connect to Office 365.  Outlook stops operating properly, and no emails go in or out.  It appears that this problem starting occurring after we setup Microsoft Teams on the computers.  Existing computers with Outlook already installed are still fine, but any new computer or new user added to a computer has this problem.

    Bottom line, I need Outlook to stop trying to connect to Office 365.

    Monday, May 4, 2020 10:41 PM

Answers

  • I worked with a Microsoft engineer, Colin, who solved the problem.  As stated above, we have an on-premises Exchange server.  Outlook would pop up a "Microsoft login dialog) whenever Outlook was started.  What we found was Microsoft 365 was adding an Exchange Online (Plan 1) Microsoft Teams Exploratory" license to every user.  We didn't ask for this license.  Microsoft 365 added it automatically.  We unchecked the "Exchange Online (Plan 1) license for each user in the Microsoft 365 Admin console.

    When the dialog popped up in Outlook, it came up in the format {username}@{domain}.local.  I erased this, and entered the Microsoft 365 login email address and then password for Microsoft 365 for that user.  That cleared the dialog, and it never came back up.

    Many thanks to Colin at Microsoft for solving this!

    Michael


    • Marked as answer by Michael1000 Friday, June 26, 2020 9:52 PM
    • Edited by Michael1000 Friday, June 26, 2020 9:56 PM
    Friday, June 26, 2020 9:52 PM

All replies

  • Hi Michael,

    Do you still use Office 365 accounts at the same time on these problematic computers?

    >> I need Outlook to stop trying to connect to Office 365.
    According to my research, to make Outlook stop trying to connect to Office 365, it is suggested for you to try the following steps and see if it works:

    1. Open Registry Editor (Press Win + R, type “Registry Editor”, press Enter.)
    2. Go to:
      Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover\RedirectServers
    3. Delete the key "RedirectServers"
    4. Add the ExcludeExplicit.
      HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover
      DWORD
      ExcludeExplicitO365Endpoint
      Set to 1
    5. Restart your Outlook.

    (Please Note: Serious problems can occur if you modify the registry incorrectly. Before making changes, back up the registry to restore it in case something goes wrong.)

    Hope this can be helpful.

    Regards,

    Jeff Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Tuesday, May 5, 2020 5:59 AM
  • Hi Jeff,

    Thanks for getting back to me.  

    There are a couple of issues.

    1) This part of the path is missing from the Registry.  (There is nothing past Microsoft.)

    "Office\16.0\Outlook\AutoDiscover\RedirectServers"

    2) This computer is on a domain, and it does not allow users to modify the registry.  Since this entry starts out as HKEY_CURRENT_USER, then you have to be logged in as that user.  So we are in a bind.

    Michael


    Wednesday, May 6, 2020 6:05 PM
  • Hi Michael,

    Thanks for your reply. 

    >>  It appears that this problem starting occurring after we setup Microsoft Teams on the computers.  Existing computers with Outlook already installed are still fine, but any new computer or new user added to a computer has this problem.

    According to your description, it seems that your issue may be related to the Microsoft Teams program. To conduct further researches, it is suggested for you to adjust the order when you install programs and see if the issue has any difference.(For example, install Outlook  before installing Microsoft Teams)

    >> This computer is on a domain, and it does not allow users to modify the registry.

    I really researched a lot about your issue. However, most of information I found which may be related to your issue involves modifying the registry. If I have any more information related your issue, I'll post back.

    Thanks for your patience and understanding.

    Regards,

    Jeff Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.



    Monday, May 11, 2020 9:52 AM
  • This computer is on a domain, and it does not allow users to modify the registry.  Since this entry starts out as HKEY_CURRENT_USER, then you have to be logged in as that user.

    You can start the registry editor as an administrator and edit the keys via HKEY_USERS (the user names for the listed IDs are under the "profilelist" key).
    • Edited by admin8888 Monday, May 11, 2020 12:36 PM
    Monday, May 11, 2020 12:35 PM
  • Hi ,

    Sorry for the delay.

    I researched a lot about your issue and found that there are some other users who has the same issue as you. It is suggested for you to try to remove Office and Exchange related credentials in Windows Credential Manager and restart your Outlook to see if it there is any difference. For more information, please check this thread.

    Hope this can be useful.

    Regards,

    Jeff Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Sunday, May 17, 2020 4:40 AM
  • Hi ,

    Just checking in to see if above information was helpful. If you have any further updates on this issue, please feel free to post back.

    Regards,

    Jeff Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Sunday, May 17, 2020 4:42 AM
  • Went into Credential Manager.  Found no Credentials for Office or Exchange there.

    More things I tried.

    1)  If I cancel out of the Microsoft login (which is trying to use our local domain login), it will go into Outlook and bring up the emails from our on-premises Exchange Server.  However, a few minutes later, it asks for the stupid Microsoft login again using our domain login. So...

    DIDN'T WORK.

    2)  I spoke to Office 365 Support.  They recommended that I turn off MAPI for each users in the Admin portal.

    DIDN'T WORK.

    3)  Added registry key as suggested on another thread.

    HKEY_CURRENT_USER\Software\Microsoft\Exchange

    DWORD: MapiHttpDisabled

    Value: 1

    DIDN'T WORK.

    I absolutely frustrated with this.  We can't use Outlook.




    Thursday, May 21, 2020 5:55 PM
  • Hi Michael,

    Thanks for your reply and sharing.

    I researched a lot about your issue but have not found more possible workarounds. As I know, Outlook will not pop up O365 login prompt when only using On-Premises Exchange exchange account. There might be some information retained in Windows, as long as you had logged into Microsoft accounts before. To troubleshot this, it is suggested to try to create a new windows profile and see if it works.

    Hope this can be helpful.

    Regards,

    Jeff Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Tuesday, May 26, 2020 7:46 AM
  • Hi Jeff,

    We created a new Windows profile on another computer, and it did the same thing.

    It I cancel out of the Microsoft login dialog, it still gets email from the on-premises Exchange Server.  After a while, though, it tries to login to the Microsoft servers again.  

    Regards,

    Michael

    Tuesday, May 26, 2020 8:40 PM
  • Hi Michael ,

    Thanks for your reply.

    Sorry to hear that the issue still continues. I researched a lot about your issue but could not found more possible methods. As a workaround, you may temporarily use the webmail.

    Besides, if possible, you may try to backup all the data in your computer and reinstall clean windows and Outlook to see if it works.

    Regards,

    Jeff Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Thursday, May 28, 2020 7:01 AM
  • Hi Jeff,

    It is even doing this on a server for Remote Desktop connections, so that is not an option.

    We setup a new computer, and for whatever reason did not have the problem.  Some computers have the issue and others don't.  We can't figure this out.

    Michael

    Thursday, June 4, 2020 9:05 PM
  • Hi Michael ,

    Thanks for your reply.

    >>We setup a new computer, and for whatever reason did not have the problem. 
    As you mentioned, usually in the new devices, we will not encounter O365 pop-up if we if we have not tried to logged in to O365 account. During large amount of tests in my environment, I still could not reproduce your issue. 

    I will continue to pay attention to the information related to your issue. If I have any updates, I will post back. Thanks for your understanding and support.

    Regards,

    Jeff Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Wednesday, June 10, 2020 6:47 AM
  • We setup a new computer, and did not get this dialog box, even with multiple people setup on the computer.

    We setup another identical new computer, and the Microsoft login dialog appears filled in with {username}@{domain}.local.

    SOMEBODY PLEASE HELP!  This is impairing our ability to get things done.

    • Proposed as answer by Yaktta Friday, June 12, 2020 4:09 PM
    Thursday, June 11, 2020 4:15 PM
  • I worked with a Microsoft engineer, Colin, who solved the problem.  As stated above, we have an on-premises Exchange server.  Outlook would pop up a "Microsoft login dialog) whenever Outlook was started.  What we found was Microsoft 365 was adding an Exchange Online (Plan 1) Microsoft Teams Exploratory" license to every user.  We didn't ask for this license.  Microsoft 365 added it automatically.  We unchecked the "Exchange Online (Plan 1) license for each user in the Microsoft 365 Admin console.

    When the dialog popped up in Outlook, it came up in the format {username}@{domain}.local.  I erased this, and entered the Microsoft 365 login email address and then password for Microsoft 365 for that user.  That cleared the dialog, and it never came back up.

    Many thanks to Colin at Microsoft for solving this!

    Michael


    • Marked as answer by Michael1000 Friday, June 26, 2020 9:52 PM
    • Edited by Michael1000 Friday, June 26, 2020 9:56 PM
    Friday, June 26, 2020 9:52 PM