none
QIP DHCP Services and no DNS/WINS with SP3?

    Question

  • I've upgraded a few test machines here to SP3 and noticed that I am no longer getting DNS/WINS servers from DHCP templates. Has something change or is it the fact that QIP (Lucent) DHCP is no longer supported? We are using an older version and in the process of getting upgraded but please has anyone else experienced this?

    Friday, January 4, 2008 4:46 PM

Answers

  • Thanks for all the information. I think we have got enough information as of now to proceed with our investigation into this issue. I hope to find a resolution soon enough and I will inform you as and when there are some developments.

     

    Thursday, January 10, 2008 8:49 PM

All replies

  • Well the first thing that you need to do in such cases where you feel there is a problem with the DHCP Client is to have a network capture on the client and check if the options are in fact coming from the DHCP Server at all. In your case I would imagine that you would also have XP SP2 or earlier machines that might be working properly for you. What you need to do is to compare the Network Captures from a working machine with that of the SP3 machine and see if there are any differences, particularly looking for the presence/absence of the DNS/WINS options in the received DHCP packets. Please update the thread once you have any new findings.

     

    Friday, January 4, 2008 6:43 PM
  • I see the options getting sent over, has the DHCP code changed that dramatically from sp2 to sp3? I can do a capture to the client.

    Friday, January 4, 2008 6:45 PM
  •  

    I've got a lib pcap capture of the DHCP request/ack (2 of them) if someone from MS wants to look it over. I've got it in pcap format and netmon format.
    Friday, January 4, 2008 7:52 PM
  • Could you mail them over to jayaramk@microsoft.com. We would like to take a look.

     

    Friday, January 4, 2008 8:13 PM
  • Thanks for sending those captures. Just a few things that I wanted to clarify. Have you enabled DHCP NAP Enforcement on the XP SP3 machine and also are you getting the other options like the Domain Name, the Primary and Secondary WINS Server names, the Default Gateway properly. You can check all the Network Configuration values using "ipconfig /all" at the command prompt.

    Tuesday, January 8, 2008 12:52 PM
  •  

    I do not know about NAP I heard about it but didn't see a way to change it off/on. I am not getting DNS/WIS/Default gateway with the issue. However on my home machine running XP SP3 on DHCP i don't have these problems could it be related to domain policy?
    Tuesday, January 8, 2008 11:36 PM
  • Richie,

    if I get you correctly,you are not getting any options from among DNSWINS/DefaultGateway/DomainName etc in your IPconfig /all, is that right? But you get these options on your home machine which is also running XP SP3?

     

    Can you please copy and paste the output of ipconfig /all on your problematic machine?

     

    Thanks.

    Sameer N. Mirza

     

    Wednesday, January 9, 2008 8:34 AM
  • This is a SP3 host with the issue.

     

     

    C:\Documents and Settings\rcrews\Desktop>ipconfig /all

    Windows IP Configuration

            Host Name . . . . . . . . . . . . : osiri
            Primary Dns Suffix  . . . . . . . : turner.com
            Node Type . . . . . . . . . . . . : Hybrid
            IP Routing Enabled. . . . . . . . : No
            WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

            Connection-specific DNS Suffix  . :
            Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Cont
    roller
            Physical Address. . . . . . . . . : 00-14-22-35-15-79
            Dhcp Enabled. . . . . . . . . . . : Yes
            Autoconfiguration Enabled . . . . : Yes
            IP Address. . . . . . . . . . . . : 10.188.60.169
            Subnet Mask . . . . . . . . . . . : 255.255.254.0
            Default Gateway . . . . . . . . . :
            DHCP Server . . . . . . . . . . . : 10.188.168.30
            Lease Obtained. . . . . . . . . . : Thursday, January 10, 2008 9:40:03 A
    M
            Lease Expires . . . . . . . . . . : Saturday, January 12, 2008 9:40:03 A
    M

    C:\Documents and Settings\rcrews\Desktop>

     

     

    This is one from my house on a different DHCP server with no issues (running sp3 too).

     

    C:\Documents and Settings\Richie Crews>ipconfig /all

    Windows IP Configuration

            Host Name . . . . . . . . . . . . : pyrodex
            Primary Dns Suffix  . . . . . . . :
            Node Type . . . . . . . . . . . . : Hybrid
            IP Routing Enabled. . . . . . . . : No
            WINS Proxy Enabled. . . . . . . . : No
            DNS Suffix Search List. . . . . . : localhome.com

    Ethernet adapter Local Area Connection 2:

            Connection-specific DNS Suffix  . : localhome.com
            Description . . . . . . . . . . . : Marvell Yukon 88E8053 PCI-E Gigabit
    Ethernet Controller
            Physical Address. . . . . . . . . : 00-17-31-2A-4D-BC
            Dhcp Enabled. . . . . . . . . . . : Yes
            Autoconfiguration Enabled . . . . : Yes
            IP Address. . . . . . . . . . . . : 192.168.15.200
            Subnet Mask . . . . . . . . . . . : 255.255.255.0
            Default Gateway . . . . . . . . . : 192.168.15.1
            DHCP Server . . . . . . . . . . . : 192.168.15.1
            DNS Servers . . . . . . . . . . . : 192.168.15.1
            Primary WINS Server . . . . . . . : 192.168.15.1
            Lease Obtained. . . . . . . . . . : Thursday, January 10, 2008 9:38:49 A
    M
            Lease Expires . . . . . . . . . . : Thursday, January 10, 2008 2:38:49 P
    M

    C:\Documents and Settings\Richie Crews>

    Thursday, January 10, 2008 3:01 PM
  • Thanks for all the information. I think we have got enough information as of now to proceed with our investigation into this issue. I hope to find a resolution soon enough and I will inform you as and when there are some developments.

     

    Thursday, January 10, 2008 8:49 PM
  • Can you confirm one more thing. Open regedit and check if you are getting the DNS/WINS etc. information in the registry by going to the following key

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}]

     

    (Note : To help you choose the correct GUID for the interface on which you are getting the IP, go through the various interfaces and check for the IP address that your NIC has obtained.)

     

    Once you find such an interface just copy&paste ALL the information present in your reply or export the key and send it over to me @ navjotr@microsoft.com.

     

    Thanks

    Navjot Rattan

    Monday, January 14, 2008 12:37 PM
  • Navjot,

    I am having the same exact issue with the version that was released yesterday. I am running QIP 5.2 and have the exact same issues, no DNS, WINS, or gateway.

    Was there any resolve to this?

     

    Thanks,

    -Quinn Easterbrook

    Lockheed Martin

     

    Wednesday, May 7, 2008 1:06 PM
  • I'm also seeing what appears to be the same or a related issue on the two Dell Dimension 380's I've installed XP SP3 on. Both are using "Broadcom NetXtreme 57xx Gigabit Controller" network cards.

     

    I've noticed that the issue doesn't surface on the first reboot after installing XP SP3. It only shows up after the DHCP lease expires or after a "ipconfig /release", "ipconfig /renew" cycle.

     

    If I manually specify the DNS and WINS information and do a "ipconfig /release", "ipconfig /renew" cycle, the gateway information will be populated and I can continue using my computers. Reverting the XP SP3 update also solves the issue.

     

    Chris Squibb
    National Instruments

    Wednesday, May 7, 2008 3:51 PM
  • We have experienced exactly the same problem with QIP and XP SP3. No DNS entry, but DHCP itself works fine. At the moment, the only workaround is to fix the name server manually at a XP SP3 workstation.

     

    Any news about that or even a solution?

    Thursday, May 8, 2008 8:02 AM
  •  

    Has anyone had joy with this issue?

     

    Just updated to XP3 and having the issues mentioned.

    Monday, May 12, 2008 11:39 AM
  • I have experienced the same issue. I made some investigation and here are my assumptions:

    The problem is strongly related to Client-class (or vendor) options configured on Lucent DHCP server. We are using 2 client classes, for PXE clients and for MS clients. They are presented in dhcpd.conf with this code:

           vendor-class "MSFT 5.0" {
                option vendor-specific [010400000002];
          }

          vendor-class "PXEClient:Arch:00000:UNDI:002001" {
                option dhcp-tftp-server "x.y.z.a";
                option dhcp-bootfile-name "/etc/integra/tftp/boot.ovl";
          }

    When I disabled those client classes everything stared to work fine, Win XP SP3 clients were getting all the configuration correctly.

    When I made capture on DHCP server I detected there is new option 43 parameter (Vendor Specific Information) with value 0xDC00 sent by XP SP3 client in DHCP Discover packet. Perhaps it has something to do with Network Access Control introduced with SP3.
    Lucent DHCP server with client class options enabled responds by DHCP Offer packet with option 43, but the value is 010400000002.
    Then client sends DHCP Request packet with option 43 value 0xDC0100.
    Finally DHCP server sends DHCP ACK packet that contains option 43 with value 010400000002.

    If there is no client class configured, DHCP Discover contains option 43, value
    0xDC00, server responds DHCP Offer packet without option 43 and since that time that option is not used anymore and Win XP SP3 gets its configuration properly.

    Hope this could help you.
    Monday, May 12, 2008 4:29 PM
  • My inital reportings were with QIP version 6.0 running on Solaris 8 and Lucent DHCP version 5.2. Since then we've upgraded a few remote sites including my site and we are now running QIP 6.2 on Solaris 9 and Lucent DHCP Version 5.4. I believe the issue is with Lucent 5.2 DHCP and not QIP itself.
    Monday, May 12, 2008 4:40 PM
  • We are running DHCPService (Version: 5.4 Build 21 - Lucent DHCP Server) Copyright (c) 2000-2004 Lucent Technologies Inc. on Windows 2003 server, QIP itself is version 6.2 with some level of service pack.
    I have opened a ticket with Lucent about the issue. Waiting for answer.
    Monday, May 12, 2008 10:11 PM
  • Jan we are running QIP Version 6.2 build 44 and are having the same issue.  Has Lucent responded to your inquiry? 

     

    Tuesday, May 13, 2008 9:38 AM
  • OK, I also have this problem. I can confirm everything said so far (as I am using a laptop which I take to work and home) and have this exact same situation.

     

    First of all there is a manual fix (at least you can get your computers online) which is to manually add the Gateway and DNS information in the adapter properties. Of course its a real solution but only a fix for now.

     

    I am confirming if we are running QIP here and if so what version (I suspect it is 5.2).

     

    While I understand Lucent may have a fix for this, I must say the blame needs to be with MS and the way they changed the DHCP handshake in SP3. I mean at the end of the day, this has worked for years, and now after installing SP3 it's broken. Whether or not it is more secure is actually irrelevant if you break your system while trying to fix it. Even Vista get's online without a problem today.

     

    Anyway I hope there is a patch or something out soon to fix this, in the mean time I will get more info about the QIP that is being used here and if it can be upgraded (if that is the current fix).

     

    Tuesday, May 13, 2008 10:13 AM
  • We are also running 5.4 Build 21 - Lucent DHCP Server on Solaris 9 servers now. Prior to that we were some build of 5.2 running on Solaris 7/8 with the same issues. I beleive its tied to the Lucent version or we just got lucky in Solaris 9. Also the QIP Version could be 6.2 and you will still be running a different version of DHCP. Check your DHCP directly and don't assume due to qip version.
    Tuesday, May 13, 2008 12:58 PM
  • @Jan

    We did some testing in the lab and I can confirm your findings regarding the vendor-class "MSFT 5.0".

     

    But the value of option 43 is not the root of the problem. The problem is the option 43 itself as soon it is defined

    inside a vendor-class within QIP.

     

    When option 43 is defined inside a vendor-class, then the Lucent DHCP Server sends option 43 at the

    beginning of all DHCP options within the DHCP ACK message. Just after option 81, but before

    Subnet Mask (1), Router(3), Domain Name Server (6), Domain Name(15) etc.

     

    This seems to be a problem for XP SP3.

     

    When defining option 43 directly in a DHCP Option Template (without using a vendor-class) then the Lucent

    DHCP Server sends option 43 after the Domain Name(15) option, almost at the end of all

    DHCP options. And now it works! Independent of the value of option 43!

     

    Do a Wireshark session on your network and you will understand what I mean.

     

    The order of the DHCP options (especially option 43 ) within the DHCP ACK message, seems to

    produce a wrong behaviour of the XP SP3 DHCP client.

     

    In my opinion the order of the DHCP options within a DHCP message can be random. The DHCP

    client should not expect the options in a specific order. 

     

    One workaround is to add option 43 directly in the DHCP Option Template within the VitalQIP GUI and

    not using Vendor Classes. But then of course option 43 will be sent to all DHCP clients,...

     

    ..., or Microsoft changes the DHCP client code in SP3?

     

    Regards,

    Juerg

     

     

     

    Tuesday, May 13, 2008 4:19 PM
  • Not the whole truth what I mentioned before,...

     

    Even when using option 43 (vendor-specific) without using a vendor-class, then some DHCP options are

    missing after a ipconfig /release - ipconfig /renew.

     

    I seems that (all?) some options appearing after option 43 in the DHCP ACK message, will be ignored by

    the SP3 client.

     

    During my last tests the WINS Servers ( DHCP Option 44 ) were missing on the SP3 client. And

    option 44 was after option 43 within the DHCP ACK message,...

     

    One general question:

     

    Why using option 43 for "ordinary" XP SP3 clients?

     

     

     

     

     

     

     

    Wednesday, May 14, 2008 8:23 AM
  • Hello,

    Lucent confirmed they can reproduce the problem in their lab and the issue is under investigation. No solution provided yet.

    Regards.
    Thursday, May 15, 2008 10:23 AM
  • Hello,

     

    It appears that not only QIP DHCP services impacted. From the information on the MS SP3 forum, many others are experiencing this same issue behind certain home ADSL / DSL routers.

     

    Has XP SP3 respected the DHCP RFC's?

     

    Any comment from Microsoft would be most appreciated.

     

    Thanks

    Friday, May 16, 2008 7:24 AM
  • Option 43 has been added for XP SP3 clients to add the feature of Network Access Protection. This option encapsulates an option 220 which is a Vendor Specific Option within itself. The value of that is NULL initially to check if the DHCP Server is NAP Aware. Based on the reply from the DHCP Server the XP SP3 machine decides the further course of action.

     

    In case the server is non-NAP aware then we continue sending the VSO 220 with a value of 1 and length 1 within option 43. The location of the Option 43 can be anywhere in the options part of a DHCP packet and therefore should not affect the normal functioning of the DHCP Client.

     

    Finally the Lucent DHCP Server seems to be replaying back the same VSO 220 in it's reply to the XP SP3 client in some of the cases.

    Friday, May 16, 2008 8:04 AM
  • The investigation shows that the position of the option 43 in the packet seems to be the source of the problem. The XP SP3 client assumes that this will be the last one in the list of options. In most of the cases this is present at the end of the list, but with Lucent's DHCP Server this option can be placed anywhere in the list of options. That seems to be confusing the XP SP3 client and therefore some options are getting dropped.

     

    We are tracking this issue and will update as soon as there is any more information available in this regard.

    Saturday, May 17, 2008 9:21 AM
  • Yes, the position of option 43 within the DHCP messages seems to be the problem.

     

    Beside of that not all versions of LDHCP behave the same way.

     

    I did some tests today with LDHCP 5.2 B16 - which is a very old version of LDHCP and

    should not be used anymore - but anyway is still in use sometimes.

     

    LDHCP 5.2 B16 copies option 43 received from the XP SP3 client and ALWAYS sends option 43

    back. So with LDHCP 5.2 B16, XP SP3 clients are never working, even when option 43 is

    not defined somewhere in the configuration.

     

    LDHCP 5.2 servers should all be updated to LDHCP 5.4 B34.

     

     

     

    Monday, May 26, 2008 1:38 PM
  • did u ever find out wat was wrong wit it if so then can u help meh fix mine kisses

     

                                              

                                                                    Daneil Baugh     

    Monday, May 26, 2008 3:16 PM
  • I raised this as an incident through the free SP3 support but they couldn't help (outside of their remit apparently). At work we've now raised a coporate incident to see what they can do about it.
    Friday, May 30, 2008 8:23 PM
  • Please find the relevant information for the fix for this bug at http://support.microsoft.com/kb/953761/

    • Proposed as answer by Danix180 Tuesday, July 27, 2010 3:29 PM
    Tuesday, June 24, 2008 7:22 AM
  • This solved my problem!!!!

     

    Thanks for putting the information out there.

     

    Cees

     

    Friday, July 11, 2008 1:20 AM
  •  Navjot Rattan wrote:

    Please find the relevant information for the fix for this bug at http://support.microsoft.com/kb/953761/

    Excellent!!!.... Thank you very much,this worked on all my home pc's.

    Terry

    Thursday, September 11, 2008 7:53 PM
  • Im not sure if this is the same issue but i have a Dell Dimension 5100 running WinXP home that lost DNS after SP3 install.  I found a post with similar issue after Norton Internet Security was installed but removing that did not fix the issue.  I rebuilt the TCP/IP stack with no avail.  The only fix was uninstalling SP3 and all is working fine now.

    Wednesday, October 1, 2008 1:29 AM
  • I am not sure if its a silly question, but did you reach till the end of this discussion and saw the post with the link http://support.microsoft.com/kb/953761/ ?

     

    If you have not tried this KB please do so now with SP3 and let me know if that does not help.

     

    If this does not help please provide more details on the problem, if it turns that you are hitting some other bug we can have more discussion and I might need more data from you, for that you can contact me at s_a_m_e_e_r_m_i_@_m_i_c_r_o_s_o_f_t_._c_o_m

     

    Remove all underscores from the above mail id.

     

    Thanks

    Sameer N. Mirza

    Friday, October 17, 2008 5:33 PM