none
Discovering SQL 2012 Always On groups in SCOM 2012 SP1

    Question

  • Unable to discover/monitor SQL Always On groups in SCOM 2012 SP1

    We have 3 instances, each running on 4 SQL 2012 servers distributed across two sites.
    Each instance is configured with one Always On listener. Each site has its own  2 server failover cluster configuration.
    The SCOM 2012 agent is installed on all sQL servers. Instructions were followed in the SQL management pack guide for a low-privilege environment to allow full SQL monitoring.
    Databases and clusters are discovered in the SCOM 2012 SP1 console but not the Always On Availability groups and Replicas.
    We have also associated the AlWays On profile to the SQL Run As accounts.
    Has anyone experienced issues with discovering and monitoring Always On groups?
    What have I missed?

    Thursday, April 10, 2014 2:22 PM

Answers

  • I should have posted this before. Our DBA solved this issue but it may not be the recommended way Microsoft will come out with in the future but it worked for us.

    We had to add Read permissions to the following registry key on the SQL Low LowPriv group identified in the MP Guide.

    HKLM:\Software\Microsoft\Microsoft SQL Server\[InstanceID]\MSSQLServer\hadr

    Hope this helps everyone.

    • Marked as answer by stooney Tuesday, May 12, 2015 7:57 PM
    Tuesday, May 12, 2015 7:56 PM

All replies

  • Hi,

    Have you enable Alwayson Availability group feature? This needs to be done on all of the SQL Server instances that you will configure as replicas in your Availability Group. Have you created and configured your SQL Server 2012 AlwaysOn Availability Group?


    Regards, Yan Li

    Tuesday, April 15, 2014 1:58 AM
    Moderator
  • Hello,

    After verifying with our DBAs, yes the Always On availability group is enabled and in use.

    Friday, May 2, 2014 7:12 PM
  • This issue is still ongoing. We have found that on the SQL nodes, the AlwaysOn discovery script cannot seem to run. Event ID 10003 appears every 4 hours on  the active nodes at each site.

    I have restarted the SCOM agent and even clear the health state folder to reset the health.

    Does anybody have any suggestions? Anything goes at this point. Thank you

    Friday, May 9, 2014 7:39 PM
  • What is in the body of event ID 10003?

    "Fear disturbs your concentration"

    Friday, May 9, 2014 7:46 PM
  • Event ID 10003 displays the following:

    The descriptive for event ID 10003 from source HealthService cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the compent on the local computer.

    If the event originated on another computer, display information had to be saved with the event. The follwing information was included with the event.

    The following information was included with the event.

    <SCOM Management Group Name>

    Microsoft.SQLServer.2012.AlwaysOn.GeneralAlwaysOnDiscovery

    InstanceName AlwaysOn Seed

    Wednesday, May 21, 2014 12:27 PM
  • This issue is still on going for us. Can anyone say if installing SQL Server Management Studio on the SCOM server with the console is required to discover the availability group listeners?
    Thursday, May 29, 2014 1:05 PM
  • Hi,

    Did you end up resolving this?

    Thursday, June 12, 2014 11:20 PM
  • Hello

    I have the same problem, I did install all latest management pack available at the moment, did enable proxy to enable discover, everything is working well but the AlwaysOn discovery ...

    Here is the error I got on the Operation Manager log from the SQL server 

       Non-empty incremental data submitted and will be dropped.

       Discovery name: Microsoft.SQLServer.2012.AlwaysOn.GeneralAlwaysOnDiscovery
       Instance name: InstanceName AlwaysOn Seed
       Management group name: ManagementGroupName

    Have any of you resolved the problem ?

    Regards
    Julien

    Tuesday, December 23, 2014 2:46 PM
  • Hello,

    Refering to the management pack documentation it's not required:

        To run the SQL Management Studio task and the SQL Profiler task, you must have installed SQL Server Management Studio and SQL Server Profiler on all Operations Manager computers where these tasks will be used.

        If you try to run one of these tasks without the appropriate features installed, you will receive the error message "The system cannot find the file specified."

        You do not need SQL Server Management Studio or SQL Server Profiler for discovery and monitoring

    Regards
    Julien

    Tuesday, December 23, 2014 2:50 PM
  • Hi all,

    FYI I did open an incident to Microsoft Support, and it looks like it's a bug with the current management pack (6.5.4.0), they have the same behavior with SQL 2014 as well.
    It will be corrected in the next management pack that will be issued on june/july 2015, I will update the post regarding the result after importing this MP.

    Regards
    Julien


    Friday, April 10, 2015 1:17 PM
  • We are about to implement SQL 2014 servers, and we want til use the AlwaysON technlolgy, but we need to be able to monitor and alert with SCOM - so this issue with the SQL 2014 MP version 6.5.4.0 is also very important for us to get solved asap.

    Hopefully MS will get moving this time, so that we won't have to wait until NeXT release om SCOM to get the MP working as intended.

    These MP's are very important for many of us out here - please be serious about Things like this.  :-)

    Thursday, April 16, 2015 11:22 AM
  • I should have posted this before. Our DBA solved this issue but it may not be the recommended way Microsoft will come out with in the future but it worked for us.

    We had to add Read permissions to the following registry key on the SQL Low LowPriv group identified in the MP Guide.

    HKLM:\Software\Microsoft\Microsoft SQL Server\[InstanceID]\MSSQLServer\hadr

    Hope this helps everyone.

    • Marked as answer by stooney Tuesday, May 12, 2015 7:57 PM
    Tuesday, May 12, 2015 7:56 PM
  • Hello

    I have the same problem, I did install all latest management pack available at the moment, did enable proxy to enable discover, everything is working well but the AlwaysOn discovery ...

    Here is the error I got on the Operation Manager log from the SQL server 

       Non-empty incremental data submitted and will be dropped.

       Discovery name: Microsoft.SQLServer.2012.AlwaysOn.GeneralAlwaysOnDiscovery
       Instance name: InstanceName AlwaysOn Seed
       Management group name: ManagementGroupName

    Have any of you resolved the problem ?

    Regards
    Julien

    Thanks to Stooney - for "solving the case" - but unfortunately my problem is not the same (my system account have access to read registry), but actually my error is exactly the same as Julien mentioned - so i guess i have to wait for the patch from MS that Julian mentioned.
    Wednesday, May 13, 2015 6:44 AM
  • Thanks to Stooney - for "solving the case" - but unfortunately my problem is not the same (my system account have access to read registry), but actually my error is exactly the same as Julien mentioned - so i guess i have to wait for the patch from MS that Julian mentioned.

    Wednesday, May 13, 2015 6:45 AM
  • Erling, I confirm I am in the same case as you, the service is running with local system account so it has access to registry, and in our test with MS support we executed the script that discover the AlwaysOn instances with success, and it returns correct data, it's when the data must be submitted by the agent to the RMS that there is an issue.

    So I agree with you Stooney is resolving another issue but does not answer our specific case.

    Regards
    Julien

    Wednesday, May 13, 2015 8:27 AM
  • Please note that we had to manually set the permissions has they appeared to be inherited as we suspected. 

    Another step we took was to create different SQL RunAs accounts for each domain monitored. Meaning, one set of SQL Monitor, Action and Discovery account for each domain. O

    The error you have, we have not seen it before. If it makes any difference, our service is being ran by a domain account. 

    Wednesday, May 13, 2015 1:08 PM
  • Hi everyone - yesterday Microsoft released the new MS SQL 2014 (and other versions) MP's version 6.6.0.0 - and I have applied them to my SCOM installation this morning.

    approx. 10 minutes after the installation all my availability groups, replicas and database replicas was popping up in my SCOM console.

    Link to the MP: http://www.microsoft.com/en-us/download/details.aspx?id=42573 

    NOTE - the MP's with SQL Server stuff is now multiple MP,s and no longer one big one with everything... so because I have SQL 2008,2012 and 2014 - I had 2 MP's to download, and if you have SSRS, SSAS and other monitoring needs, there is now separate MP's for these monitoring purposes.

    • Proposed as answer by Erling B K Wednesday, July 1, 2015 8:26 AM
    Wednesday, July 1, 2015 8:26 AM
  • Have you tried the latest MP 6.6.00? I'm still having issues with 6.6.0.0. Wondering what your results were.
    Wednesday, July 22, 2015 11:42 PM
  • Did it work with your Always ON 2012 Instances or just with 2014 ones?
    Thursday, July 23, 2015 12:37 AM
  • Hello

    It did work perfectly on my Always On 2012 instances,

    Regards
    Julien

    Thursday, July 23, 2015 8:32 AM
  • I found that that read only permission are not getting inherited from on HKLM:\Software\Microsoft\Microsoft SQL Server  to 

    HKLM:\Software\Microsoft\Microsoft SQL Server\[InstanceID]\MSSQLServer\hadr

    I have added the account to hadr and SQL always on seed discovery start working for me.


    Friday, July 7, 2017 2:10 PM