locked
Login required when open excel file RRS feed

  • Question

  • This site enables anonymous access, but whenever users click to excel download link, SharePoint will prompt login form that does not happen with docx or other download links. I get logs from SharePoint like bellow:

    Information Rights Management (IRM): The IRM status of the document [Documents/aaabbb.xlsx] is: alreadydecrypted (5), the return values is: 0x0. [I do not turn on IRM feature.]

    Creating object wrapper, expecting major version, but no major version given.  URL is /CDRT/Documents/CJTD Hearing List.xlsx.

    There is a content approval workflow enabled on this document library, but even removing the workflow, the error is still the same. By now, there is no workflow enabled on this documents lib, I also try creating a new documents lib in this sub site and try uploading and downloading the excel file, but not successful.

    Could you tell me what is wrong here?

    Thanks,

    Hoan

    Tuesday, May 17, 2016 2:48 AM

Answers

  • Hi hoanvd,

    If this issue only happened with excel file type, then the issue could be related to anonymous users do not have "OpenItems" rights on the Document Library.

    If that is the case, there are three options to fix the issue:

    1. Break permission inheritance on the Document Library.

    2. Disabling the "ViewFormPagesLockDown" feature allows anonymous users to have view source rights to certain files that could potentially contain sensitive info.

    3. Giving anonymous "OpenItems" permission allows anonymous users to have view source rights to certain files that could potentially contain sensitive info.

    For more detailed information, please check the article below:

    Anonymous Users cannot open XLSX files from a SharePoint document library

    Thanks

    Best Regards


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by hoanvd1210 Monday, May 23, 2016 3:49 AM
    Sunday, May 22, 2016 6:40 AM

All replies

  • Hi,

    Have you set anonymous access on the document library even though you enabled it on site level ?

    There is "Disable lockdown" feature available for search result made available to anonymous user, there could be a equivalent  configuration done for document library too, I update this reply as soon as I am on my SharePoint environment.


    Murugesa Pandian | MCPD | MCTS | SharePoint 2010 |


    Tuesday, May 17, 2016 4:56 AM
  • Anonymous access is enabled already in this library. Also, login prompt only happen with excel file, not with docx, pdf and other files.
    Tuesday, May 17, 2016 4:59 AM
  • Hi hoanvd,

    If this issue only happened with excel file type, then the issue could be related to anonymous users do not have "OpenItems" rights on the Document Library.

    If that is the case, there are three options to fix the issue:

    1. Break permission inheritance on the Document Library.

    2. Disabling the "ViewFormPagesLockDown" feature allows anonymous users to have view source rights to certain files that could potentially contain sensitive info.

    3. Giving anonymous "OpenItems" permission allows anonymous users to have view source rights to certain files that could potentially contain sensitive info.

    For more detailed information, please check the article below:

    Anonymous Users cannot open XLSX files from a SharePoint document library

    Thanks

    Best Regards


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by hoanvd1210 Monday, May 23, 2016 3:49 AM
    Sunday, May 22, 2016 6:40 AM
  • I run powershell command to add OpenItems permission for anonymous users and it works now. Thank all you for your support.
    Monday, May 23, 2016 4:11 AM