locked
Appear Offline No Longer Works RRS feed

  • Question

  • With the latest update of Skype for Business 2016 MSO (16.0.8625.2121), the options for Apper Offline no longer work.

    I checked the registry entries in Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\16.0\Lync and they are still there.

    Is there another registry entry that is needed for for this to work?

    Tuesday, December 5, 2017 3:54 PM

All replies

  • Hi abbythespaniel,

    You can enable the Appear Offline option by modifying the Registry.
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\16.0\Lync]
    "EnableAppearOffline"=dword:00000001

    If you cannot find the registry key, you can also use the Cmd.exe command:

    Reg Add "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\16.0\Lync" /V "EnableAppearOffline" /D 1 /T REG_DWORD /F.

    Before you modify the registry or run then command, you’d better exit SFB client, after the change has been done, please restart the SFB client.

    Hope this reply is helpful to you.


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, December 6, 2017 2:28 AM
  • Hi, as I said in the original post, that no longer works with the latest update of SFB.

    That registry entry is there.

    Wednesday, December 6, 2017 2:50 PM
  • Hi abbythespaniel,

    For the registry, I only find this registry.

    Would you please tell us did you try to run the command in CMD (PC for SFB): Reg Add "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\16.0\Lync" /V "EnableAppearOffline" /D 1 /T REG_DWORD /F

    I did a test with my SFB client, it works fine


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Proposed as answer by Alice-Wang Thursday, December 7, 2017 8:59 AM
    Thursday, December 7, 2017 8:24 AM
  • I did and the entry is there. 
    Thursday, December 7, 2017 3:15 PM
  • Hi abbythespaniel,

    Thanks for your response.

    Because there is only one registry for this, you set the registry that didn't work, can you try to run the command:

    Reg Add "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\16.0\Lync" /V "EnableAppearOffline" /D 1 /T REG_DWORD /F


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Proposed as answer by clickfish13 Wednesday, July 4, 2018 11:21 AM
    Monday, December 11, 2017 1:35 AM
  • Hi abbythespaniel,

    In fact, run the following command in cmd is the same as adding the registry:

    Reg Add "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\16.0\Lync" /V "EnableAppearOffline" /D 1 /T REG_DWORD /F

    If it didn't work, please try to delete user profile under this path then test again:
    %userprofile%\AppData\Local\Microsoft\Office\16.0\Lync\sip_UserName@Domain.com


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, December 11, 2017 6:56 AM
  • Hi...


    Same outcome. Deleted the user profile and still no option to appear offline. Also, it seemed to remember by username even though I deleted that profile

    Monday, December 11, 2017 2:16 PM
  • Hi abbythespaniel,

    Can you give me a screenshot for your registry?

    After you run the command line in CMD, is that the same issue?

    After you delete user profile, when you try to sign in, please try to click "Delete sign-in info"


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    • Edited by Alice-Wang Tuesday, December 12, 2017 9:11 AM
    Tuesday, December 12, 2017 9:07 AM
  • Hi...

    Yes, I deleted the folder and clocked on delete sign on info.

    And yes, after the command line.

    Wednesday, December 13, 2017 4:42 PM
  • Hi abbythespaniel,

    I try the same method which I have been provided, it works fine.

    For this, we suggest you use another computer test if the registry works

    For this computer, please try to perform a clean boot then test again.
    https://support.microsoft.com/en-us/kb/929135


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, December 14, 2017 9:55 AM
  • Thanks, I will try next year when I am back from vacation.
    Friday, December 15, 2017 2:25 PM
  • Ok, waiting for your response. Have a nice vocation!

    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, December 18, 2017 7:35 AM
  • Hello,

    I am also having the same troubles as abbythespaniel is describing. Using Windows 10 Enterprise and Office 2016. Looks like my version of SFB is different than abbythespaniel's though (not sure if that's relevant).

    abbythespaniel's version: 16.0.8625.2121

    My version: 16.0.8201.2213

    1)The regedit exists

    

    2)I ran the cmd command as well (even though it's the same thing as adding the DWORD using regedit)

    3)I've deleted the sign on info (but it still retained my sign in info), I also cleared out what was in credential manager. 

    4)Restarted SFB multiple times as well as performing a clean boot of my PC as mentioned in a previous reply

    5)Deleted the cache data from C:\Users\<username>\AppData\Local\Microsoft\Office\16.0\Lync (leaving the $/Tracing directory, but deleting the contents within it). I found this tip on another website. 

    Definitely looks like something was updated recently w/ the application which is preventing the "appear offline" status option from showing/functioning. Are there any additional troubleshooting steps you need done?

    Wednesday, December 27, 2017 3:53 PM
  • I had to add the registry to the user hive as well. This worked with latest patch for Skype 2016.
    Thursday, June 7, 2018 1:31 PM
  • It works fine after I completely sign out the Skype, delete the sip user profile and run the REG ADD command.
    Tuesday, July 31, 2018 1:45 AM