locked
How do I setup HTTP Redirection for the SM2012 Self-Service Portal? RRS feed

  • Question

  • I've installed HTTP Redir, created a CNAME record in DNS which sets the alias as "support" and FQDN of target host as "servername" and configured http://servername:8000/smportal to point to http://support.mycompany.com however when the SSP comes up it's blank and doesn't appear to load completely.  When I go to http://servername:8000/smportal it loads just fine.  Any ideas?
    Friday, June 22, 2012 2:53 PM

Answers

  • I have been having this issue as well. I ended up modifying the SharePoint Home.aspx file and adding .NET directives to redirect to the /SMPortal directory. Definitely not a nice workaround, but I wasn't able to find a better way to do it.
    • Marked as answer by Seth Steward Monday, July 2, 2012 3:34 PM
    Saturday, June 23, 2012 2:55 PM
  • So in the end, here is what I did (thanks to my buddy Steve for the last part and thanks to Dieter for the first part):

    • Make Domain Admins a Farm Admin group on SSP
    • Created CNAME for scsmssp01.company.com --> support.company.com
    • Opened default Site (port 80) in SharePoint Designer on scsmssp01 and replaced Home.aspx with:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

    <html xmlns="http://www.w3.org/1999/xhtml">

    <head>

    <meta HTTP-EQUIV="REFRESH" content="0; url=http://scsmssp01.company.com:8000/SMPortal/">

    </head>

    <body>

    <div id="container">

     

    </div>

    </body>

    </html>

    One other make or break item is in IIS on the Service Manager Portal site > Application Settings, the value for the Application Setting should be the FQDN if the URL above is an FQDN.  If one is NetBIOS (default value in Application Settings) but the URL Redirect is FQDN, not all the web parts will load.  They must match!
    • Marked as answer by Seth Steward Monday, July 2, 2012 3:34 PM
    • Edited by Seth Steward Wednesday, July 18, 2012 11:33 PM
    Monday, July 2, 2012 3:34 PM

All replies

  • I have been having this issue as well. I ended up modifying the SharePoint Home.aspx file and adding .NET directives to redirect to the /SMPortal directory. Definitely not a nice workaround, but I wasn't able to find a better way to do it.
    • Marked as answer by Seth Steward Monday, July 2, 2012 3:34 PM
    Saturday, June 23, 2012 2:55 PM
  • Two questions - where is Home.aspx located and which directives did you add?  Thanks in advance.
    Monday, June 25, 2012 10:04 PM
  • Navigate to the top-level site in SharePoint. You should see the Home.aspx in the URL of your browser. Then, go to Site Actions, Edit in SharePoint Designer.

    In SharePoint Designer, go to Site Pages, then you will see Home.aspx. Edit the source code ("Edit File in Advanced Mode") and add

    <% Response.Redirect("/SMPortal"); %>

    just below the first <asp:Content> section. This should do the trick.

    Tuesday, June 26, 2012 1:44 PM
  • Thanks - only issue is now I'm receiving this error.
    Tuesday, June 26, 2012 3:45 PM
  • You need to enable server-side scripts for the Home.aspx by modifying the web.config file

    <PageParserPaths> 
      <PageParserPath VirtualPath="/SitePages/Home.aspx" CompilationMode="Always" AllowServerSideScript="true" />
    </PageParserPaths>


    Thursday, June 28, 2012 9:52 AM
  • So in the end, here is what I did (thanks to my buddy Steve for the last part and thanks to Dieter for the first part):

    • Make Domain Admins a Farm Admin group on SSP
    • Created CNAME for scsmssp01.company.com --> support.company.com
    • Opened default Site (port 80) in SharePoint Designer on scsmssp01 and replaced Home.aspx with:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

    <html xmlns="http://www.w3.org/1999/xhtml">

    <head>

    <meta HTTP-EQUIV="REFRESH" content="0; url=http://scsmssp01.company.com:8000/SMPortal/">

    </head>

    <body>

    <div id="container">

     

    </div>

    </body>

    </html>

    One other make or break item is in IIS on the Service Manager Portal site > Application Settings, the value for the Application Setting should be the FQDN if the URL above is an FQDN.  If one is NetBIOS (default value in Application Settings) but the URL Redirect is FQDN, not all the web parts will load.  They must match!
    • Marked as answer by Seth Steward Monday, July 2, 2012 3:34 PM
    • Edited by Seth Steward Wednesday, July 18, 2012 11:33 PM
    Monday, July 2, 2012 3:34 PM
  • One more way to do it is to simply add the following lines into <head> section of existing v4.master page of the main portal ('Team Site'):

    <script type="text/javascript">
    window.location="https://SERVER/path"
    </script>

    You may want to keep the rest of the file intact (to quickly return to the original version if you do not wish to use built-in versioning system).

    You must be secondary site collection administrator to see Master Pages section in SharePoint Designer. Site collections admins are assigned at Application Management -> Change site collections administrators page in SharePoint Central Administration UI.

    Thursday, April 18, 2013 8:44 AM
  • Thank you, thank you, thank you!!!!!!! This did the trick...
    I have one more issue and is with domain PC's getting to the service portal... it prompts for credentials every time the try to get in... any ideas... Best!
    Friday, May 10, 2013 4:57 PM
  • For domain user single sign-on, just add the site as Intranet

    Hope it help :P

    Thursday, August 15, 2013 5:26 PM