none
MAP 9.9 Change/Remove Setup Fails on 9.9 Installation RRS feed

  • Question

  • When I run MAP setup to change or remove the current installation it fails immediately with the message:

    Setup failed to update the product. The advice is to consult the Setup log file, which, when I eventually found it on the path C:\users\(logged in user)\AppData\Local\Temp gives me no help at all. One error seemed promising:

    Couldn't get instance's registry node ID. Error Code: 0x80070003. MAPS

    but the installer kept going regardless.

    Or this: Error 1406. Could not write value SQM to key \SOFTWARE\Microsoft\MAPS

    Finally I get: Reconfiguration success or error status: 1603

    Failing a successful reading of the Setup log, is there a means of removing MAP without using Setup?

    Note: I'm using a local Admin account both to install and uninstall.


    LAR

    Friday, August 24, 2018 11:40 AM

All replies

  • Hi,

    Please restart your machine and try to uninstall the MAP Toolkit once again.

    Regards,
    MAP Toolkit Team


    Aditya Karanam

    Thursday, September 6, 2018 12:43 PM
  • I had same issue of UnInstall of MAP tool and I worked out as follows and It worked for me on TWO occasions if you have same error.

    Edit the Registry Setting:

    - type  regedit  on your search button

    - Navigate in Registry Editor

      - Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MAPS\ 

            On right hand side Right Click on InstallStatus and Choose MODIFY

             Select Value Data = 0  base as Decimal and Click OK and close all.

         - Restart the Server 

         -  once start - Go to Control Panel and choose Program - Uninstall program

         - Select Microsoft Assessment Planning Toolkit and right click and choose UnInstall --

         -  It will fire up the MAP repair/uninstall option and choose UnInstall and Tick remove the database permanently and Click Ok.   BINGO... it works and ensure to restart the server to clean up any other things around and verify the registry setting and you will NOT find the MAP folder in the same spot. 

    Enjoy 

    Cheers

    Sunil Singh Thakur (SST)

    Microsoft Data Platform Consultant



    Wednesday, July 3, 2019 2:22 AM
  • I am afraid, just restart does not work for uninstall and I have restarted many times and the issue remained the same. I have worked out and follow my above reply.

    thanks,

    Kind Regards

    SST

    Microsoft Data Platform Consultant

    Wednesday, July 3, 2019 2:24 AM