locked
Kernel panic not syncing after yum update to RHEL 6.7 RRS feed

  • Question

  • After installing a fresh install of RHEL 6.6, installing LIS 4.0.11 and then yum updating to latest 6.7; we now see a kernel panic upon boot. I tried running the below command to rebuild the img file with the HV drivers in them, but it still gives the same panic. Anyone have any ideas?

    dracut --add-drivers "hv_storvsc hv_vmbus ata_piix" --force /boot/initramfs-2.6.32-573.3.1.el6.x86_64.img 2.6.32-573.3.1.el6.x86_64
    The kernel panic
    Kernel panic - not syncing: Attempted to kill init!
    Pid: 1, comm: init Not tainted 2.6.32-573.3.1.el6.x86_64 #1
    Call Trace:
     [<ffffffff????????>] ? panic+0xa7/0x16f
     [<ffffffff????????>] ? do_exit+0x867/0x870
     [<ffffffff????????>] ? fput+0x25/0x30
     [<ffffffff????????>] ? do_group_exit+0x58/0xd0
     [<ffffffff????????>] ? sys_exit_group+0x17/0x20
     [<ffffffff????????>] ? system_call_fastpath+0x16/0x1b

    Wednesday, September 9, 2015 8:48 PM

All replies

  • Ok, I figured this out about 10 min after I posted this. I just reinstalled the LIS 4.0.11 using the RHEL67 content with a --force. I then reran the dracut command and rebooted, it booted as normal into 6.7 with no kernel panic.
    Wednesday, September 9, 2015 9:16 PM
  • Hi, I'm having the same issue. I get the kernel panic when trying to boot. I did a yum update from Centos 6.6 to 6.7, although I was running LIS 4.0.7. I'd appreciate your help as I'm a Linux novice. How can I run the dracut command if I can't get the VM to boot up?
    Monday, September 14, 2015 6:58 PM
  • After some googling, I found out my problem was I was running LIS 4.0.7 before doing the yum update to Centos 6.7. The version of LIS I was running did not support Centos 6.7. For the novices like me, here is a detailed description of what I did:

    -Booted up my VM and pressed ESC at the boot screen to stop it from booting using the latest kernel version, which would crash with the kernel panic.

    -At GNU GRUB screen, I chose the 2nd option from the top which was my previous kernel version. The 1st option is the newest kernel version. This will boot your VM using the previous kernel version and allow you to log in. 

    -Once I logged in, I download the LIS 4.0.11 tar.gz file. Extract it and go to the RHEL67 folder. Modify through vi the install.sh script. Look for the rpm command (it's listed twice) and add '--force' at the end of the line. Save the changes to the file and run it. This will install the Centos 6.7 compatible version of LIS 4.0.11. When it's done reboot your VM.

    -It should boot up using the latest kernel version automatically without throwing a kernel panic. 

    • Proposed as answer by Eightbitsshort Thursday, March 31, 2016 9:00 PM
    Monday, September 14, 2015 9:06 PM
  • Can you give me an example, I don't see the rpm command you referenced
    Tuesday, September 15, 2015 6:27 PM
  • Sure! Make sure you are in the RHEL67 folder and open the install.sh script. Below is a copy of the content of the install.sh script, I put in bold the line where the rpm command is located and you can see I've added '--force' at the end of the line.

    # Determine kernel architecture version 
    osbit=`uname -m`

    #Selecting appropriate rpm, 64 bit rpm for x86_64 based VM
    if [ "$osbit" == "x86_64" ]; then
           {
                  kmodrpm=`ls kmod-microsoft-hyper-v-4*.x86_64.rpm`
                  msrpm=`ls microsoft-hyper-v-4*.x86_64.rpm`
           }
    elif [ "$osbit" == "i686" ]; then
           {
                  kmodrpm=`ls kmod-microsoft-hyper-v-4*.i686.rpm`
                  msrpm=`ls microsoft-hyper-v-4*.i686.rpm`
           }
    fi

    #Making sure both rpms are present

    if [ "$kmodrpm" != "" ] && [ "$msrpm" != ""  ]; then
           echo "Installing the Linux Integration Services for Microsoft Hyper-V..."
           rpm -ivh $kmodrpm --force
           kmodexit=$?
           if [ "$kmodexit" == 0 ]; then
                  rpm -ivh $msrpm --force
                  msexit=$?
                  if [ "$msexit" != 0 ]; then
                         echo "Microsoft-Hyper-V RPM installation failed, Exiting."
                         exit 1;
                  else
                         echo " Linux Integration Services for Hyper-V has been installed. Please reboot your system."
                  fi
           else
                  echo "Kmod RPM installation failed, Exiting."
                  exit 1
           fi
    else 
           echo "RPM's are missing"
    fi

    #The End

    After running the script you will need to restart your VM.

    • Proposed as answer by Eightbitsshort Thursday, March 31, 2016 9:00 PM
    Tuesday, September 15, 2015 6:51 PM
  • As you determined, you need to install LIS 4.0.11 on RHEL 6.7 and not 4.0.7. Also, whenever you upgrade the kernel, we recommend uninstalling LIS, upgrading the kernel, and reinstalling LIS.

    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    Monday, September 21, 2015 6:46 PM