locked
Hyper-V 2012 NIC Driver RRS feed

  • Question

  • Hello,

    I have installed Hyper-V 2012 and get the message "No Active Network Adapters Found". The system has a common Intel Pro1000 card. I've tried installing the driver using pnputil -i -a driver_file.inf, but after a reboot I get the same message. I've also tried installing the driver with devcon. devcon find shows my Ethernet adapter and the hardware ID matches what is in the inf file, but fails to install the driver. ESXi and XenServer both "just worked" on this hardware, though I'd like to test Hyper-V as I hear it has a better feature set. Thanks in advance!

    Tuesday, November 13, 2012 9:06 PM

Answers

  • This is not a "server", but an i7 system with a bunch of RAM and an Intel brand motherboard (testing setup). The drivers provided by Intel do support Server 2012, however the inf is missing an entry. After modifying the inf and disabling driver signing I was able to load the driver with pnputil. Sadly, it seems all of this effort was in vain as I've learned Hyper-V 2012 cannot be managed using RSAT on Windows 7. I picked up a few copies of Win8 with the $15 upgrade deal for testing, but it's not something I could use day to day. Thank you both for your help.

    • Marked as answer by Lawrence, Tuesday, November 27, 2012 8:44 AM
    Wednesday, November 14, 2012 9:52 PM

All replies