none
EDIFACT UNB segment BTS 2010

    Question

  • Hi All,

     

    I’m having an issue with the UNB segment when processing a message in BizTalk 2010.

    In BTS2009 when you unchecked the UNB 9 (Acknowledgement Request) and UNB 11 (Test Indicator) these “segments” where not part of the UNB segment. In BTS2010 when you uncheck both UNB9 and UNB 11 they are part of the message but being put to 0.

    We cannot have those last values because we receive an EDIFACT Control message that both values are not supported in that position.

    BTS2009:

    UNB+UNOC:3+xx+DBB+110119:0852+A1000000768'

     

    BTS 2010:

    UNB+UNOC:3+xx+DBB+110119:0852+A1000000768++++0++0'

     

    Did anyone had this issue before or can help me with my EDIFACT fallback settings on my BizTalk 2010 so that he does not generate those extra ‘segments’.

    I guess the last option would be to create custom pipeline component to clean up that UNB segment once we passed the EDI Assembler.

    Regards,

    Colpaert Glenn

     

     

     

     

     

     

     

    Wednesday, January 19, 2011 1:29 PM

All replies