locked
Outlook 2007 on Windows 2003 R2 Terminal Services with SBS 2008 exchange server: is instant search available RRS feed

  • Question

  • One of my customers is going to switch to SBS 2008 with exchange 2007. They also have an Open Value Subscription license for Office 2007.
    They currently use Windows 2003 R2 as a Terminal Server with Office 2003.

    Due to other applications they will need to stay on Windows 2003, but would like to start using Office 2007.

    I've read that Outlook 2007 does not support cached exchange mode on Terminal Services.
    Is it possible to still have instant search with an Exchange 2007 backend.

    I believe there is something called online search which should be enabled on the Exchange 2007 server for this to work, but can't find any definitive answer regarding the topic.

    Thursday, February 11, 2010 3:07 PM

Answers

  • Cached Exchange mode is possible within a TS environment on Windows Server 2003. It is also Possible with Windows Server 2008 R2. It is however not recommended.

    Please note, the following instructions apply to the following products only (although can most likely apply to others). As always, edit the registry at your own risk, but I have not had any issues with this.

    -Server 2003 TS & Server 2008 R2 RDS

    -Outlook 2003/2007

     

    Server 2003 TS & Outlook 2003/2007:

    1.) Open the registry editor on the account needing access to cached mode.

    2.) Navigate to the following key:

    HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\%profilename%\13dbb0c8aa05101a9bb000aa002fc45a

    3.) Edit the following key:

    00036601     (REG_BINARY)

    4.) Depending on what you are after, change the value to one of the following:

    enabled value;  84 01 00 00
    enabled with Public Folders/Favorites: 84 05 00 00
    disabled value; 04 00 00 00

     

    Server 2008 R2 RDS & Outlook 2003/2007:

    (Note - You will need to know how to identify user by SID. Instructions on this at the bottom)

    (Note- User must be logged in to appear in HKEY_Users)

    1.) Open the registry editor on the admin account.

    2.) Navigate to the following key:

    HKEY_USERS\%userSID%\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\%profilename%\13dbb0c8aa05101a9bb000aa002fc45a

    3.) Edit the following key:

    00036601     (REG_BINARY)

    4.) Depending on what you are after, change the value to one of the following:

    enabled value;  84 01 00 00
    enabled with Public Folders/Favorites: 84 05 00 00
    disabled value; 04 00 00 00

     

    How to identify User's SID:

    1.) Open Registry Editor and navigate to:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

    2.) Under the ProfileList key, you will see the SIDs. By selecting each one individually, you can look at the value entry and see what user name is associated with that particular SID

    Friday, August 20, 2010 8:04 PM

All replies

  • Cached Exchange mode is possible within a TS environment on Windows Server 2003. It is also Possible with Windows Server 2008 R2. It is however not recommended.

    Please note, the following instructions apply to the following products only (although can most likely apply to others). As always, edit the registry at your own risk, but I have not had any issues with this.

    -Server 2003 TS & Server 2008 R2 RDS

    -Outlook 2003/2007

     

    Server 2003 TS & Outlook 2003/2007:

    1.) Open the registry editor on the account needing access to cached mode.

    2.) Navigate to the following key:

    HKCU\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\%profilename%\13dbb0c8aa05101a9bb000aa002fc45a

    3.) Edit the following key:

    00036601     (REG_BINARY)

    4.) Depending on what you are after, change the value to one of the following:

    enabled value;  84 01 00 00
    enabled with Public Folders/Favorites: 84 05 00 00
    disabled value; 04 00 00 00

     

    Server 2008 R2 RDS & Outlook 2003/2007:

    (Note - You will need to know how to identify user by SID. Instructions on this at the bottom)

    (Note- User must be logged in to appear in HKEY_Users)

    1.) Open the registry editor on the admin account.

    2.) Navigate to the following key:

    HKEY_USERS\%userSID%\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\%profilename%\13dbb0c8aa05101a9bb000aa002fc45a

    3.) Edit the following key:

    00036601     (REG_BINARY)

    4.) Depending on what you are after, change the value to one of the following:

    enabled value;  84 01 00 00
    enabled with Public Folders/Favorites: 84 05 00 00
    disabled value; 04 00 00 00

     

    How to identify User's SID:

    1.) Open Registry Editor and navigate to:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

    2.) Under the ProfileList key, you will see the SIDs. By selecting each one individually, you can look at the value entry and see what user name is associated with that particular SID

    Friday, August 20, 2010 8:04 PM
  • Thanks for taking the time to answer this old question.

    I'd rather not enable cached exchange mode on the Terminal Server due to the number of users and mailbox sizes which would be cached.

    Is it possible to enable some type of instant search without cached mode? Can I enable some sort of indexing on the exchange server that will speed of searches in mailboxes?

    Monday, August 23, 2010 8:14 AM
  • Hi,

    I did try changing the registry but it didn't work, even to the Administrator account. The "Use Cached Exchange Mode" is greyed out. We are using Outlook 2007 on RDS 2008 R2. Any suggestion?

     

    Thanks,

     

    Frank

    Wednesday, December 15, 2010 10:15 PM
  • Hi Ken.Hoopes,

    Thanks for the useful thread.

    I have tried by changing the  00036601     (REG_BINARY) to 84 01 00 00 then i closed the registry windows.

    Ite not worked for me, Then i returned to the registry i found the changed entry 84 01 00 00 automatically changed as 84 21 00 00.

    I noticed that after closing the value edit window the value automatically changed to 84 21 00 00.

    could you please help me to solve the same.


    Best Regards, Prabhu.Rajan

    Wednesday, July 11, 2012 5:28 PM
  • Has anyone been able to get this to work?

    Have a single server terminal environment and need to move to an outlook anywhere environment for a remote site. Hoping to use cache mode to improve performance (note, terminal servers are in remote office)

    Key keeps on being written back to disabled mode.


    Steven Wells

    Thursday, October 3, 2013 5:47 AM
  • This does not work. Also refer http://technet.microsoft.com/en-us/library/cc179161(v=office.12).aspx

    This article clearly states the following:

    Outlook features that are disabled with Terminal Services

    You cannot use the following Outlook features when you run Outlook in a Terminal Services environment:

    • Offline store (OST) files.

      Features that rely on the OST (for example, Cached Exchange Mode and Offline mode) are not supported with Terminal Services.

    Thursday, March 13, 2014 6:53 PM