none
PS2010 / SSRS in sharepoint integration mode RRS feed

  • Question

  • I am unable to configure central admin reporting services.

    I have the DB server with SQL Server 2008 SSRS installed and configured with SharePoint integration.  I installed SharePoint server and project server and joined to the ps2010 farm.  The project server databases also reside on this box.

    The APP server (PS2010) has the SSRD add-in installed.  In central admin, when I go to General application settings >> Reporting services integration to add the web service URL and user credentials. It fails with the following error: Failed to establish connection with report server. Verify the server URL is correct or review ULS logs for more information. Product area: SQL Server Reporting Services, Category: Configuration Pages

    I can successful navigate to the web service URL.  The credentials that I am providing is the farm account for PS2010 and it is set as the Reports Server Database credential in SSRS Reporting Config Manager.

    There are several other errors in the ULS logs:

    Exception encountered for SOAP method GetSystemProperties: System.Net.WebException: The request failed with HTTP status 401: Unauthorized.  at Microsoft.SqlServer.ReportingServices2010.RSConnection2010.SetConnectionProtocol()   at Microsoft.SqlServer.ReportingServices2010.RSConnection2010.SoapMethodWrapper`1.ExecuteMethod(Boolean setConnectionProtocol)

    Exception in TestCurrentUrlConnection: System.Net.WebException: The request failed with HTTP status 401: Unauthorized. at Microsoft.ReportingServices.SharePoint.UI.RSConnectionInfo.get_SPManagementProxy() at Microsoft.ReportingServices.SharePoint.UI.RSUtility.CheckReportServerVersion(String& errorMessage)

     Failed to retrieve RS configuration information: System.InvalidOperationException: Client found response content type of '', but expected 'text/xml'. The request failed with an empty response. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Microsoft.SqlServer.ReportingServices2010.ReportingService2010.GetReportServerConfigInfo(Boolean ScaleOut) at Microsoft.ReportingServices.SharePoint.UI.RSIntegrationSettings.GetReportServerConfigInfo(IList`1& configInfos)

    Thursday, May 2, 2013 7:17 PM

Answers

  • My problem has been resolved. 

    In Central Admin >> General application settings >> Reporting services integration to add the web service URL and user credentials, I chose Windows Authentication (kerberos) instead of Trusted Account (NTLM).  When I resubmitted the page using Trusted Account, it worked.  :)

    • Marked as answer by JennPenn07 Monday, May 13, 2013 6:02 PM
    Monday, May 13, 2013 6:02 PM

All replies

  • Hi there,

    Please can you confirm you farm topology, from your post is this correct:

    • SQLServer1 with the SQL Database engine and SQL Analysis Services installed
    • AppServer1 with SharePoint / Project Server / SQL SSRS installed

    If this is the case, are you using a URL like http://appserver1/reportserver when configuring SSRS in Central Admin?

    This link might help:

    http://msdn.microsoft.com/en-us/library/bb677365(v=sql.105).aspx

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Thursday, May 2, 2013 8:09 PM
    Moderator
  • SSRS in installed on the database server.  See my corrections here:

    • SQLServer1 with the SQL Database engine and SQL Analysis Services installed and SQL SSRS installed
    • AppServer1 with SharePoint / Project Server / SQL SSRS add in ONLY
    Thursday, May 2, 2013 8:12 PM
  • Hi there,

    In that case SSRS in installed in Native mode, not Integrated mode. For SSRS to be installed in SharePoint integrated mode, SSRS would need to be installed on AppServer1. The SSRS databases can exist on SQLServer1, but SSRS would need to be installed on the SharePoint server.

    Hope that helps.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Thursday, May 2, 2013 8:18 PM
    Moderator
  • So are you saying the database server cannot act as both the reports Server and the database server?

    According to this article, I should be able to create a reports server seperate from the APP server as long as I join it to the PS farm.  http://technet.microsoft.com/en-us/library/bb283324(v=sql.105).aspx  The APP server must have the ssrs add in installed and the reports server must have SharePont installed.

    I have attempted to do what is in the link but instead of three servers (DB, Reports, APP) I have APP, DB/Reports.  The DB/Reports server has been joined to the farm.   SSRS has been configured for sharepoint integration.

    I hope that makes sense...  :)

    Thursday, May 2, 2013 8:32 PM
  • Hi there,

    The database server can serve as the farm database server and the Report Server in SharePoint Integrated mode if you have a single server for the farm with SQL, SharePoint, SSRS installed on the one server:

    http://msdn.microsoft.com/en-us/library/bb677368(v=sql.105).aspx

    Do you have SharePoint installed on the Report Server?

    This deployment guide will work for multi server farms (your scenario):

    http://msdn.microsoft.com/en-us/library/bb677365(v=sql.105).aspx

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Thursday, May 2, 2013 8:53 PM
    Moderator
  • Yes, I have SharePoint installed on the reports server.  In researching my error, it appears that SQL Server 2008 R2 is the correct version to use when configurign ssrs for sharepoint integration.  However i am also reading that SP1 for SQL Server 2008 solves the issue.  I have SQL Server 2008 (64bit) with SP3.
    Monday, May 6, 2013 7:57 PM
  • My problem has been resolved. 

    In Central Admin >> General application settings >> Reporting services integration to add the web service URL and user credentials, I chose Windows Authentication (kerberos) instead of Trusted Account (NTLM).  When I resubmitted the page using Trusted Account, it worked.  :)

    • Marked as answer by JennPenn07 Monday, May 13, 2013 6:02 PM
    Monday, May 13, 2013 6:02 PM