none
Exchange 2007 mailbox quota RRS feed

Answers

  • Hi Naraka,

    From your description, I understand that you want to set mailbox Quotas (1 GB limit) for all users in that security group. Please correct me if I misunderstand.

    As far as I know, for a security group, there is no way to set mailbox quota, we need to assign the policy to all individual mailboxes in that group:

    Create a .csv file to include all the users in the security group, for example c:\ group.csv. the format can be:
    Name
    User1
    User2
    ….
    Then run this cmdlet:
    Import-Csv c:\group.csv | foreach {Set-Mailbox -Identity $_.Name -IssueWarningQuota 1073741824 -ProhibitSendQuota 1073741824 -ProhibitSendReceiveQuota 1073741824 -UseDatabaseQuotaDefaults $false}
    After that all the users in security group the mailbox limit are set to 1GB (You can use this command to check “get-mailbox –id user@domain.com |fl *quota*”).

    Thanks,

    Evan Liu
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contacttngfb@microsoft.com

    Friday, April 29, 2011 7:07 AM
    Moderator
  • Hi Narka,

     

    If your group( Tier 1 Mailboxes) is Mail-Enabled Universal Security Group, you also can run this command to achieve the goal:

     

    get-distributiongroupmember -identity "Tier1Mailboxes"  | foreach {Set-Mailbox -Identity $_.Name -IssueWarningQuota 1073741824 -ProhibitSendQuota 1073741824 -ProhibitSendReceiveQuota 1073741824  -UseDatabaseQuotaDefaults $false}

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Naraka Monday, May 9, 2011 3:19 PM
    Monday, May 2, 2011 3:29 AM
    Moderator

All replies

  • YES. If a mailbox is owned by a security group (that is, if it is a shared mailbox), quota messages are sent to the security group, that is the speciality.
    Regards from www.windowsadmin.info
    Wednesday, April 27, 2011 11:06 AM
  • Hi Naraka,

     

    Yes, you can set mailbox quotas for every security group member.

     

    In Exchange 2007, the storage quotas can be configured on mailbox level and database level.

     

    If you want to configure quotas for mailbox, please refer to this document:

     

    How to Configure Storage Quotas for a Mailbox

    http://technet.microsoft.com/en-us/library/aa998353(EXCHG.80).aspx

     

    By default all the mailboxes are using the database setting, and administrator are allowed to specify custom quota limits for specific mailboxes. you can know more detail from this document:

     

    How to Configure Storage Quotas for a Mailbox Database

    http://technet.microsoft.com/en-us/library/bb201753(EXCHG.80).aspx

     

    If you have any other requirements, please explain your problem in detail.

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, April 28, 2011 5:31 AM
    Moderator
  • Thanks for the great responses. Let me clarify though - I have for instant a security group called 'Tier 1 Mailboxes' which I want to assign a mailbox policy that limits total mailbox size to 1GB. I then want to populate that security group with he respective user accounts that should have the 1GB limit set instead of defining at a database level.
    Thursday, April 28, 2011 8:15 AM
  • Hi Naraka,

    From your description, I understand that you want to set mailbox Quotas (1 GB limit) for all users in that security group. Please correct me if I misunderstand.

    As far as I know, for a security group, there is no way to set mailbox quota, we need to assign the policy to all individual mailboxes in that group:

    Create a .csv file to include all the users in the security group, for example c:\ group.csv. the format can be:
    Name
    User1
    User2
    ….
    Then run this cmdlet:
    Import-Csv c:\group.csv | foreach {Set-Mailbox -Identity $_.Name -IssueWarningQuota 1073741824 -ProhibitSendQuota 1073741824 -ProhibitSendReceiveQuota 1073741824 -UseDatabaseQuotaDefaults $false}
    After that all the users in security group the mailbox limit are set to 1GB (You can use this command to check “get-mailbox –id user@domain.com |fl *quota*”).

    Thanks,

    Evan Liu
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contacttngfb@microsoft.com

    Friday, April 29, 2011 7:07 AM
    Moderator
  • Hi Narka,

     

    If your group( Tier 1 Mailboxes) is Mail-Enabled Universal Security Group, you also can run this command to achieve the goal:

     

    get-distributiongroupmember -identity "Tier1Mailboxes"  | foreach {Set-Mailbox -Identity $_.Name -IssueWarningQuota 1073741824 -ProhibitSendQuota 1073741824 -ProhibitSendReceiveQuota 1073741824  -UseDatabaseQuotaDefaults $false}

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Naraka Monday, May 9, 2011 3:19 PM
    Monday, May 2, 2011 3:29 AM
    Moderator
  • Hi Naraka,

     

    Any updates on this issue?

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, May 6, 2011 1:32 AM
    Moderator
  • I like the suggestion from Evan and it seems to work. I however did not notice any difference although I can see that the new quota setting is applied to the test account which has a 2GB mailbox and has a 1GB limit. Is there something else I need to run before I see the administrative message in the test account mailbox (size warning)?
    Monday, May 9, 2011 3:52 PM
  • I like the suggestion from Evan and it seems to work. I however did not notice any difference although I can see that the new quota setting is applied to the test account which has a 2GB mailbox and has a 1GB limit. Is there something else I need to run before I see the administrative message in the test account mailbox (size warning)?
    Monday, May 9, 2011 3:52 PM
  • Hi Naraka,

     

    How long did you wait?

     

    As far as I know it will  take up to two hours for the new limits to apply, this is expected behavior.

     

    Maybe you can restart Microsoft Exchange Information store service to accelerate update.

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, May 10, 2011 3:28 AM
    Moderator
  • As said by Evan, storage limit's are not instant.  An IS service restart will cause the limits to be re-read instantly.
    Tuesday, May 10, 2011 12:18 PM