none
GPP mapped drives disappear

    Question

  • Hello Everyone,

    I have an issue with mapped drives disappearing. It happens randomly a we need to tell the end user to do a GPUpdate /force to fix. So here is my setup:

    • Windows 2008 R2 with Win 7,8,10 (64 and 32 bit) on the client side
    • We use GPP (GPO with no VBS or BAT scripts)
    • The mapped drive is setup with Action: "Replacing" 
    • Location: Home Drive
    • No Reconnect
    • Hide/Show this drive: Show this Drive
    • Hide/Show all drives: No change
    • (common Tab) Item Level Targeting enabled with Security groups
    • 175 login scripts for different departments
    • 12 domain controllers
    • 60 satellite sites that feed off our main site

    We have looked and eliminated the following.

    • Network
    • Server bandwidth: we show no over usage of disk, memory, and CPU
    • SAN: no stress on the connection or usage

    We have not eliminated:

    • Replication
    • Windows Update
    • 3rd Party Application i.e. MacAfee

    Replication, yes there are some connection issues to other DC’s but they remedy themselves. The mapped drive issues started happening recently. Windows updates, I can’t trace down to a specific patch. And as for MacAfee, I’m not ready to go down that road unless something underling I can prove. The duplication of the error is inconsistent and it happens to random people infrequently.

     So my question is. What gives? Too many login scripts? Recognized Microsoft issue? I was hoping that someone could shed some light on a fix or point me in the right direction.

    Thanks in advance,

    Ed


    • Edited by TLC1080 Thursday, September 8, 2016 9:24 PM
    Thursday, September 8, 2016 9:22 PM

All replies

  • Hi ED,

    Thanks for your post.

    The problem occurs random?

    Did you configure the GPP under computer configuration or user configuration?

    Sometimes, the computers/users could apply the policy correctly?

    I suggest you run gpresult /h C:\gpresult.html when the policy not applied.

    If the policy is configured under computer configuration, please run gpresult with administrative users.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 9, 2016 8:56 AM
    Moderator
    • The mapped drive is setup with Action: "Replacing" 

    You could try with "Update" instead. "Replace" deletes and recreates the mapped drive.

    See the documentation:

    Configure a Mapped Drive Item


    Rolf Lidvall, Swedish Radio (Ltd)

    Friday, September 9, 2016 12:36 PM
  • Thanks Jay,

    The policy is under the user configuration. I will try your suggestion and look at the print out.

    Regards,

    Ed

    Friday, September 9, 2016 6:17 PM
  • Hi Rolf,

    we thought of that too, except we have a some drives that are mapped through group policy. When we do a gpupdate /force or just gpupdate. the drives do not comeback. therefore the user will needs to logoff and log back in. After talking with management, we can live with this. So we have made a change request to change from "Replacing" to "Update" change happen. 

    Regards

    Ed.

    Friday, September 9, 2016 6:22 PM
  • Hi ED,

    Are there any problem in GPresult? if yes, please post it to us for further research.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 15, 2016 1:08 PM
    Moderator
  • Alright Gentlemen, 

    Sorry for the late response as i have been tied up with other projects and I owe this blog an answer. We moved away from Replace and moved to Update we also enabled Reconnect. under the Common Tab, we used item-level targeting.  Rolf was on the right path, however politics played in hand before we made our decision. 

    Thanks,

    Tuesday, January 17, 2017 10:24 PM