locked
802.1x SmartCard and Password on the same NIC RRS feed

  • Question

  • First little background:

    We have been using NPS server and 802.1x for some time now, requiring computer and user authentication.

    Now, we are considering implementing Smart Cards and we are stuck at this:

    - if we enable Smart Card authentication on NIC and create appropriate rule on NPS server everything works OK

    - if we enable username/password authentication on NIC and create appropriate rule on NPS server everything works OK

    But what if user loses it's Smart Card or forgets it at home? We considered an option where we in AD temporarily enable username/password authentication but the problem is that NIC settings are set to Smart Card authentication. Is there any way to enable both Smart Card and username/password authentication on NIC?

    Thanks for all the answers in advance.

    Regards, 

    Regards, 

    Tuesday, September 6, 2016 5:42 PM

Answers

  • Hi,

    It seems you must select 1 method when you configuring:

    And I don't find a way to enable both smart card and username/password on 1 nic,perhaps you could write a script to change the anthentication method,and run it when you want to use another method.

    ________________________________________
    Best Regards,
    Cartman
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact
    tnmff@microsoft.com.

    Wednesday, September 7, 2016 6:42 AM

All replies

  • Hi,

    It seems you must select 1 method when you configuring:

    And I don't find a way to enable both smart card and username/password on 1 nic,perhaps you could write a script to change the anthentication method,and run it when you want to use another method.

    ________________________________________
    Best Regards,
    Cartman
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact
    tnmff@microsoft.com.

    Wednesday, September 7, 2016 6:42 AM
  • Hi,

    I am checking to see if the problem has been resolved. If there's anything you'd like to know, don't hesitate to ask.


    Best Regards,
    Cartman
    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 14, 2016 7:38 AM
  • Hi Cartman, 

    thanks for caring ;) We have determined that both smart card and password authentication cannot be set up simultaneously and have decided to go with computer only (using certificate) authentication.

    Regards, 

    Wednesday, September 14, 2016 7:44 AM
  • Hi,

    Thank you for sharing to us.


    Best Regards,
    Cartman
    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 16, 2016 3:12 AM