Problem with 'add roles' and 'add features' RRS feed

  • Question

  • I am running Windows Server 2008 R2 - the 'Initial Configuration Tasks' screen shows the word 'Error' against both 'roles' and 'features' (for 'add roles' and 'add features').

    If I click on 'add roles' or 'add features' then an error dialog appears with: "Initial Configuration Tasks encountered an unexpected error while collecting data about the status of this computer".

    I have downloaded and run the 'system update readiness tool' - based on the response to another post, the CheckSUR log is copied below.

    How can I fix this ?

    Thank you,



    Checking System Update Readiness.
    Binary Version 6.1.7601.21645
    Package Version 12.0
    2011-06-10 11:23

    Checking Windows Servicing Packages

    Checking Package Manifests and Catalogs

    Checking Package Watchlist

    Checking Component Watchlist

    Checking Packages

    Checking Component Store
    (f)    CSI Missing Root Key    0x00000002    HKLM\Components\CanonicalData\Deployments       

    Seconds executed: 5
     Found 1 errors
      CSI Missing Root Key Total count: 1


    Andrew G
    Friday, June 10, 2011 10:44 AM

All replies

  • Hi,


    Please run the following command in Command Prompt.


    sfc /scannow


    If the issue persists, you may need to perform an in-place upgrade of Windows Server 2008 R2.


    Tim Quan


    Monday, June 13, 2011 4:04 AM
  • I have tried to run sfc/scannow a few times (as Administrator) including in 'Safe Mode' - each time I get the message:

    "Windows Resource Protection could not perform the requested operation"

    Any thoughts as to why that might be ?



    Andrew G
    Monday, June 13, 2011 3:51 PM
  • Hi,


    Then I’d suggest performing an in-place upgrade of the system.


    Tim Quan

    Wednesday, June 15, 2011 3:32 AM
  • Hi,

    I have now tried running an in-place upgrade (Windows Server 2008 R2 Ent), when the installer starts the "Gathering Files, Settings and Programs" stage the setup cancels immediately with and error dialog containing the message:

    "Setup cant continue, restart the computer and restart setup. When prompted try getting the latest updates"

    - which I have tried several times - with the same error every time.

    This is becoming very awkrward - what can I do to sort this out ?

    Thank you,


    Andrew G
    Thursday, June 16, 2011 8:38 AM
  • This may be related (though the error message is slightly different).


    Quote from noamo48 "

    Go to registry and delete the following keys (i only had two of the three and it worked anyways):

    • HKEY_LOCAL_MACHINE\COMPONENTS\AdvancedInstallersNeedResolving

    Reboot and that's it!


    Tuesday, July 12, 2011 1:36 AM
  • I have this exact same error.

    I can not manually add any roles with power shell either.

    Event log has the following errors when trying to add to the roles via power shell. (I also have the csi root key missing error after fixing a number of corrupt packages).  There has to be a fix other then reinstalling, linux is not this hard :)

    Could not discover the state of the system. An unexpected exception was found:
    System.Runtime.InteropServices.COMException (0x80073712): The component store has been corrupted. (Exception from HRESULT: 0x80073712)
       at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
       at Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package)
       at Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
       at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
       at Microsoft.Windows.ServerManager.Common.Provider.RefreshDiscovery()
       at Microsoft.Windows.ServerManager.LocalResult.PerformDiscovery()
       at Microsoft.Windows.ServerManager.ServerManagerModel.CreateLocalResult(RefreshType refreshType)
       at Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)

    I also do not have a components key in HKLM of the registry and can not create it or any subkey under hklm, other areas of registry work fine.

    Please help, desperately want to avoid a reinstall.

    Monday, March 5, 2012 3:12 AM