none
Value "t" (ascii 0x116) not working correctly in gpmc.msc MMC (lowercase "t" causes refresh) RRS feed

  • Question

  • Value "t" (ascii 0x116) not working correctly in MMC (lowercase "t" causes refresh)
    Can't rename a GPO if it contains a lowercase "t" in its new name.

    We have a Windows Server 2008 R2 SP1 with hotfix http://support.microsoft.com/kb/2466373 applied. This server is set up with terminal services application mode so a bunch of sysadmins can share certain tools and have a common central place to do Group Policy management.

    To see the problem:
    1. I launch the Administrative Tools > Group Policy Management (c:\windows\system32\gpmc.msc).
    2. I open the Forest > Domains > my.com > Group Policy Objects folder.
    3. I select a Group Policy Object in the Contents tab.
    4. I highlight the GPO (or right-click select Rename) and attempt to rename to a name that contains a lower case "t" (ALT-116) value.
    Symptom: the MMC does a "refresh" function (F5) and I lose my attempted rename. 

     

    There is a work-around:
    1. Open notepad.exe.
    2. type in the desired new name, highlight and Ctrl-C to copy to clipboard (can contain a lower case "t").
    3. In GPO MMC, highlight GPO to rename it, Ctrl-V to paste the text value for the new name.

     

    I am starting a new thread because the thread that applies is marked as "answered" even though it is not. See also: http://social.technet.microsoft.com/Forums/en-US/winserverManagement/thread/74b6ecba-07e9-4223-bd57-a34ddfc31302 for a thread that should be marked "unanswered".

    Monday, November 5, 2012 10:18 PM

All replies

  • This seems like a bug according to the following Technet blog and should have been fixed in kb2466373.
    http://blogs.technet.com/b/askds/archive/2009/05/05/rsat-release-candidate-for-windows-7-ehh-release-candidate.aspx?PageIndex=2&Redirected=true


    I found another post complaining about this (see the link below). That guy fixed the problem by connecting through RSAT for once and after that he was able to rename a GPO through RDP as well. You may give it a try.


    Letter "t" not allowed in GPO name
    http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/c2d649f6-c839-4524-a1a2-f9af601517a3

     

     

    Wednesday, November 7, 2012 6:06 AM
    Moderator
  • As I indicated in the post, I already installed KB2466373 hotfix. Did not fix this issue.

    I have used other keyboards, and other computers (laptops and desktop style), so it is not a physical keyboard issue.

    I have used two different RDP clients (6.1.7600.16722 and 6.1.7601.17514).

    I have used the VMware console on vCenter (no RDP).

    This is a bug in the MMC or GPMC.MSC code.



    Wednesday, November 7, 2012 4:39 PM
  • No fix to this yet?!

    Tuesday, February 17, 2015 10:14 PM
  • I'm using Server 2012 and I have been experiencing exactly the same problem ! 

    So any hotfix they did in Server 2008 clearly hasn't worked.

    Very annoying .. and it is now 9th JUNE 2015 !

    Tuesday, June 9, 2015 2:31 PM
  • RSAT for Windows 10 includes the same bug... Also the "p" is not working

    • Edited by Lukas Wiese Tuesday, September 8, 2015 2:20 PM
    Tuesday, September 8, 2015 2:19 PM
  • Great - so I am not crazy after all! Tried the rsat on windows 8.1, also opened gpsm directly on server 2012r2, and the P is not working. But it worked at one point because I have plenty of group policies with several P's.
    Wednesday, October 21, 2015 6:31 PM
  • This thread has been inactive for a while, but someone might stumble on it again like I did.  The error only happens (at least on Win 7) when you leave the Settings tab selected in Group Policy Management.  If you select a different tab before attempting to type, there is no error.  This is true even if you navigate to a different console.  Not a fix, but an easy work-around.
    • Proposed as answer by OVollmer Monday, April 2, 2018 8:57 PM
    Thursday, June 2, 2016 2:38 PM
  • This bug is *FINALLY* fixed in RSAT for 1709 that was just released... I have had this problem for years as well.

    https://www.microsoft.com/en-us/download/details.aspx?id=45520&40ddd5bd-f9e7-49a6-3526-f86656931a02=True

    Friday, November 10, 2017 2:12 PM
  • Thank you, I thought I was going crazy. Can confirm that this worked for me, switching off of the Settings tab and then renaming a GPO allowed me to use the letter t. 
    Monday, April 2, 2018 8:59 PM
  • Amazingly, this issue still exists in Server 2019. You cannot type a p or a t when renaming a GPO. This is from a directly connected screen/keyboard (i.e. from the console). You can create a new GPO and use those letters in naming it, but you cannot use them when renaming. Although, if you rename in the left pane, it is OK. This only affects renaming in the right pane of GPMC. Copy/paste from Notepad is fine.
    Wednesday, February 6, 2019 4:44 PM
  • Same thing happens on Server 2012 for me with the lowercase 't' doing refreshes in GPMC only.

    In addition, I also can't type a lowercase 'p' when trying to rename a GPO.

    I can make it break again when I click on a GPO and then view the Settings tab.

    I can also make it break if I click on the "Group Policy Objects" folder that lists all the policies in the domain.

    Here's the workaround / temporary fix that worked for me:

    Click on the GPO and then on the right pane click the Scope tab and then hit F5 to refresh. Then try to rename a GPO and type 't'.  This then allows me to use 't' and 'p' until the next time I do one of the tow things above to break it again.
    Friday, July 5, 2019 6:36 PM