none
Problem with DHCP take old DNS server from the DHCP Server on Win2k8 RRS feed

  • Question

  • Hi, we have a little problem, we magirate our domin to win2k8 Active directory, even the DHCP Server with 4 diferent scope, then all is fine we´ve depromo the all DC (win 2k3 servers) and remove it with any problem however our client Win xp and Win7 still received the old DNS (old domain controles), but on the scope configuration we don´t have anything configured with old DNS.

    Anyone having any idea about this issue

    Regards

     

    Monday, August 30, 2010 7:07 PM

Answers

  • Hi, thanks for your comments, but we already detected the problem, which is meanly that for some reason on same network segment there is another dhcp activaded only the service not the scopes, i mean that the only dhcp server was started but all scope for this server are deactived... this mean that this server is a black hole arp request .. that was the problem, when the dhcp server was stoped all work fine again...

     

    Some request go to this dhcp server and other to the vlan interface to redirect by dhcp relay to the real dhcp ... then the configuratios automatically were change on the clients, that is the issue.

     

    Thnaks for you help, the problm was resolved.

    Wednesday, September 1, 2010 2:08 PM

All replies

  • Hi,

    Thanks for the post.

    At this point, we need to ask some quesitons to further know about this issue:

    1. Is this issue affecting all client machines?

    2. What's the DNS Servers setting when running ipconfig /all on the problematic client?

    3. Please check if the DHCP Server options are set correct.

    4. Please put a test machine to newly join in this domain and check the result.

    5. What will happen if we type ipconfig /flushdns and then ipconfig /registerdns?

    Thanks,

    Miles

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, August 31, 2010 8:25 AM
    Moderator
  • Hi, thanks for your comments, but we already detected the problem, which is meanly that for some reason on same network segment there is another dhcp activaded only the service not the scopes, i mean that the only dhcp server was started but all scope for this server are deactived... this mean that this server is a black hole arp request .. that was the problem, when the dhcp server was stoped all work fine again...

     

    Some request go to this dhcp server and other to the vlan interface to redirect by dhcp relay to the real dhcp ... then the configuratios automatically were change on the clients, that is the issue.

     

    Thnaks for you help, the problm was resolved.

    Wednesday, September 1, 2010 2:08 PM