locked
MOSS 2007 Central Administration only local access RRS feed

  • Question

  • Hi,

    we're running MOSS2007 on W2k3R2. If i connect the server via RDP (with the user mossadmin), i can access the central administration http://moss:7777

    If i tried to access the URL http://moss:7777 from a remote computer, i get a promt to enter username and password. I tried the same credentials, if i used via RDP, but i doesn't work. I get the IIS-Error: "You are not authorized to view this page".

    Whats the problem? Can the CA only be accessed from localhost?

    Regards,
    Marcel

    Thursday, February 23, 2012 5:04 PM

Answers

  • Hi marceck,

    Try to use the following commands on your web sites:
    cd C:\Inetpub\Adminscripts
    cscript adsutil.vbs get w3svc/WebSite/root/NTAuthenticationProviders
    In this command, WebSite is a placeholder for the Web site ID number. The Web site ID number of the default Web site is 1.
    Some of the sites in SharePoint were set to "Not Set", "NTLM" or "Negotiate,NTLM". 

    Here you can use the following command to set the Central Admin and SharedService web site properties:
    cscript adsutil.vbs set w3svc/WebSite/root/NTAuthenticationProviders "NTLM"

    Here is a similar issue:
    http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/435e3179-a707-4132-8517-be9a9efb58c0

    Thanks,
    Lhan
    • Marked as answer by marceck Monday, February 27, 2012 11:59 AM
    Monday, February 27, 2012 9:36 AM
    Moderator

All replies

  • Is the remote system a member of the same domain? Try entering the credentials using domain\username.

    Imagine what we could be...if we could just imagine. | Daniel A. Galant | Sr. SharePoint Solutions Architect EPC Group.net

    Thursday, February 23, 2012 5:12 PM
  • Is the remote system a member of the same domain? Try entering the credentials using domain\username.

    Yes, the remote computer ist part of the same domain. No matter if i tried with domain\mossadmin or only mossadmin. Every other domain account (e.g. the admin-account) doesn't work also.

    Marcel

    Thursday, February 23, 2012 5:15 PM
  • Hi,

    Add a mapping of the central admin URL to the server where it is already hosted in your host file.

    Also check if the ports are opened between two servers.

    I hope this will help you out.


    Thanks, Rahul Rashu

    Thursday, February 23, 2012 7:25 PM
  • Add a mapping of the central admin URL to the server where it is already hosted in your host file.

    Also check if the ports are opened between two servers.

    Hi Rahul,

    the general access to the server is not the problem, i think. Because i get a prompt to enter my credentials. So maybe it's a configuration problem in the security settings?

    Marcel

    Friday, February 24, 2012 10:10 AM
  • Hi marceck,

    Try to use the following commands on your web sites:
    cd C:\Inetpub\Adminscripts
    cscript adsutil.vbs get w3svc/WebSite/root/NTAuthenticationProviders
    In this command, WebSite is a placeholder for the Web site ID number. The Web site ID number of the default Web site is 1.
    Some of the sites in SharePoint were set to "Not Set", "NTLM" or "Negotiate,NTLM". 

    Here you can use the following command to set the Central Admin and SharedService web site properties:
    cscript adsutil.vbs set w3svc/WebSite/root/NTAuthenticationProviders "NTLM"

    Here is a similar issue:
    http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/435e3179-a707-4132-8517-be9a9efb58c0

    Thanks,
    Lhan
    • Marked as answer by marceck Monday, February 27, 2012 11:59 AM
    Monday, February 27, 2012 9:36 AM
    Moderator
  • thanks Lhan, now the remote-access is working!

    regards
    Marcel

    Monday, February 27, 2012 12:09 PM