locked
Gadgets RRS feed

  • Question

  • So I got my new PC, installed up Windows 7. Turn it on, yeah, perfect. Press the right mouse, and I don't have ''gadgets'' there. Just ''Personalize'' and ''Screen Resolution''. I've checked other gadgets topics, and no,

    I tried to go in start and search for gadget - nothing.

    I went in control panel, turn windows features on or off - I didn't have that Windows Gadgets there! 

    Anyone, please help!

    Thursday, July 12, 2012 10:54 AM

All replies

  • there is a new security scare regarding gadgets.
    suspect ms has disabled them as it has said it would.
     "Artis12391" wrote in message
    news:93646a71-4fa6-4b7c-835f-1ef5bffeaaf9@communitybridge.codeplex.com...
    > So I got my new PC, installed up Windows 7. Turn it on, yeah, perfect.
    > Press the right mouse, and I don't have ''gadgets'' there. Just
    > ''Personalize'' and ''Screen Resolution''. I've checked other gadgets
    > topics, and no,
    >
    >
    > I tried to go in start and search for gadget - nothing.
    >
    >
    > I went in control panel, turn windows features on or off - I didn't have
    > that Windows Gadgets there!
    >
    >
    > Anyone, please help!
    >
     
    Thursday, July 12, 2012 11:58 AM
  • Hi,

    I would give your following methods to try:

    Method 1:

    You can enable Desktop sidebar gadget with user account control:

     1. As usual, we type in regedit in Start menu search field and hit enter to open Windows Registry Editor.

    2. Click, Yes for the UAC prompt (If you see any).

    3. Move to the following registry key:

    HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Sidebar \ Settings

    4. Here, you need to create a new DWORD value (32-bit) named “AllowElevatedProcess”.

    5. Next, double-click on the newly created “AllowElevatedProcess” and change the default value to “1”.

    6. Close Windows Registry Editor. Now you should be able to see the change in Desktop Gadget behavior.

    Method 2:

    You can try run sfc /scanow in CMD to try.

    Method 3:

    You should try to re-register some necessary dll.

    1. Click Start

    2. Type "CMD" without the quotes

    3. Right click cmd.exe and select 'Run as Administrator'

    4. In the command prompt the pops up, type the following:

    Regsvr32 -u "%ProgramFiles%\Windows Sidebar\sbdrop.dll"

    Regsvr32 -u "%ProgramFiles%\Windows Sidebar\wlsrvc.dll"

    Regsvr32 atl.dll

    Regsvr32 "%ProgramFiles%\Windows Sidebar\sbdrop.dll"

    Regsvr32 "%ProgramFiles%\Windows Sidebar\wlsrvc.dll

    If above not useful, just as Mieyhsd said, for some security reason, Microsoft has disabled them.

    Friday, July 13, 2012 8:42 AM
  • suspect ms has disabled them as it has said it would.

    While possible, I don't think Microsoft would distribute a Fix It solution via Windows Update. 

    Still, if that Fix it was installed, the simple solution is to re-enable Windows Sidebar and gadgets by running Fix It 50907.

    I went in control panel, turn windows features on or off - I didn't have that Windows Gadgets there!

    You mean you don't have "Windows Gadget Platform" in Turn Windows Features on or off? - that's odd.

    Friday, July 13, 2012 11:50 AM