none
Email routing problem RRS feed

  • Question

  • I have an email address setup called forms@domain.com.  In the Exchage Management Console, I go into Recipeint Configuration, Mailbox and then I click on Properties for the mailbox.  In the message flow settings tab, I choose properties for Deliver Options.  In the forwarding address, I Browse and choose a mail enabled folder.

    When I sent an email to forms@domain.com, I get a bounceback below.  This had been working in SBS2003 and it was working for the first week that we migrated to SBS2011.  I really need help getting this resolved because this is vital to our work flow in the office for our agents.

    Thanks!

    Delivery has failed to these recipients or groups:

     

    AgentFormsSubmitted@domain.com
    There's a problem with the recipient's mailbox. Please try resending the message. If the problem continues, please contact your helpdesk.

     

    Diagnostic information for administrators:

     

    Generating server: MTSERVER.moderntravel.local

     

    AgentFormsSubmitted@domain.com
    #554 5.2.0 STOREDRV.Deliver.Exception:ObjectNotFoundException; Failed to process message due to a permanent exception with message The Active Directory user wasn't found. ObjectNotFoundException: The Active Directory user wasn't found. ##rfc822;forms@moderntravel.net

     

    Original message headers:

     

    Received: from MTSERVER.moderntravel.local ([fe80::d88e:f8c1:582d:dba9]) by
     MTSERVER.moderntravel.local ([fe80::d88e:f8c1:582d:dba9%11]) with mapi id
     14.01.0355.002; Fri, 20 Jan 2012 12:11:29 -0600
    Content-Type: application/ms-tnef; name="winmail.dat"
    Content-Transfer-Encoding: binary
    From: Torrey Lauer torrey@domain.com
    To: forms forms@domain.com
    Subject: test
    Thread-Topic: test
    Thread-Index: AczXnu1yTwdR7orESL6c3Z4j0qUs9w==
    Disposition-Notification-To: Torrey Lauer torrey@domain.com
     
    Return-Receipt-To: torrey@domain.com
    Date: Fri, 20 Jan 2012 12:11:28 -0600
    Message-ID: <CC714C4310E5B749B9694F69217F246C10179F@MTSERVER.moderntravel.local>
    Accept-Language: en-US
    Content-Language: en-US
    X-MS-Has-Attach: yes
    X-MS-TNEF-Correlator: <CC714C4310E5B749B9694F69217F246C10179F@MTSERVER.moderntravel.local>
    MIME-Version: 1.0
    X-Originating-IP: [192.168.16.112]
    X-TM-AS-Product-Ver: SMEX-10.1.0.2244-6.800.1017-18656.004
    X-TM-AS-Result: No--47.995200-5.000000-31
    X-TM-AS-User-Approved-Sender: No
    X-TM-AS-User-Blocked-Sender: No

    Friday, January 20, 2012 6:18 PM

Answers

All replies

  • Are you able to directly send mails to AgentFormsSubmitted@domain.com

    If you create a new test PF, mail-enable it and forward mails to it, does it work?

    Just to narrow down the issue to this particular PF.

    Friday, January 20, 2012 6:46 PM
  • What's a PF?  No, I've never had an email called AgentFormsSubmitted@domain.com before.  When I select the mail enabled folder, this is what populates into the mail forward box in the Deliver Options in for the "mailbox" (which is really a public folder in Outlook) in Recipient Configuration in Exchange.
    Friday, January 20, 2012 8:19 PM
  • Is it possible that someone accidentally removed the public folder "AgentFormsSubmitted" or disabled the mail function on that folder? That way your forward on the forms@domain.com mailbox might point to a non existing (actually no longer existing) active directory object.

    As Vibha already said before: try creating a new test public folder, mail enable that public folder and forward the emails to that PF. If that works... try to mail disable the "AgentFormsSubmitted" public folder and mail enable it afterwards.

    Try forwarding your forms@domain.com mails to the original folder again. If that won't work.. well... I'd then check my active directory health (dcdiag, nltest, ...).

    As you mentioned the SBS migration: did you make sure the public folder replication finished before you removed the source server?
    • Edited by Frederik J Friday, January 20, 2012 11:23 PM
    Friday, January 20, 2012 11:22 PM
  • I created a new public folder called "test pf" and mail enabled it.  Then, I chose to have the emails forwarded to the public folder.  I sent a test email to it and got this:

     

    Delivery has failed to these recipients or groups:

     

    test pf (testpf@domain.com)
    A problem occurred during the delivery of this message. Please try to resend the message later. If the problem continues, contact your helpdesk.

     

     

     

     

     

     

     

    Diagnostic information for administrators:

     

    Generating server: MTSERVER.moderntravel.local

     

    testpf@domain.com#550 5.4.6 RESOLVER.FWD.Loop; there is a forwarding loop configured in the directory ##rfc822;testpf@domain.com

     

    Original message headers:

     

    Received: from MTSERVER.moderntravel.local ([fe80::d88e:f8c1:582d:dba9]) by
     MTSERVER.moderntravel.local ([fe80::d88e:f8c1:582d:dba9%11]) with mapi id
     14.01.0355.002; Fri, 20 Jan 2012 19:03:14 -0600
    Content-Type: application/ms-tnef; name="winmail.dat"


    Saturday, January 21, 2012 1:04 AM
  • Frederik,

    How do I use dcdiag and nltest?  I've googled it but I'm not sure what to put in the parameters.

    Saturday, January 21, 2012 1:59 AM
  • From the error message I'd say your mail forward is somehow not configured correctly. Could you try to send an email directly to the mail enabled public folder instead of through the forwarding mechanism?

    After reading your first mail again: 

    "The Active Directory user wasn't found. ObjectNotFoundException: The Active Directory user wasn't found" points to a missing or wrong entry within active directory. Maybe the object in AD for your public folder still somehow points to the old and retired exchange public folder database. Please check once more if the migration was completed correctly - especially check that the public folder instances were replicated and transfered successfully. Please see the microsoft documentation (http://technet.microsoft.com/en-us/library/gg576862.aspx) for details on how to remove the last legacy exchange server. This should have been done as one of the final steps of the SBS 2003 to SBS 2011 migration. One needs to be very patient at the public folder replication especially when there are a lot of public folders and/or a lot of items within the public folders.

     

    Sunday, January 22, 2012 8:06 PM
  • dcdiag must be run from an elevated command prompt on the domain controller. Just running dcdiag in an elevated command prompt without parameters should check at least the basics. Normally that should suffice and point into the right direction.

    Please run the Microsoft SBS Best Practice Analyzer (more information is available at http://technet.microsoft.com/en-us/library/gg508357.aspx) in addition to dcdiag.

    If you do not know these tools you should have an expert have a look at your servers. Migrations are not an easy task and one can easily miss out on important things there.

    Sunday, January 22, 2012 8:13 PM
  • Hi,

     

    After reviewing the NDR message, I noticed the following error message:

     

    #554 5.2.0 STOREDRV.Deliver.Exception:ObjectNotFoundException; Failed to process message due to a permanent exception with message The Active Directory user wasn't found. ObjectNotFoundException: The Active Directory user wasn't found. ##rfc822;forms@moderntravel.net

     

    It seems that there are more than one domains are hosted on your SBS 2011:

     

    domain.com;

    moderntravel.local;

    moderntravel.net;

     

    Based on the current situation, please run the following commands in the EMS to verify the issue:

     

    Get-Mailbox -Identity forms@domain.com |FL

     

    At the same time, please make sure that you have added these domains in the Accepted Domain list.

     

    Then we could do the test via the website tool – Microsoft Remote Connectivity Analyzer. Please use the Internet E-mail Tests to complete the testing.

     

    Regards,

    James

    James Xiong

    TechNet Community Support

    Tuesday, January 24, 2012 2:18 AM
    Moderator
  • James,

    We only have the moderntravel.local and moderntravel.net, not domain.com.  Below are the results of the command you asked me to run.  The active directory user wasn't found is just one of the erros I get when trying to get it to work the way it did in SBS2003 and how it was working until last week with SBS2011.  I also get the forwarding loop error when trying to get it to work using different configurations.

    [PS] C:\Windows\system32>Get-Mailbox -Identity forms@moderntravel.net |FL


    RunspaceId                             : 56fc9339-07d0-4e0d-94e0-f8c84df19766
    Database                               : Mailbox Database 2012010120
    UseDatabaseRetentionDefaults           : True
    RetainDeletedItemsUntilBackup          : False
    DeliverToMailboxAndForward             : False
    LitigationHoldEnabled                  : False
    SingleItemRecoveryEnabled              : False
    RetentionHoldEnabled                   : False
    EndDateForRetentionHold                :
    StartDateForRetentionHold              :
    RetentionComment                       :
    RetentionUrl                           :
    LitigationHoldDate                     :
    LitigationHoldOwner                    :
    ManagedFolderMailboxPolicy             :
    RetentionPolicy                        :
    CalendarRepairDisabled                 : False
    ExchangeGuid                           : 2989ab33-fa97-4747-9f51-cf79e10a4b4c
    ExchangeSecurityDescriptor             : System.Security.AccessControl.RawSecurityDescriptor
    ExchangeUserAccountControl             : None
    MessageTrackingReadStatusEnabled       : True
    ExternalOofOptions                     : External
    ForwardingAddress                      : moderntravel.local/Microsoft Exchange System Objects/Agent Forms Submitted
    ForwardingSmtpAddress                  :
    RetainDeletedItemsFor                  : 30.00:00:00
    IsMailboxEnabled                       : True
    Languages                              : {}
    OfflineAddressBook                     :
    ProhibitSendQuota                      : 2 GB (2,147,483,648 bytes)
    ProhibitSendReceiveQuota               : 2 GB (2,147,483,648 bytes)
    RecoverableItemsQuota                  : unlimited
    RecoverableItemsWarningQuota           : unlimited
    DowngradeHighPriorityMessagesEnabled   : False
    ProtocolSettings                       : {HTTP§1§1§§§§§§, OWA§1}
    RecipientLimits                        : unlimited
    IsResource                             : False
    IsLinked                               : False
    IsShared                               : False
    LinkedMasterAccount                    :
    ResourceCapacity                       :
    ResourceCustom                         : {}
    ResourceType                           :
    SamAccountName                         : forms
    SCLDeleteThreshold                     :
    SCLDeleteEnabled                       :
    SCLRejectThreshold                     :
    SCLRejectEnabled                       :
    SCLQuarantineThreshold                 :
    SCLQuarantineEnabled                   :
    SCLJunkThreshold                       :
    SCLJunkEnabled                         :
    AntispamBypassEnabled                  : False
    ServerLegacyDN                         : /o=MODERNTRAVEL/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configur
                                             ation/cn=Servers/cn=MTSERVER
    ServerName                             : mtserver
    UseDatabaseQuotaDefaults               : False
    IssueWarningQuota                      : 1.902 GB (2,042,626,048 bytes)
    RulesQuota                             : 64 KB (65,536 bytes)
    Office                                 :
    UserPrincipalName                      : forms@moderntravel.local
    UMEnabled                              : False
    MaxSafeSenders                         :
    MaxBlockedSenders                      :
    ReconciliationId                       :
    WindowsLiveID                          :
    ThrottlingPolicy                       :
    RoleAssignmentPolicy                   : Default Role Assignment Policy
    SharingPolicy                          : Default Sharing Policy
    RemoteAccountPolicy                    :
    MailboxPlan                            :
    ArchiveDatabase                        :
    ArchiveGuid                            : 00000000-0000-0000-0000-000000000000
    ArchiveName                            : {}
    ArchiveQuota                           : unlimited
    ArchiveWarningQuota                    : unlimited
    ArchiveDomain                          :
    ArchiveStatus                          : None
    RemoteRecipientType                    : None
    DisabledArchiveDatabase                :
    DisabledArchiveGuid                    : 00000000-0000-0000-0000-000000000000
    QueryBaseDNRestrictionEnabled          : False
    MailboxMoveTargetMDB                   : Mailbox Database 2012010120
    MailboxMoveSourceMDB                   :
    MailboxMoveFlags                       : IntraOrg, Pull, Offline
    MailboxMoveRemoteHostName              :
    MailboxMoveBatchName                   :
    MailboxMoveStatus                      : Completed
    IsPersonToPersonTextMessagingEnabled   : False
    IsMachineToPersonTextMessagingEnabled  : True
    UserSMimeCertificate                   : {}
    UserCertificate                        : {}
    CalendarVersionStoreDisabled           : False
    ImmutableId                            :
    PersistedCapabilities                  : {}
    SKUAssigned                            : False
    AuditEnabled                           : False
    AuditLogAgeLimit                       : 90.00:00:00
    AuditAdmin                             : {Update, Move, MoveToDeletedItems, SoftDelete, HardDelete, FolderBind, SendAs,
                                              SendOnBehalf, Create}
    AuditDelegate                          : {Update, SoftDelete, HardDelete, SendAs, Create}
    AuditOwner                             : {}
    WhenMailboxCreated                     : 1/2/2012 4:13:08 PM
    UsageLocation                          :
    Extensions                             : {}
    HasPicture                             : False
    HasSpokenName                          : False
    AcceptMessagesOnlyFrom                 : {}
    AcceptMessagesOnlyFromDLMembers        : {}
    AcceptMessagesOnlyFromSendersOrMembers : {}
    AddressListMembership                  : {\Default Global Address List, \All Users}
    Alias                                  : forms
    ArbitrationMailbox                     :
    BypassModerationFromSendersOrMembers   : {}
    OrganizationalUnit                     : moderntravel.local/MyBusiness/Users/SBSUsers
    CustomAttribute1                       :
    CustomAttribute10                      :
    CustomAttribute11                      :
    CustomAttribute12                      :
    CustomAttribute13                      :
    CustomAttribute14                      :
    CustomAttribute15                      :
    CustomAttribute2                       :
    CustomAttribute3                       :
    CustomAttribute4                       :
    CustomAttribute5                       :
    CustomAttribute6                       :
    CustomAttribute7                       :
    CustomAttribute8                       :
    CustomAttribute9                       :
    DisplayName                            : forms
    EmailAddresses                         : {smtp:forms@firekeeperstravel.com, smtp:forms@moderntravel.local, smtp:forms@r
                                             ainbowskytravel.com, X400:C=US;A= ;P=MODERNTRAVEL;O=Exchange;S=forms;, SMTP:fo
                                             rms@moderntravel.net}
    GrantSendOnBehalfTo                    : {}
    ExternalDirectoryObjectId              :
    HiddenFromAddressListsEnabled          : False
    LastExchangeChangedTime                :
    LegacyExchangeDN                       : /o=MODERNTRAVEL/ou=first administrative group/cn=Recipients/cn=forms
    MaxSendSize                            : unlimited
    MaxReceiveSize                         : unlimited
    ModeratedBy                            : {}
    ModerationEnabled                      : False
    PoliciesIncluded                       : {724338f9-0027-4610-b834-d785a82714d8, {26491cfc-9e50-4857-861b-0cb8df22b5d7}}
    PoliciesExcluded                       : {}
    EmailAddressPolicyEnabled              : True
    PrimarySmtpAddress                     : forms@moderntravel.net
    RecipientType                          : UserMailbox
    RecipientTypeDetails                   : UserMailbox
    RejectMessagesFrom                     : {}
    RejectMessagesFromDLMembers            : {}
    RejectMessagesFromSendersOrMembers     : {}
    RequireSenderAuthenticationEnabled     : False
    SimpleDisplayName                      :
    SendModerationNotifications            : Always
    UMDtmfMap                              : {}
    WindowsEmailAddress                    : forms@moderntravel.net
    MailTip                                :
    MailTipTranslations                    : {}
    PartnerObjectId                        : 00000000-0000-0000-0000-000000000000
    IsValid                                : True
    ExchangeVersion                        : 0.10 (14.0.100.0)
    Name                                   : forms
    DistinguishedName                      : CN=forms,OU=SBSUsers,OU=Users,OU=MyBusiness,DC=moderntravel,DC=local
    Identity                               : moderntravel.local/MyBusiness/Users/SBSUsers/forms
    Guid                                   : 6c0cb9ee-f144-444a-862d-c107aa42fb13
    ObjectCategory                         : moderntravel.local/Configuration/Schema/Person
    ObjectClass                            : {top, person, organizationalPerson, user}
    WhenChanged                            : 1/3/2012 11:28:58 PM
    WhenCreated                            : 4/23/2006 7:34:14 PM
    WhenChangedUTC                         : 1/4/2012 5:28:58 AM
    WhenCreatedUTC                         : 4/24/2006 12:34:14 AM
    OrganizationId                         :
    OriginatingServer                      : MTSERVER.moderntravel.local

     

    [PS] C:\Windows\system32>

     

    Tuesday, January 24, 2012 4:45 AM
  • Using the MS Remote Connectivity Analyzer to test the inbound email for the forms@moderntravel net email address.

     

    Testing inbound SMTP mail flow for domain forms@moderntravel.net.
      ExRCA failed to test inbound SMTP mail flow.
     
    Test Steps
     
    Attempting to retrieve DNS MX records for domain moderntravel.net.
      One or more MX records were successfully retrieved from DNS.
     
    Additional Details
      MX Records Host 207.67.13.210, Preference 10
    Testing Mail Exchanger 207.67.13.210.
      One or more SMTP tests failed for this Mail Exchanger.
     
    Test Steps
     
    Attempting to resolve the host name 207.67.13.210 in DNS.
      The host name couldn't be resolved.
       <label for="testSelectWizard_ctl12_ctl06_ctl01_ctl00_tmmArrow">Tell me more about this issue and how to resolve it</label>
     
    Additional Details
      Host 207.67.13.210 couldn't be resolved in DNS InfoDomainNonexistent.
    Tuesday, January 24, 2012 4:50 AM
  • AgentFormsSubmitted@moderntravel.net
    #550 5.4.6 RESOLVER.FWD.Loop; there is a forwarding loop configured in the directory ##rfc822;forms@moderntravel.net    How exactly is this set up on your server?

    Tuesday, January 24, 2012 5:33 AM
    Moderator
  • An email sent to forms@ goes to agenforumssubmitted?

     

    Tuesday, January 24, 2012 5:34 AM
    Moderator
  • Susan,

    In SBS2003, I had it setup like this:

    I created a user and email address.  For that user, I went into (forgive me, I don't the exact area off the top of my head) the properties for that user and clicked on a tab that allowed me to set how email was delivered for the user.  I then clicked a box on that tab that allowed me to select an email address to which email to that email user could be forwarded or I could select a public folder.  I chose a public folder called Agent Forms Submitted.  All emails to forms @ moderntravel net were then sent to the Agent Forms Submitted public folder.

    Likewise, I did this with the faxes too.  A fax would come in and I had it route to email to a user and email I had created called faxes @ moderntravel net and it was then configured the same way the forms email address was above but this time the email was sent to the Faxes public folder.

    When I did the server migration, all those settings transfered and were working until about a week or two later and then opened this thread on it.  In looking to troubleshoot the problem intially, I could no longer find the tab that was available in Exchange for SBS2003 where I could choose a public folder for the incoming email to go to.  However, I did come across in the SBS2011 version of Exchange a Configuration Management Tool in Exchange 2010 called Public Folder Management Console.  In that console, I went into the Default Public Folders and into properties for the Faxes public folder.  I noticed that the faxes @ moderntravel net email address that I created in SBS2003 had been changed for this public folder to faxes1 @ moderntravel net.  I then went into the Mail Flow Settings tab and selected the properties for Delivery Options.  In there, I have it set to Forward to: faxes1 @ moderntravel net (which is the address for the Faxes public folder).

    Maybe I don't understand how this works in SBS2011 (Exchange 2010).  Since it was working intitially because the settings just transferred during the migration.

    Wednesday, January 25, 2012 2:56 AM
  • You've since dcpromo'd out the SBS 2003 correct?

    I'm guessing some transport rule on the sbs 2003 was still in play.

    I'm getting a bounce back when I try to email that alias.

    I'd do as a test a brand new public folder and then a brand new forward and see if it works.

    Wednesday, January 25, 2012 4:47 AM
    Moderator
  • Yes, that's correct.  I've dcpromo'd the SBS2003 server already.

    I'll create a new folder and email and see if that works.  Once I've had a chance to do that, I'll post back.

    Thanks!

    Wednesday, January 25, 2012 4:48 AM
  • Susan,

    Could you tell me exactly what I need to do to get this to work.  I have tried everything and I either get a bounce back for: 

    #550 5.4.6 RESOLVER.FWD.Loop; there is a forwarding loop configured in the directory ##rfc822;testfolder@moderntravel.net

    or

    #554 5.2.0 STOREDRV.Deliver.Exception:ObjectNotFoundException; Failed to process message due to a permanent exception with message The Active Directory user wasn't found. ObjectNotFoundException: The Active Directory user wasn't found. ##

     

    Here's what I did.  I created a public folder and then I email enabled it.  I called the public folder "testfolder."  When I email enabled it, it created an email address testfolder @ moderntravel net. I then went into Properties and in the Mail Flow Settings I set the "Forward to" to point to the public folder (testfolder) which when I click on Ok it shows as testfolder @ moderntravel net.   When I send an email to that email address, I get the first bounce back error from above about the loopback.  When I remove the "Forward to" option in the Mail Flow Settings tab for "Test Folder," I get the second error.

     

    What am I doing wrong?

    Thursday, January 26, 2012 5:32 AM
  • I built a new public folder.

    I mail enabled it.

    I wouldn't then go into the very same mail enabled folder and make it forward to.  You are causing it to loop to itself.

    The email address on that public folder is only tesfolder@domain.local and not open to the external world.

    Go into the testfolder properties

    In the smtp email section, what exact email address is listed in the email section?

    Thursday, January 26, 2012 7:03 AM
    Moderator
  • The email address listed there is testfolder @ moderntravel net.
    Thursday, January 26, 2012 7:06 AM
  • When sending e-mail messages to a mail-enabled public folder that have been replicated from old Exchange Server 2000/2003/2007, Exchange Server 2010 environment mails are rejected with NDR.:
    http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/e8e78736-be67-4e4a-b929-2c3ce61e0eb6

    OH you are getting nailed by this.

    Also read this:

    http://social.technet.microsoft.com/Forums/en-TT/exchange2010/thread/49e06d4a-1b32-4067-999a-c85abd349c68

    I think you deleted a little bit too much when removing your old Exchange, either that or it did.

    • Marked as answer by Torrey Lauer Thursday, January 26, 2012 5:25 PM
    Thursday, January 26, 2012 7:12 AM
    Moderator
  • Susan,

    That helped, partially.  I went into ADSI Edit and even though I had gone into it last week to manually clean up Exchange, I apparently didn't delete the old "server" part of it as it listed in the step-by-step instructions in the links you provided.

    So, the part that worked after deleting the old server from ADSI Edit is that forms @ moderntravel net is now working and routing correctly to the "Agent Forms Submitted" public folder.

    The faxes @ moderntravel net is not routing to the "Faxes" public folder.  I have it setup just like I do for the forms email address going to the Agent Forms Submitted public folder.  So, I have an email address called forms moderntrvel net that points I have set to forward to the Forms public folder (which has an email address of forms1 @ moderntravel net).

    Even though I have them setup the way, I get the following error for the forms email address (even though I do not have a faxes13d @ moderntravel net email address):

    faxes
    The e-mail address you entered couldn't be found. Please check the recipient's e-mail address and try to resend the message. If the problem continues, please contact your helpdesk.

     

     

    Diagnostic information for administrators:

     

    Generating server: MTSERVER.moderntravel.local

     

    IMCEAEX-_O=MODERNTRAVEL_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+28FYDIBOHF23SPDLT+29_CN=RECIPIENTS_CN=Faxes13d@moderntravel.net
    #550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##

    Any ideas on this one?

    Thursday, January 26, 2012 8:21 AM
  • Susan,

    This morning we had faxes come in AND they routed to the Faxes public folder!  I knew if there was anyone that would be able to help me, it would be you!  THANK YOU THANK YOU THANK YOU!!!!

    Thursday, January 26, 2012 5:25 PM
  • Yea!  One more problem down. 
    Friday, January 27, 2012 7:06 AM
    Moderator