none
DPM 2010 agent install and connect on cluster nodes but virtual cluster server name not available to protect RRS feed

  • Question

  • the agent version 3.0.7706.0.

    After successfully connecting the agent to DPM server we cannot protect the cluster server.

    The nodes apear in DPM management view.  We have 3 Two node SQL clusters in the child.parent.co.za domain.

    The DBTEST clusters works perfect.

    The QADB1 and QADB2 clusters do not work, they used to have an earlier DPM agent on from 8 months ago when we did POC.  the DBTEST cluster did not have any agent prior on.

    The firewalls are off on DPM and all nodes.

    The setDPMServer do not provide any error, connect succesful.

    The agent status in DPM Management view after refresh is OK.

    On the DPM Monitoring Alerts view, the Warning I get states, "No agent on cluster node"

    And the detail description of the warning, "A protection agent is not installed on clusternode1.child.parent.co.za in clustername.child.parent.co.za server cluster. Protection may fail if a failover occurs to clusternode1.child.parent.co.za. (ID 369)


    JuanB
    Wednesday, January 12, 2011 6:47 AM

All replies

  • We resolved out own problem.  It was related to dns and not DPM.

    There was an A record in the parent domain for the the server names of the cluster nodes.

    when we removed the A records and added nodes to DPM again using FQDN of the child domain (node1.child.parent.co.za) the cluster virtual server name was visible in DPM 2010 to be protected.

    We have similar issue now with another agent in a another forest that is trusted by the forest where DPM 2010 is installed.

    When we attach the server to be protected we immediately get following error message:

    Unable to connect to the Active Directory Domain Services database.

    Make sure that the DPM server is a member of a domain and that a domain controller is running. Also verify that there is network connectivity between the DPM server and the domain controller.

    ID: 7
    Details: There is no such object on the server (0x80072030)

     

     

     

     


    JuanB
    • Edited by JuanB Wednesday, January 12, 2011 11:55 AM correction
    • Proposed as answer by MarcReynolds Wednesday, January 12, 2011 2:17 PM
    Wednesday, January 12, 2011 11:52 AM