none
Remote desktop doesn't work to public internet RRS feed

  • Question

  • I want to open remote desktop on Windows server 2016 to public internet.

    Public ip address is assigned directly on Server network interface.

    Server hosts virtual machines, and no more roles are installed. (and actually I successfully connect to those VMs via remote desktop through internet)

    For testing purposes I turned off firewall. so firewall is not the issue.

    I may telnet on port 3389 without an issue.

    But whenever I connect via remote desktop it says "internal server error".

    From local networks I can successfully connect via remote desktop. 

    Even, when I vpn to server, I still can connect via remote desktop. 

    However, without vpn, connecting directly through internet doesn't work.

    Seems like, the server somehow identifies public internet and blocks connection. 

    How to allow it?


    • Edited by aldarik Wednesday, November 29, 2017 5:10 AM
    Wednesday, November 29, 2017 5:08 AM

Answers

  • Thanks for reply, 

    On server there are hosted several VMs. For those VMs is created virtual switch in hyper-v. 

    I found when I disable this switch from network adapters, I may connect to host. But I lose connection to VMs.

    Connection type of the virtual switch is "external network" and picked my real network adapter.

    Hi,

    It seems related to Hyper-V virtual switch configuration, I suggest you to post on Hyper-V forum for further assistant:

    https://social.technet.microsoft.com/Forums/ie/en-US/home?forum=winserverhyperv


    Best Regards
    Cartman
    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by aldarik Thursday, February 15, 2018 2:30 AM
    Thursday, November 30, 2017 2:23 AM

All replies

  • Hi,

    there could be a lot of issues

    you can try to do the following

    change the registry key HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

    Set the existing keys SecurityLayer and UserAuthentication to 0

    Create an RDP file (open mstsc and click Save after entering the servername) and in notepad add the line enablecredsspsupport:i:0 somewhere. This disables the expectation of security.

    When you then run the RDP file it should allow you to UNSECURELY connect and gain access to your server.

    check if that will work.

    Wednesday, November 29, 2017 8:44 AM
  • Thanks for reply, 

    On server there are hosted several VMs. For those VMs is created virtual switch in hyper-v. 

    I found when I disable this switch from network adapters, I may connect to host. But I lose connection to VMs.

    Connection type of the virtual switch is "external network" and picked my real network adapter.

    Wednesday, November 29, 2017 9:14 AM
  • Thanks for reply, 

    On server there are hosted several VMs. For those VMs is created virtual switch in hyper-v. 

    I found when I disable this switch from network adapters, I may connect to host. But I lose connection to VMs.

    Connection type of the virtual switch is "external network" and picked my real network adapter.

    Hi,

    It seems related to Hyper-V virtual switch configuration, I suggest you to post on Hyper-V forum for further assistant:

    https://social.technet.microsoft.com/Forums/ie/en-US/home?forum=winserverhyperv


    Best Regards
    Cartman
    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by aldarik Thursday, February 15, 2018 2:30 AM
    Thursday, November 30, 2017 2:23 AM