none
WMI Filter Option Missing

    Question

  • I'm attempting to set up a GPO on Server 2008 R2 Standard x64 that needs a WMI filter as part of its implementation but it seems the option to apply a WMI filter isn't showing in GPMC.

    The Forest and Domain Functional Levels are set to Server 2008 R2.

    I have attached a screenshot showing the GPMC with the missing WMI Filter (some areas have been blacked out for customer privacy).

    Thursday, May 14, 2015 5:53 PM

Answers

  • On Windows Server, you would use Server Manager -> Roles & Features -> Features -> RSAT -> AD DS and LDS Tools

    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Saturday, May 23, 2015 8:37 AM

All replies

  • Hi,

    Thanks for post here. Basicly, the WMI filter is built in the GPMC. You can have a check as below screenshots:

    1> Go to view> Options

    2> Check if the WMI filter checkbox checked:


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 15, 2015 6:43 AM
    Moderator
  • Elaine Jing,

    Thank you for your reply.  I checked these settings and they are all checked in similar fashion to your posted screenshot.  I have tried unchecking them, clicking "OK" and then rechecking them and pressing "OK" again to no avail.  The WMI Filter section is still not being displayed.

    Friday, May 15, 2015 2:46 PM
  • sounds odd never seen this, try removing gpmc and then add again
    Friday, May 15, 2015 6:31 PM
  • The WMI Filter section is still not being displayed.

    Your screenshot shows WMI Filters missing from the right-hand-pane and also seems to be missing from the left-hand-pane.

    This suggests that you don't have enough permissions within the domain to manage WMI Filters ??

    (Or, unlikely, you have Win2000 domain controllers.. Win2000 did not implement WMI Filters)


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Saturday, May 16, 2015 9:02 AM
  • Don,

    Thank you for your reply. 

    The user in use is the domain "administrator" account.  It has full permissions to all areas of the network.

    Per my first post the server is 2008 R2 Standard x64.

    Alex,

    Thank you for your reply.

    I have never needed to reinstalled GPMC on a domain controller before.  Do you have a procedure to do this?  On a related, note, I am running GPMC directly from the PDC not from a workstation.

    Any assistance is appreciated.

    Friday, May 22, 2015 2:10 PM
  • On Windows Server, you would use Server Manager -> Roles & Features -> Features -> RSAT -> AD DS and LDS Tools

    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Saturday, May 23, 2015 8:37 AM