none
Mail-enabled public folders not receiving external mail.

    Question

  • Greetings,

    I need some help with a situation that has been ongoing for the past couple of days - All our mail enabled public folders have stopped receiving external mail. Internal works fine.

    Our environment is setup as below:

    - Exchange 2013 CU7 - Version: Version 15.0 (Build 1044.25)

    Public Folder created > "Showroom" > under one subfolder from the root

    • Mail      Enabled: YES
    • SMTP      Address configured: YES
    • Mail      Flow Settings    
      • Accept       Messages from: All senders
      • Require       that all senders are authenticated: False
      • Reject       messages from: {}
    • ExternalEmailAddress:     
    • RequireSenderAuthenticationEnabled:      False
    • Folder      Permissions:    
      • Myself:       Owner
      • Default:       Author
      • Anonymous:       Contributor

    Any assistance would be highly appreciated.

    Thank you!


    Carlos

    Tuesday, February 23, 2016 5:55 PM

Answers

  • So Telnet messages do get delivered.

    Carlos


    That indicates its not an Exchange issue. Check your anti-spam solution again or gateway SMTP servers.

    Blog:    Twitter:   

    Thursday, February 25, 2016 2:53 AM

All replies

  • Make sure that the folder doesn't have any restrictions.

    https://technet.microsoft.com/en-us/library/aa998824(v=exchg.160).aspx

    https://technet.microsoft.com/en-us/library/bb123707(v=exchg.160).aspx

    https://technet.microsoft.com/en-us/library/bb124772(v=exchg.160).aspx

    Check the SMTP queues to see if the public folder mail is being held up.  Make sure that the mailbox databases hosting the public folder mailboxes are mounted.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Tuesday, February 23, 2016 6:38 PM
    Moderator
  • Hi Ed,

    Thank you very much for your response.

    - The folders do not have any restrictions, all settings look normal (they were still working as of last week)

    - There's nothing in the queues pointing to public folders.

    - All databases hosting PFs are mounted.

    At this point I'm contemplating perhaps re-creating the PF (delete then recreate)

    Thank you!


    Carlos

    Tuesday, February 23, 2016 7:26 PM
  • Before doing that, try mail-disabling the PF (Disable-MailPublicFolder), then mail enabling it (Enable-MailPublicFolder) and setting the e-mail address (Set-MailPublicFolder).

    You don't have an antispam filtering server, appliance or service that might be blocking it, do you?


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!


    Tuesday, February 23, 2016 7:29 PM
    Moderator
  • Hi Ed,

    I tried disabling and enabling the PF in Mail Settings (twice) - No luck!

    The disturbing part for me is there's no NDRs returned from all the test mails I have sent from my Gmail and Hotmail accounts. Nothing in the queues, and message tracking returns no results too.

    We use Proofpoint for antispam, but my searches there also show nothing.

    Thanks.


    Carlos

    Tuesday, February 23, 2016 8:05 PM
  • Hi Ed,

    I tried disabling and enabling the PF in Mail Settings (twice) - No luck!

    The disturbing part for me is there's no NDRs returned from all the test mails I have sent from my Gmail and Hotmail accounts. Nothing in the queues, and message tracking returns no results too.

    We use Proofpoint for antispam, but my searches there also show nothing.

    Thanks.


    Carlos


    Send a test message to a mail-enabled PF  from your workstation or another server directly to an Exchange Server using telnet on port 25, so you bypass the edge stuff and see if its accepted and gets delivered.

    Blog:    Twitter:   

    Tuesday, February 23, 2016 9:27 PM
  • Hi,

    Have you received any error message on sender side?

    I suggest you try to create a brand-new mail-enabled public folder for test.

    Please refer to the following link:

    https://technet.microsoft.com/en-us/library/jj651147(v=exchg.150).aspx

    Regards,

    David



    Wednesday, February 24, 2016 6:23 AM
    Moderator
  • Thanks for the replies guys,

    Andy - I tried the Telnet thing and in the end I get the following message:

    250 2.6.0 <81ab622bd5da4deea3491b080085d951@ServerName.Domain.local> [InternalId=3
    8740605009950, Hostname=ServerName.Domain.local] Queued mail for delivery
    451 4.7.0 Timeout waiting for client input

    David - I do not receive any error messages or NDRs, which is worrying. I created a brand new mail-enabled PF from scratch and the same thing happens - Still not receiving external mail from the PF.


    Carlos

    Wednesday, February 24, 2016 4:12 PM
  • So Telnet messages do get delivered.

    Carlos

    Wednesday, February 24, 2016 10:00 PM
  • So Telnet messages do get delivered.

    Carlos


    That indicates its not an Exchange issue. Check your anti-spam solution again or gateway SMTP servers.

    Blog:    Twitter:   

    Thursday, February 25, 2016 2:53 AM
  • Try this in powershell

    Add-PublicFolderClientPermission -Identity "\publicfoldername" -User "Anonymous" -AccessRights CreateItems


    I know you have it set to Contributor, as did I, but this resolve my issue.
    • Proposed as answer by Sortileger7678 Wednesday, March 15, 2017 10:18 PM
    • Edited by Sortileger7678 Wednesday, March 15, 2017 10:21 PM Elaboration
    Wednesday, March 15, 2017 10:17 PM