none
Issue with MMS Snap-in Console in Workbench

    Question

  • Hi,

    I am installing a new MDT server for the company I work for. I've choosen a Windows 2016.

    I have installed the adksetup.exe and the MicrosoftDeploymentToolkit_x64.msi and restarted.

    I am able to create my new DeploymentManagerShare en a secondary drive (D:). Everything seems to be working. But when I want to do go to properties or to add an application / Tasksequence) I get a MMS Snap IN error with the following error :

    FX:{ffb8695a-66b4-4929-abb6-15cb8bd2ae3d}

    Exeception type : System.IO.DirectoryNotFoundException

     at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
       at System.IO.FileSystemEnumerableIterator`1.CommonInit()
       at System.IO.Directory.GetFiles(String path)
       at Microsoft.BDD.Core.DeploymentTools.GetFeaturePacks(String platform, String deploymentSharePath)
       at Microsoft.BDD.Workbench.DeployWindowsPE.RefreshData()
       at Microsoft.ManagementConsole.SnapInBase.ProcessNotification(Notification notification)
       at Microsoft.ManagementConsole.NamespaceSnapInBase.ProcessNotification(Notification notif)
       at Microsoft.ManagementConsole.Internal.SnapInClient.Microsoft.ManagementConsole.Internal.IMessageClient.ProcessNotification(Notification notification)
       at Microsoft.ManagementConsole.Internal.IMessageClient.ProcessNotification(Notification notification)
       at Microsoft.ManagementConsole.Executive.SnapInNotificationOperation.ProcessNotification()
       at Microsoft.ManagementConsole.Executive.Operation.OnThreadTransfer(SimpleOperationCallback callback)

    I've tried to uninstall the ADK and the MDT and reinstall. Still the same issue. I have tried with DotNet3.5 installed also but no differences. 

    Do someone have an idea about my issue ? A way to work around or to resolve deffinitively the issue.

    Thank you for you time. Have a nice weekend.

    Best Regards,

    John

    Friday, November 9, 2018 3:11 PM

All replies

  • Had the same problem when I updated my exisiting installation to the newest ADK & MDT. For some inexplicable reason they removed the WinPE component from the normal ADK installer...
    It's a separate "addon" now.

    Install this after you installed ADK and it works:

    https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/winpe-add-packages--optional-components-reference

    • Proposed as answer by bonk3rs Friday, November 16, 2018 2:31 PM
    Friday, November 16, 2018 2:27 PM