none
After Windows Update Sharepoint Site Stopped CA is also not working

    Question

  • Hello All SP Gurus - After Windows update (Windows Server 2012), SP (version - 15.0.4420.1017) 2013 site stopped working. When I tried to browse Center Admin site, I am getting following error.

    Derived method 'RequiresWebPartClientScript' in type 'Microsoft.SharePoint.Taxonomy.TermProperty' from assembly 'Microsoft.SharePoint.Taxonomy, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' cannot reduce access. 

    Update - Tried to run the SP Configuration Wizard which end up with the following error.

    The windows update ran are KB4012220 and KB3102429

    Does anyone know what went wrong and what should I do? I did google but couldn't find anything that help.

    Thanks & Regards,


    Khushi



    Monday, April 10, 2017 5:03 PM

Answers

  • Hi Khushi,

    Run the PowerShell commands below:

    Stsadm -o execadmsvcjobs
    stsadm -o setproperty -pn command-line-upgrade-running -pv No

    Then refresh SharePoint:

    IISreset
    net stop sptimerv4
    net start sptimerv4
    

    Run the wizard with PowerShell command:

    Psconfig.exe -cmd upgrade -inplace b2b -wait -force

    More information reference:

    https://social.technet.microsoft.com/wiki/contents/articles/30838.psconfig-wizard-fails-after-you-install-any-update-on-sharepoint-server.aspx

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, April 13, 2017 1:41 AM

All replies

  • Hi Khushi,

    For your issue, firstly, clear the SharePoint configure cache and then run the SharePoint Product Configuration Wizard again to check if the issue exists. Reference:

    https://gallery.technet.microsoft.com/office/SharePoint-2010-2013-21f55320

    Besides, check the configure log mentioned in the SharePoint Product Configure Wizard and ULS log, find if there any detailed error message to troubleshoot this issue.

    Best regards,

    Grace Wang



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, April 11, 2017 6:48 AM
  • Thank you Grace but I couldn't find any error other than "a TaskDriverEventHandler: TaskDriverEventArgs.EventCriticalityType error, TaskDriverEventArgs.EventType stop, message Configuration of SharePoint Products failed.  Configuration must be performed before you use SharePoint Product" I checked the link that you provided. I couldn't locate Cahce.ini file and there were no XML file in the "%SystemDrive%\ProgramData\Microsoft\SharePoint\Config\"

    Any thoughts?


    Khushi

    Tuesday, April 11, 2017 7:51 PM
  • Hi Khushi,

    If the SharePoint Configuration Cache folder, along with the cache.ini file goes missing, SharePoint Timer Service will fail.

    Try to create the cache.ini file, create a folder named GUID under [SharePoint InstallDrive]\ProgramData\Microsoft\SharePoint\Config\ -> create a file named it Cache.ini ->edit this file and key in value “1” then save it.

    More information and steps refer to the article below:

    https://thesharepointfarm.com/2014/02/configuration-cache-folder-goes-missing/

    Restart the SharePoint Timer Service and run the SharePoint Configure Wizard again.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, April 12, 2017 1:43 AM
  • Thanks Grace. So, I was able to create the GUID folder and Cache.ini. Guid folder was populating with XML files.

    SPAdmin4, SPSSearchHostController, SPTimerV4 and FIMSynchronizationService Services are Stopped. When tried to start except the FIM, they all are keep stopping. No error in Event log Viewer that could help. Just a below error in PSCDiagonistics file

      Leaving function PsconfigBaseForm.TaskDriverEventHandler
    04/12/2017 12:46:55  8  INF                  Leaving function TaskDriver.FireOnTaskDriverEvent
    04/12/2017 12:46:55  8  INF                Leaving function TaskDriver.OnTaskDriverStopping
    04/12/2017 12:46:55  8  INF              Leaving function TaskDriver.ExecuteTasks
    04/12/2017 12:46:55  8  ERR              One or more configuration tasks has failed to execute
    04/12/2017 12:46:55  8  INF              Entering function TaskDriver.Stop
    04/12/2017 12:46:55  8  INF                Entering function StringResourceManager.GetResourceString
    04/12/2017 12:46:55  8  INF                  Resource id to be retrieved is PostSetupConfigurationFailedEventLog for language English (United States)
    04/12/2017 12:46:55  8  INF                  Resource retrieved id PostSetupConfigurationFailedEventLog is Configuration of SharePoint Products failed.

    Even W3SVC stopped after sometime. I reset the IIS, didn't work. I reboot the server, didn't work. Of course, SP Config Wizard is not running to complete. 

    Any clue?


    Khushi



    Wednesday, April 12, 2017 5:55 PM
  • Hi Khushi,

    Run the PowerShell commands below:

    Stsadm -o execadmsvcjobs
    stsadm -o setproperty -pn command-line-upgrade-running -pv No

    Then refresh SharePoint:

    IISreset
    net stop sptimerv4
    net start sptimerv4
    

    Run the wizard with PowerShell command:

    Psconfig.exe -cmd upgrade -inplace b2b -wait -force

    More information reference:

    https://social.technet.microsoft.com/wiki/contents/articles/30838.psconfig-wizard-fails-after-you-install-any-update-on-sharepoint-server.aspx

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, April 13, 2017 1:41 AM
  • Thanks Grace. It worked. Now everything is working fine. Really appreciate your help.

    Best Regards,


    Khushi

    Friday, April 14, 2017 4:47 PM