none
Cannot find APPID key in DCOM Config (Error 10016 fix fail) RRS feed

  • Question

  • The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID

    {6B3B8D23-FA8D-40B9-8DBD-B950333E2C52}
    and APPID
    {4839DDB7-58C2-48F5-8283-E1D1807D0D7D}
    to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

    I tried changing the file owner to both keys to Administrators, even using a Powershell code which worked, ticked both SYSTEM and Administrators with Full Control, and did the same thing for RuntimeBroker which had the SID {9CA88EE3-ACB7-47c8-AFC4-AB702511C276}. I did so for both HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Classes\AppID\{9CA88EE3-ACB7-47c8-AFC4-AB702511C276} and the \CSID\ file.

    Without a fix for this error, my HP computer is having a hard day with a sudden shutdown every time this error junk load stream occurs. Every 10-20 minutes or so.

    The APPID number {4839DDB7-58C2-48F5-8283-E1D1807D0D7D} is not in the DCOM config registry found in the dcomcnfg Events Manager.

    Someone help. The only DCOM 10016 solution I see all around google is editing the DCOM config registry and even the RuntimeBroker and APPID SIDs are not the same.

    I could neither edit the other SID in regedit after the permission granted. Even with the SetACL.exe extension.

    No SIDs found in the corresponding SYSTEM event.

    Specs: Windows 10 Professional x64, HP Elitebook 8440p, i7-3610QM,  M520 8GB 2.4Ghz




    • Edited by Teiu Monday, November 2, 2020 1:52 AM
    Monday, November 2, 2020 1:49 AM

All replies