none
Offline MDT deployment - Rules not taking effect RRS feed

  • Question

  • I am seriously inexperienced with MDT but I am trying to build an image which has everything within the ISO image itself. I have accomplished importing applications and getting them to install silently. I am now trying to find a way of skipping certain aspects of welcome stage when you have to choose things like Bitlocker, admin password and things like that.

    At the moment the rules i have set will not take effect and skip the specified options. I am wondering whether this is due to the bootstrap.ini attempting to connect the my deployment share, which i do not want to happen.

    Currently this is what the Bootstrap.ini looks like.

    [Settings]
    Priority=Default

    [Default]
    DeployRoot=\\DESKTOP-AGSIBB9\MDTBuildLab$

    I do not want any connection at all between the PC i am installing windows on and the deployment share. I would like it completely separate and for it too take everything from the USB it is booting from.

    This is the Customsettings.ini which i want it too use.[Settings]
    Priority=Default
    Properties=MyCustomProperty

    [Default]
    OSInstall=Y

    SkipAppsOnUpgrade=YES
    SkipCapture=YES
    SkipAdminPassword=YES
    SkipProductKey=YES

    SkipDeploymentType=YES
    DeploymentType=NEWPC

    SkipDomainMembership=YES

    SkipTaskSequence=YES
    TaskSequenceID=TEST

    SkipComputerName=YES
    OSDComputerName=%INTLON0001%

    SkipPackageDisplay=YES
    LanguagePacks001={3af4e3ce-8122-41a2-9cf9-892145521660}
    LanguagePacks002={84fc70d4-db4b-40dc-a660-d546a50bf226}

    SkipLocaleSelection=YES
    UILanguage=en-GB
    UserLocale=en-GB
    KeyboardLocale=0809:00000809

    SkipTimeZone=YES
    TimeZoneName=GMT Standard Time

    I am skipping domain membership for the moment while testing aswell as Bitlocker and several other aspects which require connection to the network. 

    I hope this has explained well enough. I would appreciate any help as I have been pulling my hair out over this.

    Many thanks,

    Liam


    • Edited by Liamsy11 Monday, August 8, 2016 11:59 AM
    Monday, August 8, 2016 11:50 AM

Answers

  • I found the answer, when you are creating a bootable media to use without using a deployment share you edit the customsettings.ini and bootstrap.ini on the media you are creating by right clicking and selecting properties on your media. You are then greeted with the familiar rules tab. Thanks for you help, I'm sure you knew this already though and I was being a bit of an idiot.
    • Marked as answer by Liamsy11 Monday, August 8, 2016 4:03 PM
    Monday, August 8, 2016 4:03 PM

All replies

  • Remove the DeployRoot variable from your Bootstrap.ini then right click on your deployment share and select update your deployment share and regenerate boot images.  Then rebuild the media.  Assuming everything else is good on your USB media, it should boot from that and use the customsettings.ini from there instead of the one on the deployment share.

    • Proposed as answer by Wolverine58 Wednesday, September 26, 2018 7:45 PM
    Monday, August 8, 2016 12:51 PM
  • I removed the DeployRoot variable but still the options remain. Can you give me an example of what the Bootstrap.ini should look like for my scenario. Also would you be able to provide an example customsettings.ini as well.
    Monday, August 8, 2016 2:55 PM
  • I found the answer, when you are creating a bootable media to use without using a deployment share you edit the customsettings.ini and bootstrap.ini on the media you are creating by right clicking and selecting properties on your media. You are then greeted with the familiar rules tab. Thanks for you help, I'm sure you knew this already though and I was being a bit of an idiot.
    • Marked as answer by Liamsy11 Monday, August 8, 2016 4:03 PM
    Monday, August 8, 2016 4:03 PM
  • It does throw a person off because the ini files are different than your share.

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    Monday, August 8, 2016 5:23 PM
    Moderator
  • This is the answer. As a matter of fact this was a technical question I was given on a job interview. It is a well known issue that happens when creating offline MDT media. You must remove the DeployRoot variable from the bootstrap.ini file. 
    Wednesday, September 26, 2018 7:48 PM