locked
SCOM and GW Server (Agent Installation) RRS feed

  • Question

  • There is a way to install SCOM Agent by SCOM Console, choosing GW server as Management Server? Or I can install SCOM Agent in untrusted domain only manually?

    I have a untrusted domain, with a GW Server, all working fine, but I have many servers to install SCOM Agent in same domain that GW Server. Install manually will by very hard for me.

    • Edited by JRSCE Wednesday, September 29, 2010 9:28 PM typo
    Wednesday, September 29, 2010 9:21 PM

Answers

  • Sorry for late answare.

    In the Computer and Device Management Wizard - Auto or Advanced your chose your GW, on Discovery Method you chose Browse for...., on Administrator Account you fill in an account that has permissions to install and also manually type the domain that you are installing in. It will give you a warning that it can't verify the account, but that is all good..

    This is also how I do when using a console that is not in the domain...


    mats.w | www.opsmode.com | Please mark this answer as helpful if it helped you.
    • Marked as answer by JRSCE Tuesday, October 12, 2010 11:39 AM
    Tuesday, October 12, 2010 9:56 AM

All replies

  • You may want to take a look at http://blogs.technet.com/b/smsandmom/archive/2008/05/21/opsmgr-2007-how-to-enable-ad-integration-for-an-untrusted-domain.aspx, which discusses enabling AD Integration for an untrusted domain.

    If AD Integration is set up and you have Configuration Manager, you should be able to deploy the agent as a ConfigMgr package.

    Disclaimer: I personally have not tested this.

    • Proposed as answer by Nicholas Li Friday, October 1, 2010 7:02 AM
    • Marked as answer by Cleber Marques MSFT Monday, October 11, 2010 11:21 PM
    • Unmarked as answer by JRSCE Tuesday, October 12, 2010 11:39 AM
    Thursday, September 30, 2010 5:52 AM
  • If you chose the GW as MS in the discovery and give install privileges in the untrusted domain, you will be able to install agents.


    mats.w | www.opsmode.com | Please mark this answer as helpful if it helped you.
    • Proposed as answer by Nicholas Li Friday, October 1, 2010 7:02 AM
    Thursday, September 30, 2010 7:03 AM
  • Additionally, I would like to share the following with you for your reference:

     

    Gateways and agents in untrusted domains/workgroups

    http://blogs.msdn.com/b/steverac/archive/2008/10/03/gateways-and-agents-in-untrusted-domains-workgroups.aspx

     

    Hope this helps.

     

    Thanks.


    Nicholas Li - MSFT
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, October 1, 2010 7:27 AM
  • You may want to take a look at http://blogs.technet.com/b/smsandmom/archive/2008/05/21/opsmgr-2007-how-to-enable-ad-integration-for-an-untrusted-domain.aspx, which discusses enabling AD Integration for an untrusted domain.

    If AD Integration is set up and you have Configuration Manager, you should be able to deploy the agent as a ConfigMgr package.

    Disclaimer: I personally have not tested this.


    Hi Kerrie, but no way to usa SCOM Console to do this?
    Friday, October 1, 2010 12:45 PM
  • If you chose the GW as MS in the discovery and give install privileges in the untrusted domain, you will be able to install agents.


    mats.w | www.opsmode.com | Please mark this answer as helpful if it helped you.

    OK Mats, but when I choose GW server as MS in Discovery Wizard, I cant choose GW Server domain. So this don't work.
    Friday, October 1, 2010 12:46 PM
  • Additionally, I would like to share the following with you for your reference:

     

    Gateways and agents in untrusted domains/workgroups

    http://blogs.msdn.com/b/steverac/archive/2008/10/03/gateways-and-agents-in-untrusted-domains-workgroups.aspx

     

    Hope this helps.

     

    Thanks.


    Hi Nicholas, thanks for this info, but my GW Server are working fina, all my Agent/GW managed agents are reporting good. But I want to install my next agents using SCOM Console in untrusted domain.
    Friday, October 1, 2010 12:48 PM
  • If you have "many agents to install" I'm trying to understand why you want to do this through the console. Using a Configuration Manager package would automate this and make it a faster process.
    Wednesday, October 6, 2010 6:02 AM
  • I'm trying to understand why it is necesary for you to use the console?
    Wednesday, October 6, 2010 6:03 AM
  • Sorry for late answare.

    In the Computer and Device Management Wizard - Auto or Advanced your chose your GW, on Discovery Method you chose Browse for...., on Administrator Account you fill in an account that has permissions to install and also manually type the domain that you are installing in. It will give you a warning that it can't verify the account, but that is all good..

    This is also how I do when using a console that is not in the domain...


    mats.w | www.opsmode.com | Please mark this answer as helpful if it helped you.
    • Marked as answer by JRSCE Tuesday, October 12, 2010 11:39 AM
    Tuesday, October 12, 2010 9:56 AM
  • Sorry for late answare.

    In the Computer and Device Management Wizard - Auto or Advanced your chose your GW, on Discovery Method you chose Browse for...., on Administrator Account you fill in an account that has permissions to install and also manually type the domain that you are installing in. It will give you a warning that it can't verify the account, but that is all good..

    This is also how I do when using a console that is not in the domain...


    mats.w | www.opsmode.com | Please mark this answer as helpful if it helped you.

    No problem Mats, you have solved my problem, thank you so much, this works like a charm.

     

     

    If you have "many agents to install" I'm trying to understand why you want to do this through the console. Using a Configuration Manager package would automate this and make it a faster process.


    Sorry Kerrie, but I don't have SCCM in my environment.

    Tuesday, October 12, 2010 11:38 AM