locked
ForeFront no longer on laptops RRS feed

  • Question

  • Hi, having an issue with ForeFront on several of our laptops.  This morning several laptops were reporting that no antivirus is installed.  The error wasnt there yesterday.  We use ForeFront client security pushed out via WSUS.

    The laptops all have 1 update waiting to be installed which is ForeFront, however installing updates gives the error:

    Some updates were not installed. Error(s) found: Code 666 Windows Update encountered an unknown error.

    I have successfully reinstalled forefront by running the msi manually on the effected machines, however I am concerned that something could be on my network disabling antivirus.

    Is there anything else I can do to see why this could be happening?

    Thursday, March 10, 2011 1:30 AM

Answers

All replies

  • I have the same issue on my Thinkpad W510 laptop at the moment.The OS also reports that there's no antivirus installed. I think it might have something to do with Windows 7 SP1 installation (I just installed this too, and since then I have the problem).

    I'll try reinstalling Forefront Client Security, I hope that fixes the problem. Meanwhile, any help will be highly appreciated!

    Best regards,
    D.

    Thursday, March 10, 2011 7:57 AM
  • Yep, reinstalling FCS seemed to resolve my problem.

    I can't confirm, but it seems that when the windows update is installing this update, you must be connected to the corporate FCS server! If you're not, you might get the error showing. I'm not sure if this is the solution (can't verify it now since I do not see the error), but if you're getting this error, try ensuring that you're on your corporate network and retry!

    Good luck!
    D.


    Best regards, D.
    Thursday, March 10, 2011 8:53 AM
  • Thursday, March 10, 2011 1:11 PM
  • I found that in the C:\Program Files\Microsoft Forefront\Client Security\Client\Logs\FCSSSA.log it said the error was because a program was already installed.  I went in to Control Panel, Add and Remove Programs and removed the Forefront Client Security State Assessment.  Then it let me run the update and now my notebook is back to normal. 
    • Proposed as answer by Druidic Friday, March 25, 2011 11:13 PM
    Thursday, March 10, 2011 2:08 PM
  • Only seems to affect machines with SP1.
    Thursday, March 10, 2011 3:25 PM
  • We had this error on Windows 7 with and without SP1, maybe this will be help?

    -> KB2508833

    Thursday, March 10, 2011 7:12 PM
  • This has now been updated with the full, sorry tale:

    http://blogs.technet.com/b/clientsecurity/

    • Marked as answer by Miles Zhang Monday, March 14, 2011 2:02 AM
    Friday, March 11, 2011 11:03 AM
  • This corrected the issue for us on Windows 7 Client that were recently updated with SP1 after the March Updates.
    D
    Friday, March 25, 2011 11:14 PM