locked
App-v Dependencies don't function on some PC RRS feed

  • Question

  • Hi,

    I had created 2 package with dependencies, MS office 2007 & Ibroker. I'm using this Ibroker software to export reports to Excel. this 2 package had push down to more than 30 PC, 2 of the PC had try using different user profile to log in but seem like it is unable to find or communicate with my office 2007 package using dependencies or not even a locally installed office 2007. 

    I had try to clear all the temp app-v file on both administrator and inside user profile but still the same. Is there any ways to troubleshoot?? i dont wish to reformat(many user data and configuration) as i know it mostly will work after format.

    Thursday, March 3, 2011 3:12 AM

Answers

All replies

  • Hello,

    See this article which log-files exists

    http://technet.microsoft.com/en-us/library/cc817103.aspx


    /Znack
    Thursday, March 3, 2011 6:40 AM
  • Hi Znack,

     

    Thanks for reply....

    The following log receive. had compare this log with another workable PC, both had the same error.

     

    [03/03/2011 14:18:01:243 SRVC INF] {tid=11BC}
    ---- The Application Virtualization Client Service version 4.6.0.1523 has started ----


    [03/03/2011 14:23:04:523 SWAP WRN] {tid=12FC:usr=}
    Could not load OSD file DefaultApp.osd


    [03/03/2011 14:23:04:543 AMGR INF] {tid=12FC:usr=}
    The app manager could not create an application from 'DefaultApp.osd' (rc 0C405564-00000002).


    [03/03/2011 14:23:19:406 MIME INF] {tid=12FC:usr=}
    Updated MIME information from


    [03/03/2011 14:25:58:138 ???? INF] {tid=13E4:usr=}
    CVirtualRegistry::UploadSection9: Sec9 WOW64 Redirection Successfull.


    [03/03/2011 14:25:59:152 ???? INF] {tid=13E4:usr=}
    An error occurred while opening the virtual registry (section: 9), rc: 07B01F0C-0000004A


    [03/03/2011 14:25:59:183 SWAP INF] {hap=17:app=i-Broker 64:tid=13E4:usr=}
    Elapsed time for upload: 1.45 seconds


    [03/03/2011 14:26:03:149 SWAP INF] {hap=17:app=i-Broker 64:tid=13E4:usr=}
    Elapsed time for launch: 7.207 seconds


    [03/03/2011 15:10:00:612 SWAP INF] {hap=18:app=i-Broker 64:tid=A8C:usr=}
    Elapsed time for upload: 0.0 seconds


    [03/03/2011 15:10:02:431 SWAP INF] {hap=18:app=i-Broker 64:tid=A8C:usr=}
    Elapsed time for launch: 1.903 seconds

    Thursday, March 3, 2011 7:40 AM
  • Hello,

    Is your application related to DefaultApp?
    /Znack
    Thursday, March 3, 2011 7:43 AM
  • Hi Znack,

     

    Sorry, how can i find out is the application related to DefaultApp?

    Thursday, March 3, 2011 7:53 AM
  • Hello,

    You only have two errors in the entire log. One is harmless and described here;

    http://www.mitoonline.net/appv/?p=20

    The other one relates to the inability to load DefaultApp. As there are no errors  apart from the log - everything would work fine unless your application has a depency configured for DefaultApp. Considering that you can not answer this, its most likely not. 

     

    You can review this documentation how the connection is done and then you can verify your package and see if it is dependt on DefaultApp.
    http://blogs.technet.com/b/appv/archive/2008/09/24/how-to-dynamically-suite-two-application-packages-using-app-v-4-5-and-dsc.aspx

     


    /Znack
    • Proposed as answer by znack Monday, March 7, 2011 10:56 PM
    • Marked as answer by Aaron.ParkerModerator Saturday, November 17, 2012 11:45 AM
    Thursday, March 3, 2011 7:58 AM