locked
Skype client error connecting Exchange RRS feed

  • Question

  • Hello,

    Due to our setup as we have a shared namespace in Exchange the auto configuration for Exchange done through xml instead of autodiscover URL and that works perfectly ,but that make an issue for skype client as it fails to connect to Exchange as it tries to connect to another Exchange organization (the organization that share the same namesapce)

    Is there anyway to make Skype client use the same way as currently configured on outlook for connecting Exchange?

    Monday, January 13, 2020 1:40 PM

All replies

  • Hi Moataz!

    What is your current environment? On-premise or online?

    Does this issue occur after you making the auto configuration for Exchange through xml?

    What is the meaning of connect to another Exchange organization? Do you mean you have two Exchange Server with shared name space published on public networks?

    Before troubleshooting this issue, please make sure your EWS status is OK in the Skype for Business configuration information. 


    Then you should also confirm that your client is configured for Exchange or Outlook integration.


    Based on my knowledge, Skype for Business connect to exchange by doing a DNS lookup for Autodiscover. Once it connects to Autodiscover it will get back the url for EWS and connect there. So the autodiscover must be configured before you can integrate Skype for Business Server and Exchange Server.

    After the autodiscover service has been configured, you must then modify the Skype for Business Server OAuth configuration settings; this ensures that Skype for Business Server knows where to find the autodiscover service. To modify the OAuth configuration settings in Skype for Business Server, run the following command from within the Skype for Business Server Management Shell. When running this command, be sure that you specify the URI to the autodiscover service running on your Exchange Server, and that you use autodiscover.svc to point to the service location instead of autodiscover.xml (which points to the XML file used by the service):

    Set-CsOAuthConfiguration -Identity global -ExchangeAutodiscoverUrl "https://autodiscover.litwareinc.com/autodiscover/autodiscover.svc"

    In addition to configuring the autodiscover service, you must also create a DNS record for the service that points to the Exchange Server. For more details, you can refer to:

    https://docs.microsoft.com/en-us/skypeforbusiness/plan-your-deployment/integrate-with-exchange/integrate-with-exchange

    Besides, we recommend you use Remote Connectivity Analyzer(https://testconnectivity.microsoft.com/) to test if the connection between them is normal.

    Best Regards,
    Jimmy Yang

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, January 14, 2020 7:17 AM
  • Hi,
    I am checking the status of this case. Please let us know if you would like further assistance.
    Meanwhile, if the reply is helpful to you, please try to mark it as an answer to close the thread, it will help others who encounter the same issue and read this thread.
    Thank you for your understanding and patience!

    Best Regards,
    Jimmy Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, January 28, 2020 12:57 AM