locked
[SOLVED] - Win 7 Enterprise Sysprep Blue screen Stop 0x0000007B (0x7B) Error RRS feed

  • General discussion

  • I'm preparing a fat image for multiple system types.  Applications and updates are installed & configured.  I've copied the various machine specific drivers to

    • C:\Windows\Drivers\<MODEL>.

    From there I added the driver locations to the registry using this command

    • reg add "HKLM\Software\Microsoft\Windows\CurrentVersion" /v DevicePath /d "C:\Windows\Drivers" /t reg_sz /f

    I run sysprep, the machine restarts, begins its configuration process, detects the hardware (and presumably loads the appropriate drivers), then says 'Setup will continue after your system restarts' - or something like that - and from there, the machine is stuck in an endless reboot loop.  At first I thought it was a bad driver, but after eliminating drivers in chunks then getting down to just one driver (audio or video for instance), I knew something else was wrong.

    If I follow the same system build process but exclude the driver copy portion, and also the registry entry above, and then run sysprep, everything is fine.

    I assume my adding of the registry entry is what's causing things to break.

    1. By doing that, am I forcing Windows to *only* look in one location versus the locations it would normally look for drivers?
    2. Is there a typo?

    Should I add other locations to that list like

    • C:\Windows\inf
    • C:\Windows\System32\drivers
    • C:\Windows\System32\DriverStore
    • C:\Windows\System32\DRVSTORE

    For what its worth, the machines are all Dell (Optiplex 755, 760 and 780; Latitude E4300, E6400, D630) and I believe they all use an Intel Chipset and have SATA drives.

     

    Update: I needed to include "%SystemRoot%\inf" as part of the device path
    reg add "HKLM\Software\Microsoft\Windows\CurrentVersion" /v DevicePath /d "
    %SystemRoot%\inf;C:\Windows\Drivers;" /t reg_expand_sz /f

    • Changed type Dale Qiao Monday, June 21, 2010 1:27 AM sharing
    • Edited by JuliusPIV Wednesday, February 16, 2011 12:57 PM
    Friday, June 18, 2010 6:02 PM

All replies

  • You rock.

    thanks for sharing.

    Sunday, June 20, 2010 7:46 PM
  • Hi,


    Thanks for sharing your experience in Microsoft TechNet Forum. It does a great help to community users who comes across with this kind of issue.

     
    Have a nice day.
    Thanks.

    Monday, June 21, 2010 1:42 AM
  • Hi,

    I am exactly in the same situation, i have 4 different models of machines.

    - Did you included mass storage drivers for all the machines ?

    - What are the parameters to use with sysprep ?

    - What is the exact build process u have used because i can't figure out waht was edited

    in your post.

     

    Thanx in advance

    Tuesday, July 27, 2010 3:25 PM
  • I needed to include "%SystemRoot%\inf" as part of the device path
    reg add "HKLM\Software\Microsoft\Windows\CurrentVersion" /v DevicePath /d "
    %SystemRoot%\inf;C:\Windows\Drivers;" /t reg_expand_sz /f

    Wednesday, February 16, 2011 12:57 PM